Help us improve accessibility of our game Idle Crafting Kingdom

iOS & iPadOS Gaming

Hi everyone,

I'm one of the developers of the game Crafting Kingdom.
We just released the game today and we would love to know what you think, especially in terms of the game's accessibility.

The game focuses a lot on crafting resources, producing goods and then selling them.
You start out small, chopping logs in your lumberyard. Eventually you will work your way up unlock new products, buy new buildings and production facilities which allow you to produce more valuable goods.
You can also build out your own estate, if you have the necessary construction materials.

The game is incremental, which means one of the gameplay mechanics is that you need to restart your progress every now and then to get ahead. You complete quests and earn bonuses like faster production and higher sale prices for your next restart.

The game is free. There are optional ads, but no in-app purchases. The ads are voluntary rewarded videos, which will give you a powerful boost for watching (for example double log production for 10 minutes).

You can find the game here:

We tried to make this game as accessible as possible, but know that there are probably plenty of things that could be better. We would really appreciate some feedback on what could be improved. Any feedback is welcome.

Please note: The game uses Unity and the Unity Accessibility Plugin (UAP), so not all VoiceOver gestures are supported.



Submitted by Michelle on Thursday, October 18, 2018

Hi Ali Colak,
that sounds serious. Could you please send me an email to with your Player ID? Then I can access your game data on our server, see what went wrong and also credit you your gems back.
You can find your player ID at the very bottom of the settings menu in the game's main screen. It's a long string of numbers and text, so if you just want to send a screenshot instead of typing it down character by character, that would work perfectly fine, too.

Submitted by Unregistered User (not verified) on Wednesday, October 24, 2018

The only thing that really affects me is when I don't have Wi-Fi because I can't complete the boost quests or restart the game to collect rewards after I finish completing the quests. Sometimes I have to wait a few hours or days before I can! Anyway, I will just have to find a way to work around it. Other than that, when it comes to watching videos, it has definitely gotten easier. Keep doing what you're doing there. When it comes to gems, I realize that some of mine have disappeared as well. I mean, I don't remember the last time I saved my game progress, I think it was a few days ago, but when I started playing again today, I was redirected to a previous version, and I know I had another version after this one. I'm just a bit confuse right now because I'm not sure what happened. I had about 500 gems, now I only have 10 and I'm not sure if I should continue playing from this version, or do something else.

Submitted by MikeFont on Thursday, October 25, 2018

I haven't had one gem disappear on me yet, but I think I've only been playing lately on wifi.
Question, how soon are we to an update? Thanks so much. Keep up the great work devs! :)

Submitted by Sasha Stride on Thursday, November 1, 2018

I installed this game on my iPad becausre I don't have a phone, wich is irelevant. How do I restore the boost thing I purchased?

Submitted by Paul Martin on Friday, November 2, 2018

In short, all you need to do to restore a purchase of the $5 unlimited boost is to simply run a beost again. In the screen where you are prompted to watch a video, there is a restore button near the bottom.

Submitted by Michelle on Friday, November 2, 2018

Thanks Paul,
you beat me to it. But I heard someone say that there is an issue with the Restore Purchases button not being accessible. I haven't had a chance to check whether this is still the case in the latest version. The button is there, but it might be that it cannot be selected without sighted help. Let me know if you need help.
One of the things I'm changing with the next update is that I can restore the ad-free boosts for players directly on our game server, even if there's an issue with accessibility or with the Apple account being different, Currently, I cannot do that, but the next version will allow me to do that.

Submitted by Sasha Stride on Saturday, November 3, 2018

I was just about to write on here that it did not work but then I realized I already had it. Restored it from backup because I needed a new phone. Sorry for

Submitted by MikeFont on Sunday, December 2, 2018

Hi Michelle, any idea when we might expect an update? I know its a tough time of year with holidays and all, but I've been hoping to hear the end of the video reward notifications for some time. lol
As always thanks for all the teriffic work you do for this community. :)

Submitted by Jessica Diaz on Wednesday, December 5, 2018

A few days ago, I accessed the game to play and I no longer could move around with VO. It just said possible text accessibility mode enabled. I found a play button but double tapping did nothing. When I then turned VO off, I can play with this strange voice and it is super slow. Can anyone tell me what to do to fix this? I did delete and reinstall the game but I am getting the same issue.

Submitted by Paul Martin on Friday, December 7, 2018

There is a setting available within the Voiceover router when using something like this game that allows you to disable what's known as direct touch, which is in this case allowing players to flick and tap the screen without Voiceover getting in the way. Think of it as half like putting the screen reader to sleep if you will. My only guess for this problem is that it somehow got disabled. When next you start the game, attempt to use the voiceover router till you hear it announce "direct touch", at which point you should be able to simply flick up or down. Voiceover should then say on, followed by you suddenly being able to play the game again without disabling Voiceover first!

Submitted by Jessica Diaz on Friday, December 7, 2018

Thanks a million to the guy who suggested the direct touch setting. I have never heard of that. It did fix my issue.

Submitted by Michelle on Friday, December 7, 2018

In reply to by MikeFont

Hi Mike,
I was hoping we'd finish in time, but with the holidays coming up, honestly, I'm sure it will be January before the next update can be released.

Submitted by Kerry Fielding on Monday, April 15, 2019

Hi. I started playing this game when it was initially released back in 2017, however, when it broke sometime ago, I stopped playing. Out of curiosity, I went back last week and discovered that I can now play again. Hurray! However, couple of questions. Firstly, I keep getting notifications about a video reward. When I tap on the video to play it, it comes up with an app for me to download. I go to the App Store, hit cancel and then come back, but don’t seem to get any rewards. Also, I am told that I can open a gem shop, but when I go to open it, all I see are buttons to buy gems et cetera. How do I open the shop? What is its purpose?

Submitted by Jennie A Facer on Monday, April 15, 2019


What you do for the video rewards is when the video is done playing, touch the very top right hand side of the screen and then double tap. This will give you one gem. A second video reward will give you two more doing the same thing with the top right-hand of the screen.

When you open the gem shop, you can purchase gems from there. You can't get them without either purchasing them or viewing the rewards.

Hi. Thanks for the tip about the video reward. As for the shop, I already purchased the welcome gift, but still am unable to open the shop. There doesn’t appear to be an open button anywhere.

Submitted by Ravenpaw on Wednesday, August 21, 2019

Glad to see that this thread is still somewhat active ☺️ First question: has anyone else clicked on an advertisement video and been presented with options to "learn more" (brings up ad history) or close/resume the video (which don't seem to work with VoiceOver)? As far as I know the only ways to exit that screen are to either restart the app completely or to report the ad through the history panel. Second question: am I the only one who thinks the product unlock costs for armor and weapons should be reversed?

Submitted by KE7ZUM on Wednesday, August 21, 2019

Got a quick problem. I reinstalled the game as I thought that would help fix my issue. My issue, the load to cloud option was dimmed. Crap. Oh well. But the reason I uninstalled and reinstalled as I can't restore my purchases of my boost and other things I bought. I am signed into the app store but i've ben having this issue since ios 12.

Submitted by KE7ZUM on Thursday, August 22, 2019

For anyone who wants a screenshot to see what I mean, there it is. I see no way to get the boost thing if I did not get this 2 years ago, and if I did I see no way to restore the purchase. Someone suggested I check to see if I'm signed into the app store. I sure am as I'm able to get apps, pay for stuff, etc.

Submitted by Hilary Reed on Monday, September 2, 2019

I am so glad I found the above comment. I’ve been struggling with a Game of Thrones Conquest add for about 10 minutes or so, counting all of the times it has appeared haha.

Submitted by Michelle on Tuesday, September 24, 2019

I just found your post in another thread. Could you send me your player ID via PM or email ( I can probably restore your purchases on the server manually if somehow the game doesn't recognize you.

The new iOS version changed the way games recognize when they are being reinstalled. Before, as long as you reinstalled it on the same device, the games would immediately be able to recognize this and automatically connect you to your old game account (an account which is otherwise anonymous). But with the new iOS, the device ID used for this is no longer unique. A lot of games that have used this in the past are now struggling to solve this issue. We're working on this too, but don't have a solution yet.
Here's the email, in case you don't have it:

Submitted by Bobbi on Wednesday, October 30, 2019

Hi there, since updating to iOS 13.2, I can no longer find the option to close the video ads used for obtaining gems. When the ad finishes playing, I can read the question that asks if you want to close the video, and it says I'll lose the reward if I do so, but double tapping on close video or resume video doesn't do anything. The only way I can get out of ads now is to kill the app in Appswitcher, and I am no longer able to get gems as a result. Has anyone else experienced this?

Submitted by KE7ZUM on Thursday, October 31, 2019

I've seen this since ios 13.0 beta. And also I'm still having my little issue of the in app purchases thing but I'm not worried, I'll just I guess use my gems for the boosts.

Have you been able to work through the ad issue at all? I must admit, it was awfully jarring to find I couldn't close ads considering how often I play. Watching ads for gems has become as much a part of gameplay as anything else, and I find my whole flow interrupted as a result. The game is, at this point, not nearly as playable for me. I could play without obtaining more gems, I suppose, but I've gotten so use to responding to the video reward notifications that the transition is going to be difficult at best.

Submitted by Ashleigh Piccinino on Thursday, October 31, 2019

I have commented on this game twice, of course, editing my first comment on the review page for the App store. I've deleted the game today as it's too boring for me. if you didn't see my review, and it might've been a little sloppy, here's what I said. I'd like the game to be like the Legend of Zelda games where you can actively talk to people, of course, using the whatever those Zelda games use for that. find out what people in the city need before crafting a bunch of resources you won't probably use in your estate deed. have the game have better music as the stuff there is kind of boring after a while. plus, I think, if you look at games like "A Blind Legend" you'll find that self-voicing the game--not with unity but with the game's actors--of course, hired and all--would be good. Also, like in "A Blind Legend" iPhone users who are visually impaired should be able to swipe around, finding their own way to the farm and lumber yard, just by the sounds of those plants they here/which direction the're in. Axes can be used for more than chopping logs, but let's keep it kid friendly here. I wish the sounds in the current game, for example cutting meat and harvesting grain didn't have the same grain-scooping sound. I also noticed that both VoiceOver and the Unity engine disagreed on things. for example, when you would have one gem left, both screen readers would pluralize that word, not cool in my opinion/other things like that need to be fixed. I'm not an English major, but that's a real turn-off for me to not have proper grammatical useage throughout the game. Also, when we're talking about the grain or coal, are they single pieces or what? on the incrementality thing: I think once you complete a quest, you should be able to click on the "completed" text and earn your reward, no restart needed. there were too many adds to gain gems, and I had to buy the small packages a few times anyway. I think you should keep what you have if a restart is required, so keep what you had from the previous setup--no progress depletion. over all, though, this game is good but needs more adventure stuff for me/you actually walking around/swiping your finger like as in regular VoiceOver gestures, to do things/get somewhere,. This might still be confusing, but it's what I have.
Thank you for a nice game anyway,
Ashleigh Piccinino
P.S. Why I said the things about actually locating places by sound and direction is I'm wanting to become a TVI, and I think that sort of thing, even within game worlds, can help with Orientation and Mobility skills for young students/older ones as well. Plus, people who live in the city might not experience those sounds, lumber yards/farms near as often, so having realistic sounds like that and treating the money/gold coin situation like real-world standards today might teach proper budgetrey habits. One more thing, is this game set in the Industrial Revolution/Medieval Times, when in history, exactly? Maybe, having a newer version, within the same game, for today's standards could also help.

Submitted by Bobbi on Thursday, October 31, 2019

With all due respect Ashley (and I realize I'm not the game developer), I personally feel this comment is overly critical considering how this thing started out. Crafting Kingdom would not be Crafting Kingdom without being exactly how it is at the present time. IF you want something more like Legend of Zelda and with a lot more action, there are other games like that out there that I would suggest you go to instead. This game is meant to be an idle clicker and therefore not extremely intensive to play as a result. There is a game called Pitch Black that is due to come out soon that I would suggest you have a look into. They have a Kickstarter and a playable demo for you to try (at least for the PC), but the game is also going to be cross platform as well so it will be working on iOS and Android when everything's said and done.

Submitted by Bobbi on Tuesday, November 19, 2019

As much as I don't want to do this, I've had to report all the ads I can't close. Even after reporting I continue to see them, however. Not all ads are like this, I've found, but since reporting ads from Robin Hood that's all I've seen now. It's the only way I know to be able to continue without having to actually purchase gems. Yes, there are treasure chests, but at 3 gems per ad session, it's fairly lucrative and I've gained over 2000 gems this way. I hate having to report ads that aren't actually offensive... thank Heaven's there's an option for me to select Other. Not sure what else to do, as not all ads will allow me to close them simply by touching the top right of the screen. Running iOS 13.2.3.

Submitted by Astute Boss Visionary on Wednesday, January 22, 2020

Hey all. Noticed I wasn’t receiving notifications for the game and when I went to check settings, there was no tab for the game under notifications. And, I have uninstalled/reinstalled the game and it does not ask me if I want to allow notifications either.

Submitted by Jessica Diaz on Wednesday, December 2, 2020

So, the new update makes the game look completely different but I actually like it. Will anyone start playing again? Also, can someone just give me a short idea of what direct touch is? Ever since IOS 14, I have to turn this on to play. Happy playing.

Submitted by Tyson Ernst on Friday, December 4, 2020

With the new update, I can no longer collect the quest rewards. First, the dev changed the label to "ascension", and when I double tap it I still receive the normal warnings about resetting the game progress. However, after acknowledging the reset box, I get a "zero" gems screen with the "Okay" button to continue. I have all five quests completed and when the game relaunches, the hint dialogue box states that I have completed a few quests.

This happens repeatedly, to the point I rerolled the least of the quests in an attempt to see if that would unstick the feature to no avail. Is anyone experiencing the same issue? To add to the info, I also upgraded my estate to the highest level of 14 right before attempting to ascend for new quests

I had the same problem but it does work. Do the following. After completing a quest, go through and on where it says won after each quest , double tap. It changes it to active. Then go to the ascend and it will reset. It makes no sense but that is how they did it.

Submitted by Stephen p on Saturday, December 5, 2020

This is a great game, I love it and I’m thankful for it. I can no longer close the advertisements with this new release. Please help thank you

Submitted by Bobbi on Saturday, December 5, 2020

Sadly I too am not able to make any use at all of the video rewards as I cannot close the advertisements without killing the app. While there are gems sometimes found in the treasure chests, I still want the advantage of gaining more gems by watching videos if I'd like, rather than having to pay for packages of gems. At this point, sighted people have a distinct advantage when it comes to obtaining gems now. Were it not for the fact that I can sometimes get gems in treasure chests, I would have deleted the game ages ago. Other than this though, I do enjoy how things are done, though ascension has become a little less intuitive given that you have to click a button labeled with a symbol number 1 in order to obtain the rewards of the quests you've completed. There's nothing that explains anywhere that this is what you need to do. Nor is the button label any kind of indication as to what it does. I was afraid I was accidentally rerolling quests when I tried it out, and luckily I hadn't... this could be worked on in my opinion so that the label explains what the button actually is, and also explain somewhere that you need to click this button in order to get the rewards.

Other than these relatively minor issues, I haven't had any other problems with the game, and I find that I enjoy it overall.

Submitted by Bobbi on Saturday, December 5, 2020

Hi guys, I just wanted to let you know that when you click the button that says 1 near each completed quest, it actually activates the quest. Hence why it gives you of an active status. I completed a quest that resulted in +1 log production, for example, and when I doubled tapped the 1 button near the quest after completing it, it activated it and I was then seeing 2 logs per production slot vs ony the 1 log per slot I had beforehand.

What I don't know yet is if rerolling the quest will get you a new quest so you can complete more quests without having to reset progress or not. I do know that after you ascend though, the rewards you've activated are listed and they will then be active for your next game, and you will get another set of quests to complete.

Submitted by Bobbi on Saturday, December 5, 2020

Hi guys, I just wanted to let you know that when you click the button that says 1 near each completed quest, it actually activates the quest. Hence why it gives you of an active status. I completed a quest that resulted in +1 log production, for example, and when I doubled tapped the 1 button near the quest after completing it, it activated it and I was then seeing 2 logs per production slot vs ony the 1 log per slot I had beforehand.

What I don't know yet is if rerolling the quest will get you a new quest so you can complete more quests without having to reset progress or not. I do know that after you ascend though, the rewards you've activated are listed and they will then be active for your next game, and you will get another set of quests to complete.

Submitted by Ashleigh Piccinino on Saturday, December 5, 2020

In reply to by Ornella

Have you tried that before? I know that if VoiceOver says you’ll lose the reward as you close the video ...I just wanna know that it works first to go act like you’re going to get the game. Sometimes, I cick download just to see what the game’s about/if it’s accessable—most if not all aren’t.

Don’t cut my head off here, but the clicking on questions completed was my idea. That way, you’d know which were and weren’t ... a sort of “checkbox” for the completed quests, if you will. I think it’s a good idea, so don’t bring a headsman to my door, please? Just thought I’d help.

Submitted by Ashleigh Piccinino on Saturday, December 5, 2020

In reply to by Jessica Diaz

Direct Touch is a tricky little item. When using VoiceOver, use your rotor to get to direct touch—it’s to the right of headings. It only activates on games like this and galactic colonies. If you don’t use VO, though/turn VO off when these games are opened, the game’s own vocal engine/accessability mode will allow you to not use direct touch/you can play like normal.

Submitted by Ashleigh Piccinino on Sunday, December 6, 2020

In reply to by Ornella

I’ve tried this, but it doesn’t work for me. I’m using an iPhone 8+, but it still doesn’t work for me. It’s even hard for VoiceOver to get to the “get” button at times/don’t think the ads here work. It’s funny though, you can close out ones from Galatic colonies, though.

Submitted by Ashleigh Piccinino on Friday, February 19, 2021

In reply to by Ornella

I've tried that, but it doesn't work. clearly, the people having the videos out there need more work on their end to make iot accessable to exit. on Lords and Knights, at least, you don't have to exit a video perse, just watch it/close the app and open it again/and your gold is there.

I've been thinking about this for some time, and what if things were different? That is, what if parts of Galactic Colonies and Crafting Kingdom were merged? I'm thinking about how much easier it would be doing the following. Whereas in GC you can tap with two fingers to hear stats like how much money/energy cell you have, you could do the same here. In GC a three finger tap gets you to your colonies base ... from anywhere. What about using that here to get to your city, from anywhere on the map? Of course, the city page would need to open upon your three finger tap. Also, how about using yuour phone's stereo system, both for the cheesey music as well as properly locating your treasure chest--that needs to be louder somehow/heard from everywhere when it appears? The music ... oh yuck! the music needs to change to better reflect this game and/or it needs to be a self-voicing title. I'm sorry to be critical here, but ...