Help us improve accessibility of our game Idle Crafting Kingdom

Forum
iOS & iPadOS Gaming

Hi everyone,

I'm one of the developers of the game Crafting Kingdom.
We just released the game today and we would love to know what you think, especially in terms of the game's accessibility.

The game focuses a lot on crafting resources, producing goods and then selling them.
You start out small, chopping logs in your lumberyard. Eventually you will work your way up unlock new products, buy new buildings and production facilities which allow you to produce more valuable goods.
You can also build out your own estate, if you have the necessary construction materials.

The game is incremental, which means one of the gameplay mechanics is that you need to restart your progress every now and then to get ahead. You complete quests and earn bonuses like faster production and higher sale prices for your next restart.

The game is free. There are optional ads, but no in-app purchases. The ads are voluntary rewarded videos, which will give you a powerful boost for watching (for example double log production for 10 minutes).

You can find the game here:
https://itunes.apple.com/us/app/crafting-kingdom/id1190611967?ls=1&mt=8

We tried to make this game as accessible as possible, but know that there are probably plenty of things that could be better. We would really appreciate some feedback on what could be improved. Any feedback is welcome.

Please note: The game uses Unity and the Unity Accessibility Plugin (UAP), so not all VoiceOver gestures are supported.

Options

Comments

Submitted by Michelle on Monday, December 4, 2017

Hi everybody,
we did a performance update with one of the last patches that we thought would have solved the sluggishness when there are so many slots. The problems most likely stem from the user interface trying to render that many entries.
It seems that at least in combination with VoiceOver this problem still persists, and I will take another look.

Big thank you to Alex Wallis, for pointing me to his cloud save. I downloaded it for testing, so you can update it now. Thank you for waiting!

Submitted by Wren on Friday, December 8, 2017

Hi Michelle,
The focus is very much improved on this beta.

When the number is announced that tells how much metal is left, voiceover says 1.003. I believe it means that I had 1003 metal left. But I don’t know what number represents or what character represents the point. Thank you so much for a great game. Sorry for the errors in this comment but it’s a bad day for posting comments for me :-)
God bless,
Wren Langley
PS I really love this game and I’m grateful to be able to be a beta tester.

Submitted by alex wallis on Friday, December 8, 2017

I have let michelle know about this issue, as well as the fact that when I return to crafting kingdom from another app often the total amount of products I have can take a long time to update from the amount I had when I was last in crafting kingdom. I have also let her know that quite often I am bounced from the world map screen back to the main menu when reopening crafting kingdom even if I leave it on the world map screen.
I really hope that multi tasking gesture support can be sorted out soon as it seriously isn't fun switching apps with the iPhone x, really don't think apples decision to get rid of the home button is a good one.
wren for your information I believe that a decimal point is represented by the period as americans call it or full stop as we say in the UK.

Submitted by Michelle on Friday, December 8, 2017

Hi Wren,
thanks for the report. The number formatting slipped through the cracks. That was a actually fix to make the numbers read correctly with VoiceOver for Europe. The USA is one of the few countries that use a comma to separate thousands, and use a point to separate decimals. I have to manually switch depending on the language, and that's when the mistake happened. The current beta accidentally runs with the European number formatting even for English.
I already uploaded a fix, but it will take a little while for Apple to approve the new beta.

In regards to the multi tasking gesture - I was able to switch apps using a four finger swipe even in the current version of Crafting Kingdom. It seems to me that these gestures are iOS native and not overridden by Unity. It's also not a VoiceOver gesture - this works even when VoiceOver is off. It's probably meant for sighted and blind users alike.

However, the detection seems a little flaky. Sometimes it would work, sometimes it wouldn't. The only gesture that works reliably is the swipe up to the top of the screen to bring up the app switcher.

Submitted by alex wallis on Friday, December 8, 2017

Hi Michelle, that's really weird, for me the 4 finger swipe gesture doesn't work at all in crafting kingdom but it works fine in any other app, so I don't get what is going on there. Is there anything I can do to help track down why this might not be working?

Submitted by Wren on Sunday, December 10, 2017

I have the beta installed on both my iPad and iPhone. I played the game on both and then save both games to the cloud from their devices. Then I played the game on my phone later on. I saved to the cloud, and when I loaded it to the iPad I got the iPad game can someone please tell me how I can get the same game on both devices with the same progress. On the phone game I have gold ore and leather strips both producing. On the iPad game I only had leather strips producing. If you need a better explanation please let me know and I will do my best

Submitted by Jennie A Facer on Sunday, December 10, 2017

In reply to by Christel john

Hi all,

I am a beta tester of Crafting Kingdom. I am having a problem where all of a sudden, my automations and boosts reset on me. They were going for a little while, then they were all gone. My storage filled up once, and then I went to see how many products were in storage, and nothing was there. I tried to use the test flight app to report this directly, and it said this build is no longer available. It is 1.181. Sorry fro those whe have to read this that are not beta testers. Have a blessed day!

Jennie Facer

Submitted by Michelle on Tuesday, December 12, 2017

Hi Jennie,
I removed that build from Testflight, because it was faulty. Testflight should let you update to the latest build though.

Submitted by Clare Page on Wednesday, December 13, 2017

Since I have set my iPhone 6 to update apps automatically, I was pleasantly surprised, after battling with a jamming app this morning, to find later that Crafting Kingdom had updated on my iPhone. The first thing I noticed was that the blacksmith and mine had been swapped round on the world map, which seems logical, as the mine is more expensive to buy than the blacksmith anyway. It's also good to hear VoiceOver read numbers correctly in the quest list, such as 5000000 instead of five zero zero zero zero zero zero. Just after I'd discovered that the game had updated, I restarted automations in all the properties I need to make 5000000 metal parts, the current quest I'm working on, and the performance seemed to have definitely improved at that point. However, when i tried to restart automations later, the whole app jammed up when I went into the quarry, which currently has more production slots in it than the furnace and the blacksmith, while those two could be navigated normally. It wasn't until I restarted my iPhone that I could navigate the quarry and restart all automations there again: I hope that I won't have to restart the phone every time I want to restart automations to continue my quests, especially as I need the quarry for all my remaining quests in my current play-through. I don't know whether these continuing performance issues in Crafting Kingdom are quirks of my three-year-old iPhone 6, so it'll be interesting to see if anyone else still has performance problems with the new version of Crafting Kingdom, regardless of which iPhone they are playing it on.

Submitted by Nicolai Svendsen on Thursday, December 14, 2017

Club AppleVis Member

I started playing this game again a few days ago after a few updates had been released, and unfortunately the gesture to change accessibility mode doesn’t seem to work at all on my iPhone 6s. I also saw in an earlier comment that accessibility mode should turn on by default if VOiceOVer is detected and running, but this doesn’t seem to happen either, so I’m kind of stuck on how to get accessibility mode enabled again.

Any help would be appreciated.

Edit: Seems like reinstalling the app fixed it so that VoiceOver was detected upon launch, although gesture to enable and disable accessibility mode still doesn’t work, unfortunately.

Submitted by Bellsfurmama on Thursday, December 14, 2017

I was already having problems with the game malfunctioning n the quary when trying to move between slots. It will jump all over the place making it impossible to operate, just by opening up the quary. But now, since yesterday’s update, it is no longer working at all. And I just spent over a billion coins adding slots. Please help!

I have tried restarting, disabling then reenabling accessibility mode. Nothing works.

Submitted by Paul Martin on Thursday, December 14, 2017

I can confirm the shortcut for turning on/off the accessibility mode doesn't seem to work on both an iPhone 7 and iPad pro. I even tried turning off Voiceover and going to the options menu, but still no luck there.
As for the focus being beyond buggy: I've been having strange issues on only one device for the past few days which has in fact caused me to lose some of the "gift favor", and I'm now down to 88 percent even though I've been vsiiting that section every day. it simply wouldn't give me a chance to "open gift". With the latest update, the feature to load and save games from iCloud has been introduced to the masses. I'd suggest saving first, uninstalling the game from your device, and reloading it all from the store. The cloud options can be found in the game options menu just before tapping the play button.

Submitted by alex wallis on Thursday, December 14, 2017

if accessibility is working all you people should just leave it alone and not try toggling it on and off if its picked up in the first place. if not turn VoiceOver off then try the gesture remember a lot of VoiceOver gestures don't work in the game. for example the 4 finger swipe gesture for moving apps doesn't work at all for me but does work for michelle which I would very much like to see fixed.

Submitted by DrummerGuy on Thursday, December 14, 2017

In reply to by alex wallis

It is true that I did it only because I wanted to test the gesture. But as for other people, who knows what happened and they had to do it. May I remind you that back when numbers were not being read properly many of us used to turn voiceover off in order to use accessibility mode?

Since yesterday, my ability to navigate in Crafting kingdom has definitely deteriorated. There are only two things which I have consistently been able to do, namely get the gift from the princess and go into the castle to do the usual things there, such as starting boosts, checking how much time I have left in those boosts, and looking at how my quests are progressing. Once in a while I have been able to restart automations, but the app has now started jamming in every property I enter except when visiting the princess and the castle: I even couldn't close the help screen in the city after accidentally opening it because focus jumps around when I'm selling. Reinstalling the app is very tempting right now, especially as in the newest version we can save a game and reload it after a reinstall, but, after reports that the accessibility gesture doesn't work now, I may run the risk of not being able to play after the reinstall. I can't guess why Crafting Kingdom is now jamming like this, but it makes the game impossible to play unless I'm very lucky and get the chance to navigate normally round different properties every so often.

I honestly don’t think that you would have that problem with accessibility mode. In my case, I just wanted to try the gesture and disabled the mode intentionally but, to my surprise, it did not work. However, I just asked my girlfriend to help me enabling the accessibility mode and I had no problem after that. I admit that I haven’t tried it again because, after my last experience, I have decided not to do it until Michelle tells us that accessibility mode can be enabled or disabled safely. Take care and God bless. Happy holidays in advance.

Submitted by alex wallis on Thursday, December 14, 2017

I just sent the following to michelle, thought I would post hear as well in case people want to comment.

Hi Michelle,

unfortunately I have to report performance issues in the latest crafting kingdom beta, they have only just started but look like the same kind of issues as before that I had in the quarry.

This time the issues are in the workshop, I just added my 62nd slot to the workshop, and suddenly VoiceOver started getting slightly sluggish but the workshop was still navigable, however I then went to the slot I had just added, and opened the area to decide what to produce.

I checked belts, then selected to automate, again performance was sluggish and not great but usable.

However once I pressed on automate it took a few taps before the slot automated, and once it did I was unable to tap the back button to get back to the main workshop area, it literally wouldn't respond.

So then I had to terminate crafting kingdom from the app switcher and reopen it, when I did that I went back to the workshop and I found that my newly added slot had lost what I set it to produce the slot was still automated but I had to go back into the production area and select belts again.

I then found that once I did that and tried to go back my focus started jumping around to areas like the sale price or list of produceable items.

Now when I go into the workshop VoiceOver still feels sluggish, and I have found that sometimes when I go into it focus places me on one of the slots rather than where I should be in the window, and when I am flicking down through the production slots sometimes I jump around.

I know the issue is probably to do with rendering things on screen, one thought that occurs to me, is why don't you do away with the produce buttons for all slots? and just make it so that tapping on a slot is enough to start its production, then beside it you could have the select production button as you do now, so that would mean less clutter on screen as well as you would just have the slot then for each one a select production button.

I do also have a small bug I need to let you know about relating to boosts, this is that if you are in the city and have the salesman boosts activated if they run out while you are in the city speech feedback still indicates that things are being sold for the boosted prices although the actual amount things are sold for is correct and back to the non boosted level.

there is also an issue with the lumber yard in that you can see the boost for sharpened ax all the time even when you don't own the lumber yard, I think I reported this to you already.

I have saved my game data to cloud for you to look at, again I will keep saving this game till I am ready to reset but then won't save a fresh game till after you have grabbed my data.

hope you find this useful,

Alex.

Submitted by alex wallis on Saturday, December 16, 2017

well now I just went to add my 71st slot to the workshop and the sluggishness is as bad now as it was in the last beta, the game is so bad that I am lucky if I can scroll to the 71st slot, if I get there I go into select production then focus jumps everywhere and no matter how hard I try I can't tap the automation button focus keeps jumping to the automation cost.
I have saved this game to cloud, but doubtless I will have to wait for automation to run out before I can automate that slot. the latest game is on the cloud for you to grab michelle where this just started happening.
Interestingly I tried going into the workshop without VoiceOver and scrolling works better, still a little sluggish though but better, and I was able to finally automate that slot, it still doesn't feel as snappy as when say I have 20 or 30 slots.

Submitted by Jessica Diaz on Saturday, December 16, 2017

I am so glad I found this forum. I thought I was crazy when I woke up this morning and my game is basically frozen. All I can do is get boosts going and then go to the city to try to sell and or update storage. I also am interested in being a beta tester.
savedbygrace0421@gmail.com

Submitted by Taylor Brown on Saturday, December 16, 2017

I don't have a *lot* of vision, I'm a voiceover user, but the visual portion of this latest update is a little rough.
When I use either the built-in speech or VO with direct touch, the screen looks like it jumps around a lot. Maybe it's a background image thing? The icons seem to be in the right place, but the background sometimes only shows on the right half of the screen, or it has slid down about a sixth of the screen, or slid up, and sometimes they move around as I scroll through the icons. It gives me a little bit of a headache, to be honest.

Submitted by Wren on Sunday, December 17, 2017

Voiceover was stuttering a lot on the cell all tab and was not focusing well. When I opened the beta again today it seems to be OK. On the automations in the lumberyard when I first start they are very expensive. May I please have some suggestions on how to make gold so that I can add the slots? Thank you on the quest does the quest that say to sell 1 million or 2 million of something followers from one game to another?
Thank you for a great game I am so enjoying this game and thank you for letting me be a beta tester.

Submitted by Wren on Sunday, December 17, 2017

could a button be added so that we could quickly flick from the beginning to the end of our slots? Put it work like the castle and a state buttons were when we flick those we are taking quickly to the location? Please and thank you.

Submitted by alex wallis on Sunday, December 17, 2017

well a two finger flick up is enough to take us to the back button so I would say a two finger flick down should jump us to the end of slots or other areas, remember though that its a small team possibly a one man band behind this game so everything can't be done at once, and I would say sorting out stability with large numbers of slots is far more important than other features at the moment.
I am still mystified how the developers of the game make any money after we pay for the one off purchase to remove ads.

hi all,
Just to let you know I am never in any rush when I submit any suggestions. They are only suggestions, and I’m grateful for whatever we get whenever we get it. I tried the two finger down flick but it doesn’t work. Everyone have a happy and merry Christmas and a happy new year. God bless

Submitted by alex wallis on Sunday, December 17, 2017

no two finger flick down isn't a currently implemented gesture, it is my suggestion for quickly moving to the bottom of slots, as two finger flick up goes to the top so it seems to me that a good gesture for going to the bottom would be two finger flick down.

Submitted by Taylor Brown on Monday, December 18, 2017

Rest your finger just above where the home button is, and the game rapidly scrolls to the bottom. It works all throughout, as far as I know.

Submitted by bsharp on Monday, December 18, 2017

I am very advanced in the game, all estate requirements are met, and I have the castle. I love the game and enjoy playing. Game gets stuck in different areas like farm, quarry and so on. It bounces around, won't let me flick around or tap on any choice to do anything. It freezes everything because I can't start any automations or anything.
Please help. Is there anything that can be done?? I am running the most recent IOS on an IPhone 6.
Am I the only one having problems?
Very frustrated!!

Submitted by alex wallis on Monday, December 18, 2017

thanks for the tip taylor about resting your finger on the screen to scroll rapidly to the bottom, it worked great for me on the iPhone x I just tried it in the mine. Interestingly it doesn't work in the main game window where all the buildings are shown, and you have to focus on the first slot in an area before it works, but once you do it works great. I would still like to see a dedicated two finger swipe down gesture added to go directly to the end of slots, as hunting for this little area on the screen can be a bit hit and miss, plus I do have to navigate to the first slot before I can hold on it. still its a nice work around to know about. I wonder if this control or whatever it is could be given a VoiceOver label to make finding it easier.

Submitted by Wren on Tuesday, December 19, 2017

hi Michelle,
I just saved my game that I have been playing on my iPad to the cloud. There are lots of focus problems with it. It doesn’t work well in the booth, or even in other areas of the game. The focus just seems to jump around. I have to repeatedly try and get the cursor where I would like it.
Thank you for a great game though. I still love it.
God bless,
Wren Langley PS the game works a little better on my phone, and on the phone and the iPad I am running the latest version of iOS. I have an iPad first generation pro and in iPhone 8 Plus.

Submitted by Frank on Wednesday, December 20, 2017

Hi, I have been playing this game since April! I am playing three different games on three different devices! I have upgraded the newest version of this game on two of my devices. I am playing the game on the 7+ and a 6S! The focus issues are just as bad on both of them when I go into a to produce product. At first I thought it was only the businesses that I have that for example logs producing four at a time without boosting them and metal on my other phone producing 4 at a time without boosting them! But it seems to be getting worse! I know that this is been addressed already but I wanted to reiterate that this is happening to me as well! I am not going to upgrade This game on my other device! I hope this issue is fixed rather quickly but I know how it takes time with Apple! I also would like to be a beta tester as well if someone can get a hold of me. Thank you and this is an awesome game!

Submitted by Jennifer Kent on Thursday, December 21, 2017

I am going to try this game again and see how my phone does I have an iPhone 7 running ios 11.2.1 I would be glad to grab testflight and beta test let me know and I will put my email address here.

Submitted by Michelle on Friday, December 22, 2017

Hi everyone,

I'm reading all the reports here and in the emails about the app being unresponsive. It is very clear that the latest update introduced some kind of bug that produces a performance issue inside the locations.
I wanted to write a quick update to let everyone know that I'm aware of the issue. I'm really sorry this happened, and I have been unable to find the cause so far.

And I'll try push out another update as soon as possible - which will contain nothing else but a fix for the responsiveness. I know how annoying this is, and if I put nothing else in the update, I should be able to push it out faster.

Are the issues only happening when VoiceOver is on, or does it not make a difference whether it's the system voice or VoiceOver?

Submitted by Jessica Brown on Friday, December 22, 2017

It happens with vo and the system voice.

Submitted by Anthony on Friday, December 22, 2017

Hello there I have news that focus when I’m in the city is worse or with voiceover on then without which is using the system voice I’m outside the city with every games normal when I’m on the map made voiceover is fine navigating on the main map and in the stores for me but when I go into the city which ever jumped all over the place and I have a hard time selling stuff with voiceover on when I turn voiceover off and use a system voice in the city I am able to sell stuff easier and focus is a lot better with the system voice on for me and I am using a a 7+ running iOS 11.2.1 can I have the current version of the game

I'm using an iphone 6 here, with the latest IOS. I have only once had to put up with the Crafting Kingdom app jamming while I was in the city: that's more likely to happen in the buildings where the production is done, even when I have as few as ten slots in those buildings. Sometimes the game works better with the system voice than with VoiceOver, but at other times, more often in fact, the game will jam regardless of which voice I choose to use. The only places I have never had any jamming-up are the castle and the screen where the princess gives us her gift. Focus dances to the bottom of the screen in the castle if i swipe too fast, but going back to the top and swiping more slowly allows me to start boosts or chedck quest progress as normal.

Submitted by Jennie A Facer on Friday, December 22, 2017

In reply to by brandon armstrong

Hi all,

Sometimes when I get a notification or a phone call, the game says that storage is full and all of my boosts and automations run out even though I had just started them. I don’t know what could be causing this. I am running an iPhone 8+. It is happening to me daily now.

Submitted by Jennie A Facer on Tuesday, December 26, 2017

In reply to by brandon armstrong

When I tried to switch from playing with my phone which is an 8 plus, I went to my iPad pro 10.5 inch. That is where all of the focus problems are for me. Hope this helps.

Submitted by Jennie A Facer on Saturday, December 30, 2017

In reply to by brandon armstrong

For some reason when I started my game for the first time today, I lost gold after having played for a while. It was around 100,000. Not a big loss, but therefore a loss that I thought needed to be reported. I was at 21,890,000 and somehow got down to 21,704,000. There was some gold at the end, but I don’t actually remember how much. I hope this helps.

Submitted by Jennie A Facer on Sunday, January 7, 2018

In reply to by brandon armstrong

I swear I have a gremlin in my phone and Crafting Kingdom. Whenever I receive a call while I’m playing, all automations and boosts run out and it interferes with the connection between my phone and iPad. My iPad won’t ring now and WiFi calling is on and all is set up. Not sure if Crafting Kingdom could be the problem? I have called Apple support on this one and he helped me set it back up again all to no avail. The problem still persists.

if I were you I’d save my progress to the cloud uninstall the app and see if you’re calling works after that. I know it sounds a bit simple but it just might let you know if Crafting Kingdom is actually the problem. that might at least give you peace of mind. :-)

Submitted by Michelle on Tuesday, January 9, 2018

I received an email a few days ago from a player suggesting that I could add a setting for the accessibility mode of the game into the iOS settings app directly. I think that is a great idea, because the iOS settings are accessible with VoiceOver, and so it would always be possible to turn the accessibility back on if it was turned off by accident. I have to do some research though to see if that is something that's even possible to do for Unity games.

For those having issues with the triple tap to turn on the accessibility mode again: This gesture only works when you are in the main menu. You will need to close the app completely from the app switcher and restart it. I also recommend doing the taps near the top of the screen, to avoid accidentally hitting the play button which takes you directly to the world map. The taps have to be fairly fast - and the mode might take a second to kick in.

I have another suggestion however I might find it hard to put into words please bear with me.

with the cloud save you are asked to confirm whether you want to save your progress. My idea is that this occurs when the accessibility mode is turned on or off within the options. I believe this would be helpful in cases where that option is accidentally triggered.

Submitted by alex wallis on Tuesday, January 9, 2018

just wondering michelle, have you had any luck getting the 4 finger swipe gesture to work consistently when going from crafting kingdom to other apps? I haven't ever got it to work on an iPhone 7 plus or an x, I know you said it works for you which I can't understand if that is the case why it doesn't work for me. also any progress with working out why the game really doesn't perform well with high numbers of slots in production areas? I am also very much looking forward to a way to stop boosts at will.

Submitted by Anthony on Tuesday, January 9, 2018

Hello there I have noticed with VoiceOver running when I have my phone in Low Power Mode and also with the system voice when I have my phone in Low Power Mode that the focus loses it in the city and a little bit hotter to buy stuff with the system voice also when I’m trying to sell stuff when I have it in the parenthood to maybe something in the code for Low Power Mode is the problem maybe I was trying to say that it’s a little hard to sell stuff when I have in Low Power Mode but when I take it out a little parrot it easier in the store in the city to navigate and sell stuff with no Low Power Mode for both whichever and the system voice Ronnie iPhone 7 Plus and I have the latest update in stalled I hope this is understandable using dictation

Submitted by Wren on Saturday, January 13, 2018

I save the game to the cloud earlier in the morning and when I want to save it again it did not save. I was going to delete the game and reinstall it to see if the focus with voiceover would be better, which after the installation it was not. I also noticed that when the game is saved to the cloud the princess gift ours went back to 21 hours. This morning when I got my 58% higher gift the sale prices did not change. The focus for me is a little better with self voicing but it is still troublesome.
Is it better to wait until the automations run out before saving the game to the cloud also when resetting progress is it better to wait until the automations run out before doing this?

Submitted by Wren on Saturday, January 13, 2018

hi all,
If this saved previously I apologize, but I did not see it post. The other day I was playing the game on my iPad and saved to the cloud. Then I was going to see a focus would be better if I reinstall the game so I saved to the cloud again. The game did not save. Focus was also no better after a while then previously. My princess gift also goes back to 21 hours when I save the game to the cloud. The second time I save the game to the cloud I had automations running is it better to wait until all of the Ottoman automations run out before saving? Also this morning when playing the game I got my princess gift which was 58% higher the prices did not seem to change from 56% sales to 58% sales. have to talk to Tatian to finger double tap when finished
Is it better when resetting progress or saving to the cloud to wait until the automations run out before doing either one of these things?
Thank you very much for the help and for a great game
God bless,
Wren sorry for the extra text in the comment, but it seems to do that every time I dictate the comment.