Help us improve accessibility of our game Idle Crafting Kingdom

Forum
iOS & iPadOS Gaming

Hi everyone,

I'm one of the developers of the game Crafting Kingdom.
We just released the game today and we would love to know what you think, especially in terms of the game's accessibility.

The game focuses a lot on crafting resources, producing goods and then selling them.
You start out small, chopping logs in your lumberyard. Eventually you will work your way up unlock new products, buy new buildings and production facilities which allow you to produce more valuable goods.
You can also build out your own estate, if you have the necessary construction materials.

The game is incremental, which means one of the gameplay mechanics is that you need to restart your progress every now and then to get ahead. You complete quests and earn bonuses like faster production and higher sale prices for your next restart.

The game is free. There are optional ads, but no in-app purchases. The ads are voluntary rewarded videos, which will give you a powerful boost for watching (for example double log production for 10 minutes).

You can find the game here:
https://itunes.apple.com/us/app/crafting-kingdom/id1190611967?ls=1&mt=8

We tried to make this game as accessible as possible, but know that there are probably plenty of things that could be better. We would really appreciate some feedback on what could be improved. Any feedback is welcome.

Please note: The game uses Unity and the Unity Accessibility Plugin (UAP), so not all VoiceOver gestures are supported.

Options

Comments

Submitted by KE7ZUM on Thursday, March 1, 2018

When you reset after quest you start over, but you get your storage and stuff upgraded and your quest rewards. Is this what you meant?

Submitted by Anthony on Thursday, March 1, 2018

Somewhat I kind of knew that but I had a quest that I was working on and I wasn’t sure if it gets carried over to the new restart

Submitted by KE7ZUM on Thursday, March 1, 2018

Yes the quest you did not finish will carry over. I'm in the middle of selling 50 thousand logs and it's already carried over 3 times.

Submitted by Anthony on Thursday, March 1, 2018

Oh OK that’s what I thought but wasn’t high percent sure working on the 5000 gold and want to get new ones

Submitted by Use Small Words on Thursday, March 1, 2018

In reply to by Anthony

just to let you know when you reset, your quests involving money and storage reset. For example if you want to get 5000 gold coins by getting two million in the bank, when you reset your money goes down to 0. Same goes for if you want to get 10% off your storage by getting 5000 storage it goes down to 0. just thought I’d let you know. All the other quests carryover though

Submitted by Clare Page on Thursday, March 1, 2018

I'm sad to have to report here that, since I updated my iPhone 6 to IOS 11.2.6, the performance of Crafting Kingdom has got far worse for me. I have recently only been able to produce goods in one property at a time, which allowed me to use the quarry to complete a huge iron ore quest, but adding the furnace and blacksmith to the quarry to produce metal parts didn't work: I couldn't get the Restart All Automations button to work for either the furnace or the blacksmith after restarting the quarry's production, even without VoiceOver. For this reason, I have saved my progress, and I currently only open Crafting Kingdom once a day to receive the princess's gift, but being unable to use more than one property at a time for production has made me have to call a halt to my quests for the time being. I will resume those quests either when I upgrade my iPhone or when an update to the app brings performance improvements, whichever comes first. I love this game, and will miss playing it, but I'd rather take a hopefully short break from it rather than having to fight with it every day just to get some production going.

Submitted by KE7ZUM on Thursday, March 1, 2018

I'm also noticing that on android even though I updated my device to android 8. Because of this latest update and not being able to turn accessibility on, when I can I have to double tap multiple times just to get anything to trigger.. I put the game away for a while and started again, and accessibilitymode was turned back off. This as of the last two updates over the last two days for the game. I dunno if any of this will help but hopefully the performance issues will be fixed on ios and android. By the way I have not ben able to get the accessibility turned back on. It works when it wants to. Roar.

Also the "save to cloud" option I didn't know I had to do once in a while. I thought that was done automatically. I never apparently saved to cloud until yesterday. Oops?

Submitted by Ornella on Thursday, March 1, 2018

I redownloaded the game on a new phone. I'm using an IPhone S.e and since I had to start over its working much more snappier but I don't know if I progress much futher in to the game if I will run in to those issues that some of you are having. I wished if we could've kept the money and the buildings that we already bought in the first level and just move on from there and keep getting harder and harder quests.

Submitted by molly on Thursday, March 1, 2018

hello. a number of Android users, myself included, are unable to enable the accessibility in crafting kingdom. tapping the screen 3 times with 3 fingers does nothing. we experienced this issue after crafting kingdom was updated. this has been happening on a galaxy s8 and other phones. is anyone on iOS having this issue? please contact us on the eyes free google groups forum.
thanks.

Submitted by Michelle on Friday, March 2, 2018

Hi Molly,
I already responded via email and in the forum, but just wanted to post here real quick as a follow-up.

Again, thanks for writing here and via email, because I don't get notifications from the eyes free forum at Google and would have missed this otherwise!

Submitted by alex wallis on Wednesday, March 7, 2018

so is there an ETA when you hope to release the update to fix the performance issues either to testers or to the public in general?
I appreciate of course you want to do a lot of private testing to ensure no save games are broken etc.
so this might seem a rather stupid idea, but given that you of course want to be very thorough with your testing and so this could mean weeks or even a month or two of testing why not release an update to the appstore that entirely removes the cloud save feature if that is the root cause of the stability issues? that way you could do all the testing you want and we could make much more progress with our games.
I personally don't see cloud save being a hugely important feature anyway given that its really intended for backups and not to be used regularly for saving and restoring games.
I am curious though why has cloud save caused this massive issue with performance? given that cloud save shouldn't be doing anything when we are playing the game normally in production sites etc, I mean just out of curiosity could we possibly have a technical explanation as to why it has caused these problems and are they definitely resolved with the new save load feature, I mean have you stress tested the game with several hundred slots in a production area.

speaking of stress testing, I have a bug to report with numbers in the game, this relates to your amount of gold coin you have saved up, don't ask me why but I saved up a huge amount of gold which I did then spend, but I found that once I had over 2 billion gold coins the game did something very strange with the number for gold coins, VoiceOver started giving the number as a negative value for example negative 2 billion gold coins, I then found that when I spent some gold the negative number increased rather than decreased so effectively I got more gold when I spent it, I found myself thinking oh this is great, and started spending but a minute or two after that the game crashed, and when I reopened it gold was behaving normally again and the number was no longer showing as a negative value.but I have been able to get this behavior to repeat twice consistently.

I thought I would edit this comment as nobody has posted since, so its pointless to add a fresh comment, I just found another bug, our old friend where numbers are spoken as digits rather than proper numbers by VoiceOver.
this is in relation to storage, I just found that instead of VoiceOver telling me I have 1 hundred thousand 1 hundred storage it announces the number 1 hundred thousand 1 hundred as digits, so 1 0 0 1 0 0.

Submitted by Michelle on Friday, March 9, 2018

Hi Alex,
I thought I'd post here as well, in addition to the email I sent you.
The storage numbers bug is fixed, thanks for your email with the detailed instructions on how to find it. It'll be included in the patch update.
I have yet to track down and fix the money bug, which sounds like an overflow to be honest - meaning if the money gets so big that it's overrunning the variable memory I am using to store it. I'll look into this!

As for the cloud save, I'll gladly explain why this causes a performance hit. We are storing the cloud save in a separate save file, a text file to be exact. That's because cloud save was added after the game was already running and our old save system didn't support it. And our server only has limited space per user, which means we can't even store all data, but have to cut it down and compress it. That's for example why the princess wouldn't properly save to cloud.
Now, the reason why this caused a loss of performance is because the Cloud Save used to piggy back of the regular save. Whenever the game saved, it would create an additional text file with a slimmed down version of the game's data and then compress it. There was no other way to do it without massively rewriting the save system. But creating a long block of text in memory and then compressing it costs performance. And that is on top of our save system which was already very slow, because writing to a file is slow. And the game was auto-saving on every screen change and doing an auto save every few seconds. I guess you can see the problem.

We have now completely rewritten the save and load system, so that it neither compresses data, nor writes a lot of stuff into a file. Cloud Save and regular save are now using the same system, so nothing needs to run in the background and compress data on the fly. We're also now only accessing the save file when it's actually needed, so the regular save is much much quicker as well. And as an added bonus, the save game now saves everything, include the princess.

We just learned that some players on Android and Kongregate use it to help get the quests they want. They cloud save right before resetting the game - and if they don't like the quests they get, they load the cloud save and reset again. Until they get the quests they like.

Submitted by alex wallis on Saturday, March 10, 2018

Hi michelle, thanks for explaining why the cloud save causes such performance issues, I can certainly see why it caused problems and glad to know its fixed.

Submitted by riyu12345 (not verified) on Saturday, March 17, 2018

As people have said, I've noticed a huge lag.

I think it might be to do with the amount of slots you have.

If I save using the cloud, delete the game and then redownload it, and load my game, the game will run for a minute or so and then lag again.

Submitted by Michelle on Saturday, March 17, 2018

Hi everyone!
I submitted the beta to review last night, and hopefully it will be approved for beta testing in the next few days. This build has now been beta tested on Android for quite a while and so I think a week or two on iOS to find the last kinks if there are any should do.

Submitted by Wren on Saturday, March 17, 2018

hi Michelle,
Here is my report on the latest beta when I use the cell 50 multiple times it keeps repeating sell 50. It doesn’t tell me how much I have sold or how much is remaining. It doesn’t give me how much I have earned either.
The save to cloud and load from cloud functions seem to work well. Thank you for this great safe system. I have reinstalled the game several times but there is no change. At first it was telling me how much I was earning and how much remain after the sale. Then it quit doing it.
Thank you for a great game. I love it.

Submitted by riyu12345 (not verified) on Wednesday, March 21, 2018

Hi.

When I go to the estate and look at the metal parts, it shows up as 0. I know for a fact I have about 65 metal in my city.

I think the estate calls them metal parts where as the produce menu calls them metal.

Submitted by Use Small Words on Wednesday, March 21, 2018

In reply to by riyu12345 (not verified)

your metal parts are showing a zero in your estate because you only have metal in your city in order to start collecting metal parts you need to purchase the blacksmith and start making metal parts using your metal that you’ve already collected.

It’s not a bug.

Hope this helps.

Submitted by Clare Page on Wednesday, March 21, 2018

In reply to by riyu12345 (not verified)

You're not the only one who wondered why you saw that you had 0 metal parts when you had been producing metal, Brad: I made the same mistake myself the first time I had to produce metal parts, which I think was also for an estate expansion. Luckily, it wasn't long till I realised that I needed to go to the blacksmith to make my metal parts, using metal I'd produced in the furnace. So having no metal parts when you have only produced metal so far is not a bug, it's just a case of getting a bit confused, something which could happen to any of us.

Submitted by riyu12345 (not verified) on Thursday, March 22, 2018

Thanks to people on here and my friend Amin, I've realised that the metal showing up as 0 because I don't have metal parts is not a bug.

Submitted by riyu12345 (not verified) on Thursday, March 22, 2018

hello.

I'd like to be a beta tester if possible.

My email address is bradleybrown2@live.co.uk

i'm noticeing a huge lag.

i'm not exactly sure but I think it might have to do with when you produce products. I think that slows things down.

I noticed that when I was not producing any products, I was able to change products to what I needed to with no problem but as soon as I started producing products, everything slowed down to a crall and there's a lot of jumping around too.

I also really think a button to change all products to a sertain type at once would be great. If you have 20 or 30 slots and need to change eatch one, that will take a very long time.

Submitted by alex wallis on Friday, March 23, 2018

Hi Michelle,
I have emailed this to you, but posting the following here as well, though I have added further thoughts below which aren't in my original email.
I can confirm as others have said that when you sell things in the city there is no feedback to say what you sold or how many of an item you had left,
or how much gold you earnt.

also, there is another issue where if I lock my phone or am out of crafting kingdom doing other things quite often the game isn't producing products while
I am away from the game, and also timers for production of products and boosts are not being run down properly its as if the game is totally paused this doesn't seem to happen all the time though but happens regularly.

on the plus side I haven't found any lag issues so far and I am now up to 81 slots in my workshop. Having said that scrolling through slots does seem slower
now when I hold my finger on the screen it does get really tedious navigating loads of slots the more we have especially to quickly add slots or automate
them, the problem is that focus doesn't stay put after adding a slot meaning you have to find it again unless you hold on the screen for a split second then if your lucky you might be in the right place, but if you ry to flick down after doing anything like adding a slot or backing out of a slot after automating it your back at the top of the screen.
I think a way to change all slots to produce a single item would be good as well, in fact I think the hole design of production slots needs a rethink, as its really tedious flicking down to a given slot then having to locate the option to open the production menu for each slot, there must be a better more unified way production slots can be managed. I mean just thinking off the top of my head, what about doing away with the select production button entirely, so you would flick down to locate a slot, then right for a menu to select what it produces, alternatively double tapping a slot directly could open a production menu, the select production button just seems pointless to me and adds in unnecessary flicks and taps.
I hope you find this useful.

Submitted by Ornella on Saturday, March 24, 2018

Hi. I want to make sure I unlock the right product and I am a little confused. I am on level 4 of the estate. It says a house, built from brick with curtains and windows. It says that I need metal parts and I know the furnace and the black smith produces those things. I'm not sure which ones to open.

Submitted by Sasha Stride on Saturday, March 24, 2018

hYou will need both. To make metal parts, you need metal. Metal is made in the furnace and metal parts are made in the blacksmith so this means that you need to unlock both.

Submitted by Use Small Words on Saturday, March 24, 2018

first by the furnace and get metal then when you can afford it by the blacksmith and get metal parts.

Submitted by Clare Page on Saturday, March 24, 2018

In reply to by Sasha Stride

To add to the previous post, you actually need to have three properties unlocked in order to make metal parts. Coal and iron ore from the quarry are used to make metal in the furnace, and the metal in turn is used to make the metal parts which are done by the blacksmith. So, to make metal parts, you need to have the quarry, the furnace and the blacksmith all unlocked.

Submitted by Ornella on Saturday, March 24, 2018

Thanks. I have the cory unlocked becaused I was selling stone. So I will then open the furnace and the blacksmith. Thanks guys.

Submitted by alex wallis on Saturday, March 24, 2018

why on earth don't people try tapping on properties and reading the displayed information, if you actually read in a property window before purchasing it it actually says what products are made there, now OK I agree metal parts from metal might not be such an obvious leap, but come on people explore the game before asking for help. I mean if you need metal parts it does sort of stand to reason you need metal to make the parts. If you actually look at the different properties it does say that the furnace makes metal and the blacksmith makes metal parts in there descriptions and product lists.

Submitted by Ornella on Saturday, March 24, 2018

So what's wrong with asking someone for help? Is it a crime? People get upset over little things. I won't ask anymore questions on here. I just asked because I wasn't really sure what to open first.

Submitted by charles on Saturday, March 24, 2018

In reply to by Ornella

People are getting upset about a message from Alex Wallace, even though he made an excellent point. Each property lists, quite plainly, what that property will produce. Think of this as a good way of learning the game. This is better than reading a huge and possibly complex user's manual before playing for the first time. So often, on blind gamers' eMail lists, questions that are clearly answered in a user's guide are asked by people who refuse to read the guides provided. Then these people get upset if they are told where to find the answers to their unnecessary questions. This, to be honest, is due to their laziness. My subject line of this message sums it up perfectly. To throw a tantrum and state that you will never ask a question on here again is crazy. Alex is understandably frustrated with so many questions that are unnecessary, and so am I. Read the supplied help. That is why it is provided.

Submitted by Yokose on Sunday, March 25, 2018

I must admit, I find myself at a loss for words. Someone asks for help, and there's almost always a few who are willing to give grief because of it. I have a couple of points for anyone willing to listen.

Number one, when looking at a property, either before you purchase it, or look at the help file after you purchase it, there's no in-depth information. Before you purchase property, sure, there is a list of items you can create there, but no information about what may be needed to create said items. After you purchase a property, there's nothing in the help file about items that can be created let alone about what is required to create said items.
Number two, more often than not, developers do not create intuitive or efficient help files for their apps, or games.

For the original poster who asked for help, I'm glad that you got an answer that was helpful. At the same time, I don't blame you for not wanting to associate with this community again because a minority within feels it is OK to treat people badly. This is exactly why I rarely comment here, I don't know what kind of treatment I will receive because of it.

In closing, may I offer some advice to the minority here? This is actually really simple advice, so I hope you'll listen. If you don't have anything nice to say or contribute, then shut up. Good day.

Submitted by Ornella on Sunday, March 25, 2018

I never meant I was never going to not ask any question on the site but on this particular topic. And you are right people give grief for very little things. All I wanted to do was make sure I was doing the right thing. And some people should really shut up if they have nothing good to say.

Submitted by DrummerGuy on Sunday, March 25, 2018

In reply to by Yokose

Those who have questions, keep them coming. Those with answers, keep them coming, too. After all, this is only a game. Why getting so frustrated about a thing such as a game? If this is the reaction about a game, I cannot imagine how people would react about a more serious matter.

Submitted by Ornella on Sunday, March 25, 2018

I do have a suggestion for the farm. After finishing the quests after unlocking all the products I think gradually in future updates there should be more like wheat to make flour that would then make bread, eggs milk butter and cheese as more products. And we stack the eggs manually in to crates to then sell in the city which gives something to do while other products are producing.

Submitted by Justin on Sunday, March 25, 2018

Hi,
I like that idea Ornella. I too think this is something good to possibly implement in future versions.

Submitted by riyu12345 (not verified) on Monday, March 26, 2018

Hi.

I've noticed that if I have 1000 timber and 2000 logs and my storage space is 3000, once those logs fill up the storage space, they will not be made into timber.

A friend of mine suggested selling one log, then trying to restart the timber autimation but that doesn't seam to work.

I say doesn't seam to because I have 10 timber slots and the game could have started turning the logs into timber. I just checked the first slot, nothing was happening.

I've solled all my logs. The quest I'm on, i'm meant to get 25000 timber and if the logs could keep being made into timber, that would be nice.

Submitted by Ornella on Monday, March 26, 2018

Sometimes I run in to that problem but when I sell the remaining logs, I get timber again. Don't know if that's a bug.

Submitted by Wren on Tuesday, March 27, 2018

hi,
I wanted to download the original version of the game because the beta repeats so much. I deleted the beta after I saved to the cloud, and when I went to load it from the cloud after installing the nonbeta version my game was gone. Just wanted to let you know. Thank you for a great game.
God bless,

Submitted by alex wallis on Wednesday, March 28, 2018

Hi all, I have noticed some other iintermittent bugs, first in the latest beta when I flick up to go to the back button or the top of the screen VoiceOver moves me to the top but then tries to read me the entire contents of the screen, this is a particular issue on the world map screen.
Secondly there is an issue with treasure chests where when I open a chest quite often the chest opens and I get the noise of the gold being awarded, but then a few seconds after that there is a click as if the cursor moved and I am told how many products I have in storage, these are definitely issues not present in the last proper appstore build.

Submitted by KE7ZUM on Wednesday, March 28, 2018

to the person who is being lazy it's quite obvious of what you should have done. Each of the products lists what you need and it's obvious where you get the stuff. you just need to do a bit of digging. Learn how to do your homework and research first. I find that i learn a lot more than asking for help all the time unless I'm really struggling. I tell my students all the time. I expect them to do the looking up of words and stuff before they come to me this way they learn on their own.

second here is a slight bug with eh android version that might have already ben brought up on the iOs version. I can't remember if I sent an email about this.

  1. Launch CK.
  2. tap play
  3. tap the city or any properties.
  4. try and do something like sell all products or start crafting.

Notice that it takes sometimes 4 or 5 or more taps for the process to happen. I'm also suffering from the focus issue as well and i'm on a moto z2 force with 4 gigs of ram. and a snap dragon 835 processor.

Submitted by alex wallis on Thursday, March 29, 2018

Hi Michelle, as usual emailing this to you and posting to applevis as well.

I just installed the new crafting kingdom beta, and I noticed that loading seems to take a bit longer after selecting the play option, maybe a few more seconds,

also whenever I open the game now there are two little ping sounds the sounds that play whenever you get a hint that says you have completed a few quests.

I find the sounds annoying when they play each time I open the game, and actually I wonder if we need that little screen that says loading please wait when you first select the play option as the game does load quickly and it just adds extra stuff for the speech to output.

I do like the fact that newly added slots are now automatically selected, it still isn't particularly quick to be able to get to the add slot button though I either have to hold my finger on screen or scroll manually through the slots which isn't fun when your furnace is up to 105 slots.

I don't know if you keep a bug tracker but I can still think of a lot of long term bugs I reported ages ago that are still present, of course I know there is only so much that can get added or improved for each release though, but there are still things like when you go to purchase storage and you flick down, VoiceOver says purchase but your focus is on the cancel button, and I do find it irritating that the purchase storage screen closes after every storage purchase, I can think of other issues as well though.

though over all I certainly do appreciate the automatic slot selection, just finding the splash screen and chirp sounds annoying.

Alex.

Submitted by Ornella on Thursday, March 29, 2018

Since the update the game has been working more snappier for me and some of the lag is reduced. And to Alex, when you tap on the treasure chest really fast sometimes voice over doesn't say how much money you have. I get that sometimes and when I sell stuff. If you have more than a million dollars you get 60 to 100 thousand dollars I think. For those using an SE you might want to try playing the game again who ever had the heavy lag issue.

Submitted by Jennie A Facer on Thursday, March 29, 2018

In reply to by brandon armstrong

My friend and I are having a lot of trouble with this game. We tried reinstalling the App Store version over top of the Beta and we lost our games. She lost hers completely and I lost part of mine. She had to delete and reinstall. I just lost a lot. We just wanted to bring this to your attention. The Beta won't tell us how much we've earned and it still repeats a lot. It also won't stay on the back button when you do a two-finger flick up. Thanks!

Submitted by alex wallis on Friday, March 30, 2018

I would email michelle, I am sure it can be fixed, remember they rewrote the save system, so she might want both your player ids so she can look into this, assuming you didn't already do another save of course.

Submitted by Clare Page on Friday, March 30, 2018

In reply to by Ornella

As I write this, IOS 11.3 is being installed on my iPhone 6, where I was getting severe lag when navigating any of the production sites, even with very few production slots. Having just read here that Crafting kingdom works faster under IOS 11.3, I will try to get back to production again in the next few days, in the hope that I can work towards completing a huge metal parts quest, and other quests in my current play-through, without having to wait for a new version of Crafting Kingdom or a new iPhone.

Submitted by alex wallis on Friday, March 30, 2018

the lag issues have been resolved, if people read above michelle explains the cause of the lag issues being down to there old save game system, the issue seems to be totally resolved as of the latest beta, if your running that you should experience no lag issues, though not sure when its going to be released to the appstore, there are certainly a few minor bugs I and others have mentioned above, plus that annoying splash screen whenever you open the game now, really wish there was a setting to disable that, but I haven't come across any major bugs.

Submitted by Michelle on Friday, March 30, 2018

Hi everybody!
Sorry for my week-long silence, I was in San Francisco to attend the yearly Game Developer's Conference last week.

Here's some updates on the bugs that were reported:

I'm working on fixing the missing sale announcement in the market screen. The idea was to make this announcement skippable. However, some bug in the code now causes the announcement to always be skipped when played on a phone or tablet. I'll either find a fix or revert to the previous version before release, in which the announcement wasn't skippable.

The new splash screen was a necessity to fix the issues with offline production. Whenever you resume your game, the app will calculate the time that you were away and catch up on the production. This happens in the first few seconds. However, up until now, the game would already allow you to start playing at the same time. This means the game is trying to catch up on the production while trying to actively produce at the same time. This caused lots of problems, the worst of which meant that players would lose all of their offline production. The splash screen is now covering the screen and disappears as soon as all offline production has been calculated. This usually doesn't take longer than 2 seconds.
Keep in mind that this calculation was always there, just not noticeable, because the game didn't use to wait until the calculation is done.

My goal is to update the beta one more time and then release this version to the store. I know there are many other improvements that still need to be made, but I want to push those into the next update - so that the performance problems are fixed for everyone sooner rather than later.

Submitted by Clare Page on Friday, March 30, 2018

Now that I have IOS 11.3 installed on my iPhone 6, I am pleased to be able to say that, even though I am still playing the current App Store version of Crafting Kingdom, I have noticed far less lag when restarting production just now. When I last played this game, some weeks ago, I could restart production in the quarry, but then the game would freeze if I tried to add the furnace and the blacksmith to work on a metal parts quest, but just now I could double-tap Restart All Automations in all three properties without any sign of the game freezing. Here's hoping that will continue till the next App Store version of the game comes out: don't rush it, though, best to have it working as well as possible by the time it's released!

Submitted by alex wallis on Friday, March 30, 2018

Hi michelle, regarding the splash screen, I guess I find it annoying to have the sounds play and be told loading, could some sort of accessibility setting be added so that nothing displays on screen till its loaded? basically I mean display the splash screen sure but have an option to in effect mute it so we get no speech or sound output, I guess I find the speech and sounds a bit jarring especially if I am flicking regularly between say crafting kingdom and messages or other apps. it would be nice to be able to silence it for VoiceOver or accessibility users with a setting. Before when starting the game it used to be that we new the game had loaded because it would say world map or something like that, if the screen could be made less jarring that would be good, even getting rid of the please wait from the speech would be good, as by the time the speech and sounds have played the game is usually loaded so the speech is kind of playing catch up. If it was a setting to make the screen less verbose users could choose to enable or disable it as they wished, even getting rid of the chirp sounds would be an improvement. Maybe an option could be to display a blank screen till the game had finished loading, though I suppose maybe this wouldn't be good for sighted users, but I do get the point why its needed.

Submitted by Michelle on Friday, March 30, 2018

Good point, Alex.
I'm a fan of replacing unnecessary voice announcements anyway, so I'm happy to give that a try.