Help us improve accessibility of our game Idle Crafting Kingdom

iOS & iPadOS Gaming

Hi everyone,

I'm one of the developers of the game Crafting Kingdom.
We just released the game today and we would love to know what you think, especially in terms of the game's accessibility.

The game focuses a lot on crafting resources, producing goods and then selling them.
You start out small, chopping logs in your lumberyard. Eventually you will work your way up unlock new products, buy new buildings and production facilities which allow you to produce more valuable goods.
You can also build out your own estate, if you have the necessary construction materials.

The game is incremental, which means one of the gameplay mechanics is that you need to restart your progress every now and then to get ahead. You complete quests and earn bonuses like faster production and higher sale prices for your next restart.

The game is free. There are optional ads, but no in-app purchases. The ads are voluntary rewarded videos, which will give you a powerful boost for watching (for example double log production for 10 minutes).

You can find the game here:

We tried to make this game as accessible as possible, but know that there are probably plenty of things that could be better. We would really appreciate some feedback on what could be improved. Any feedback is welcome.

Please note: The game uses Unity and the Unity Accessibility Plugin (UAP), so not all VoiceOver gestures are supported.



Submitted by alex wallis on Sunday, May 21, 2017

very strange, try emailing michelle or contacting apple, I don't know why your having issues, did you try closing the appstore totally from the appswitcher and reopening it? it might be worth doing that after installing the old version see if that helps. otherwise I would talk to apple, as certainly I am on the latest official build. it also might be worth deleting the game then waiting for a few minutes, or turning the phone off totally and restarting it after deleting the game.
also for those complaining they are not seeing new quests to get restart all automations for production areas, just be patient they come up naturally when you restart and are allocated new quests so it might be that you don't get them straight away.
they all seem similar, basically I now have restart automation buttons for the lumber yard, quary and the mine, and for these I had to have 15 production slots per area to complete the quest, you don't have to automate all the slots just have them to complete the quest. though I chose to automate them as I have 500 automations to get anyway and I didn't see the point of getting a slot without automating it.

Submitted by Kelvin Tan on Sunday, May 21, 2017

hi alex. I have already contacted michelle about this. also, if I were to uninstall the app and then reinstall it again, I will have to start all over from the beginning again and I don't wanna do that for sure. I have plus 1 production for almost all of the products till the workshop now, with 110 percent estate expansion, 50 percent from princess, and over 200 percent sale prices for all buildings, and it will take ages for me to get to where I am now again. guess I will just stick with the current beta until another beta or official version is released and hopefully it will show up in the app store by then. the strange thing is the the description in the app store shows version shows version 1.4 but when I download it, it's definitely not that version. so it's really strange. I have restarted my phone, tried to stop testing in test flight, but it's no use.

Submitted by Steady on Sunday, May 21, 2017

hi kelvin, very strange. i have a feeling that you will have to wait until there is another new built then it will appear in your app stall. just hope that there is a minor update soon. anyhow, it's totally not worth for you to delete and reinstall the game and start all over again just for this new version since you have already gone so far into the game. i am still trying to catch up with you in some areas and btw i broke some of your records. i just got a sell 2 million stone quest. haha! and btw the game is taking up 1.7 gb memory space on my phone.

Submitted by alex wallis on Sunday, May 21, 2017

my crafting kingdom is at 751.5 mb it does seem to be rather hungry for space doesn't it, I hadn't noticed that. I hope its not going to keep eating my iPhones space indefinitely.

Submitted by Kelvin Tan on Sunday, May 21, 2017

wow steady! 1.7 gb of space that's crazy! I guess u must be the kind of very very hardcore player that watches a lot of videos to get the boosts? because I think that's what I did to get my game size till the size it it. and the thing is updating to a newer version doesn't seem to solve the size problem. I definitely will not uninstall the version I have and then reinstalling again. anyone who have gotten this far in the game will not be foolish enough to do so, as everything will be lost and I will have to start all over again. keep working hard on your quests, and I guess u will catch up with me real soon. my highest sale this play through is 1 million wool, and lowest sale quest is 75 thousand armor.

to alex, I think u have been watching quite some videos as well? I have already told michelle about this. but just want to see if u guys are facing the same problem. I think only those who uses a lot of boosts by watching videos will encounter this problem in the long run. but now by purchasing the no adds feature, the file size should not increase any longer I hope.

Submitted by Steady on Monday, May 22, 2017

In reply to by Kelvin Tan

hi kelvin, while doing other quests, i enjoy watching these videos. haha! before this version release, i had already unlocked my 4th boost slot and is 1/3 through 2500 boost quest. to bring the file size down we have to wait till the save game feature becomes available before reinstalling the game. for some strange reason, i get a lot of quarry quests even though i make a point to unlock blacksmith and workshop products before restarting game. my estate expansion is 1 step behind you, but with the quests i get doesn't lead me to work on that.

Submitted by Michelle on Monday, May 22, 2017

Hi everyone,
thank you to everyone who reported the storage size issue. Unfortunately it seems that the video adapters that download the videos do not properly clean up after showing them. That's not acceptable of course.
We're currently investigating on how to delete the old videos by force and once we find a solution will release another patch.

Submitted by Kelvin Tan on Monday, May 22, 2017

hi michelle. great to know! hopefully the official version will show up in the app store for me this time. when u have the time, can u please add me back to the test flight please?

Submitted by Kelvin Tan on Monday, May 22, 2017

hi steady. for me I got stuck with a lot of farm and workshop quests. I have done 600k grain, 300k meat, now doing 600k leather strips and also 1 million wool. for my workshop, I have done 75k fabric, 75k clothes, and 50k food. I think to unlock the workshop u will have to unlock belts as well so that the quests for the workshop can show up in the quest list?

Submitted by Frost on Monday, May 22, 2017

Hats off to Metal Pop for making a very crafty game.
I have always wanted to play a game like this since all of my friends were playing Farmville on Facebook.
Unfortunately, the developers were not receptive to making the game accessible.
I applaud you for making Crafting Kingdom accessible from its conception.
I have purchased this game from the app store, and encourage others to do the same.
Not only will purchasing the game give you a slight advantage at earlier stages of the game, it will also support MetalPop Games which seems to be a company that cares about accessibility.

Michelle, I do have a slight concern and a question.
At one time, my boost duration was 70 minutes. Unfortunately, when I purchased my new phone, I had to start from the beginning.
When I purchased the game, my boost duration was 25 minutes
Since I have purchased the game, I no longer get boost quests to increase the boost duration time
It would be somewhat disappointing to be stuck at 25 minutes on my boost duration.
Could you please tell me if there have been extra quest added to increase the boost duration after you have purchased the game.
If not, do you plan to incorporate them in a future update?

Submitted by alex wallis on Monday, May 22, 2017

do you have any idea when a solution to reclaim the space that videos have eaten will be available? as obviously I don't want to delete and reinstall just to get it back, that would be a tragedy, but at the same time I really could use that space because I am going on holiday soon and would have used it for books and such. It sounds like the hole approach crafting kingdom uses to giving out adverts to those who don't want to pay for the game needs a rethink, as obviously most of them are not very accessible to begin with needing tiresome work arounds to get rid of. Though actually I can't imagine why any serious player of this game wouldn't spend the cash to support the game. One thought though I presume that serving us the adverts provided a revenue stream, once we purchase the in app purchases is that you effectively losing revenue which will long term affect your ability to keep working on the game? I presume that showing us the adverts meant you got paid a small amount for each one viewed like how websites work.

Submitted by Bellsfurmama on Tuesday, May 23, 2017

Steady, I can't imagine getting 60 thousand every time. That would be incredible.

Submitted by Kelvin Tan on Tuesday, May 23, 2017

there is no need to imagine. just buy more buildings e.g. quary, furnace, blacksmith, workshop, and get more slots automated, and always have at least 1 million in the bank, your treasure chests will always be more than 50 thousand. that i can assure u my friend. 25 thousand treasure chest is actually nothing.

Submitted by 3rdEyePro on Tuesday, May 23, 2017

In reply to by Kelvin Tan

I had to delete the game, the vids worked 1 time after the update, then crashes every time, very annoying, if the vids are not working, the boost should automatically work...

Submitted by DrummerGuy on Tuesday, May 23, 2017

In reply to by Kelvin Tan

Just keep opening more production slots and buy more buildings and the money will come to you. From time to time, I even use all of the boosts to make more money. You just need to explore and develop your own strategy on how to play this wonderful game. Good luck.

Submitted by Michelle on Tuesday, May 23, 2017

Hi Kelvin, I added you back into the TestFlight group. Strange that the store version appears to be the old one for you.
I think the version numbering needs clarification. The App Store download has a version number, which is currently 1.4, but the game has an internal build number as well, which is 1.2.0.
While the numbers each have nothing to do with each other and mean different things, it's obvious that it can lead to confusion and there's really no reason for it. With the next update we're going to try and consolidate the numbers and just jump to 1.5 on both.

The quests for the boost duration should still be available, I put that on my high priority bug list and will investigate. Thanks for reporting.

Submitted by Ornella on Tuesday, May 23, 2017

HI. I want to make sure that I'm doing the right thing. I am on my second restart because I had to reinstall the game. Anyway, my question is Before I restart the game to get more quests, should I buy the other properties before I restart or, do I just save the coins and buy all and then restart. I may have asked a question similar to this but I just want to make sure I'm doing the right thing. For the estate, I need 200 grain but the farm hasn't been opened yet and I already have the logs and timber working and I need 200 of those. Thanks for any help.

Submitted by Michelle on Tuesday, May 23, 2017

Hi Ornella,
if you can, you should try to build out the estate before restarting. The estate doesn't get reset upon restart and the extra bonus storage space will come in very handy during the next playthrough right from the beginning.
Unlocking buildings is a different matter because it influences quest selection. After a restart, new quests are selected based on which products and buildings you have when you restart. If you didn't buy the farm for example, you open quests slots will not be filled with quests for farm products.

Submitted by Kelvin Tan on Tuesday, May 23, 2017

hi michelle. thank u so much. would be interesting to see what happens when the next version comes out. just for fun I did the following test. I actually also have the beta version of crafting kingdom installed on my older iphone. on that phone, I did not get the upgrade from the app store as well. so, I uninstalled the beta version and tried restarting my phone to see if the official version which is 1.4 shows up or not after my phone restarts, and guess what, it still does not show up. at this point I am quite shocked. the only thing left for me is to log out of my current apple id and try logging in to another and see what happens. it's really strange though. as for my newer phone which is what i'm using all the time to play this game, I am just running the latest beta which I think version 1.20 something so that I can still enjoy all the new features as if I were to install the version from the app store I will not enjoy these new features. looking forward to see appstore's update notification soon hahaha.

Submitted by Sasha Stride on Tuesday, May 23, 2017

Hello. I play this game a lot. I love it. The only thing I would like to suggest is to make it possible to cancel voiceOver speech. I am still addicted to this game. I am about to expand my estate and I will then restart to get my quest rewards. Thanks for a very adictive game. Rock on.

Submitted by alex wallis on Tuesday, May 23, 2017

If you want to stop VoiceOver speech why not just triple press the home button if you have that function set up that will toggle VoiceOver off for you, I am not quite sure what the point of that suggestion is given that its up to you if you use VoiceOver or the non VoiceOver voice, that's not really something that Michelle can do anything about as its down to your choice which you use. Having said that I do think if people are not using VoiceOver then control needs to be given for things like speed, but remember Michelle is one developer with limited time on her hands and she has to do things for everyone not just focus on us as blind players baring in mind that sighted people also play the game.

Submitted by Sasha Stride on Tuesday, May 23, 2017

I meant something like the two finger single tap to interupt speech. I didn't mean to turn of VoiceOver seeing that I cannot use my phone without it. I just meant to interupt speech. Sorry for the confusion.

Submitted by alex wallis on Tuesday, May 23, 2017

aah I see, even so though not quite sure why you would want an interrupt speech gesture, its not like the game is constantly talking to you, and swiping quickly interrupts speech for things as you go through, maybe I am being stupid but I really can't see the benefit of a dedicated gesture to interrupt speech, I personally wouldn't use such a gesture. though I am sure you have valid reasons for making it. VoiceOver does have one admittedly but again I can't see the point of it as once you mute speech all you hear is clicks.

Submitted by Sasha Stride on Tuesday, May 23, 2017

I don't mean muting the speech I mean to interupt the current thing, like the voiceover gesture two finger single tap, to just interupt the current thing being spoken. I guess it was a bad idea.

Submitted by hllf on Tuesday, May 23, 2017

I do not understand the necessity for an interrupt speech gesture. The game is not reading a novel. It speaks a sentence or two at most with each flick/gesture. It would take longer to perform a gesture to silence the speech than it would to simply wait for the the voice to finish speaking.

Submitted by alex wallis on Tuesday, May 23, 2017

well everyone is entitled to make there own suggestions, in this case I personally don't see the gesture as needed, having said that I didn't know about the single 2 finger tap to interrupt speech, I am not sure how often I might use it, but guess it could be useful if I have a long email and want to stop reading without losing my place, and its always nice to know about gestures I didn't previously know about. I am not sure if the 2 finger single tap is an official VoiceOver gesture or one that just happens to work, as I tried toggling VoiceOver help on and doing a 2 finger single tap and was given no help message to say what it does, though I did try it and it does appear to work, handy to know about anyway so thanks for the tip.

Submitted by hllf on Tuesday, May 23, 2017

It's an official VoiceOver gesture. two-finger single tap interrupts speech. Performing the tap a second time resumes speech. It's equivalent to using the control key on a computer to silence/resume speech.

Submitted by Ornella on Tuesday, May 23, 2017

Thanks Michelle now I understand the game much better. There's only a tiny problem some times in the lumber yard and the estate the focus jumps from where I'm from to other things. Like if I'm reading something the focus would move from where I'm reading and reads something else. It sometimes happens in the city where I meant to sell some of the logs and instead sell the timber by mistake because the focus jumps. Anyway I love this game and in the futre can't wait for more buildings.

Submitted by hllf on Tuesday, May 23, 2017

I've experienced that too. The reason is due to two things:

1. In many of the screens, such as the castle, city, or the production screens, you can actually touch the screen once and move focus to the element you touch. For example, you can move focus to a different slot simply by tapping on it once.

2. In version 1.3 of the game, Michelle vastly improved the game's ability to understand the flick gestures, and they became much smoother. However, the game still struggles with the double tap gesture. It's very often that the game thinks a double tap is a single tap, so rather than activating the element that has focus, it changes focus to whatever element is under your finger where you double tap, as it thinks you did a single tap.

I experience the above constantly when I am going through and reactivating a lot of production slots... I flick down to the next slot, flick right to the produce button, then double tap to activate. repeat that 75 times. At least 25% of the time, the double tap moves focus rather than activate, as the game thinks I just tapped.

It would be great if Michelle could at some point investigate the game's ability to understand a double tap correctly and improve that, just like she did for the flick gestures.

Submitted by Jennie A Facer on Tuesday, May 23, 2017

I love the game! I am a new user. The one thing I would work on is the VoiceOver delay when I try to flick down on the screen in any place. Especially on the world map! I'm using an iPhone 7. If you need any more help, please let me know.

Submitted by hllf on Tuesday, May 23, 2017


I am also running Crafting Kingdom on an iPhone 7, and I experience no VoiceOver lag when flicking in the game, either left/right or up/down. I recommend you check your game version and make sure you are running the latest, which is version 1.4 in the App Store.

Submitted by Michelle on Tuesday, May 23, 2017

I think you raise a good point that speech should be interruptible in general. In most places a swipe to the next element will interrupt the current speech, but there are many small announcements in Crafting Kingdom that can not be interrupted.
Examples of this would be the announcement that the storage is full, a boost has run out, you don't have enough money to buy something, how many gold coins you earned from a sale or found in a treasure chest.
The issue comes from the way these announcements are triggered. Since these are not buttons or labels that are read, but instead are announcements from the game, there might not be a way for the player to repeat them. That's why the Accessibility plugin has to treat them as vital information that by default can not be skipped.

It's a case by case problem. You don't want to miss the announcement that your storage is full because you just happened to swipe in the same moment the announcement was triggered. On the other hand, when you sell your entire stock of timber in the city, you might want to move on quickly to the next product and sell it, too. Right now you have to wait for the announcement to finish, before the buttons are read out again.

This issue has actually been on my to-do list for a while already, and I personally find it to be inconvenient at times as well. It has a lower priority though, as it is obviously not as big of an issue as the need for cloud save or numbers being read out as single digits. I am planning to get around to this eventually though, and make at least some of the announcements interruptible.

Submitted by hllf on Tuesday, May 23, 2017


You raise a good point with the "critical" announcements. Even though those are not interrupted, when doing a lot of flicking, say when restarting 100 production slots, it's easy to miss the announcement. Here are two recommendations I have to address this:

1. Have a sound play when such an announcement is about to be played, in addition to just having it spoken. The sound will grab the user's attention that an important announcement is coming.

2. Have these announcements, such as notification of a boost running out, get put into an announcements history buffer that the user can move through. For example, this could be something as simple as a two finger flick up/down to move through the history buffer, two finger flick left/right to move to the beginning and end of the buffer.

This way, the sound will let us know such an announcement has occurred, and if we miss what was spoken, we can use the history buffer to easily read through the announcements.

Also, did you see my note in my earlier comment about the issues with the game recognizing double tapping?


Submitted by Ornella on Tuesday, May 23, 2017

At first I didn't like the sell 1 button but I'm happy its back. Its very useful when you only need to sell maybe about 2 or 3 items.

Submitted by Roxann Pollard on Wednesday, May 24, 2017

My next estate build requires metal parts. I cannot figure out what is needed. I currently have the lumber yard, farm, quory, and fernace. Am I missing something?

You have to purchase the Blacksmith property to make metal parts: for 1 metal part you need 1 metal, produced in the furnace, but to make 1 metal you need 1 coal and 1 iron ore, both from the quarry. I hope this helps!

Submitted by Kelvin Tan on Wednesday, May 24, 2017

personally I think the interrupting speech is not important at all. as alex has mentioned, there are only a few areas in the game that u can't interrupt the game speech. I myself found those very easy to due with. just set your voice over speech rate to 100 percent before opening the game. it's not to hard to play with speech rate of 100 percent actually because u just have to pay attention to the numbers most of the time. and anything that is uninterruptable will pass really fast because of voice over's high speech rate.

Submitted by alex wallis on Wednesday, May 24, 2017

to respond to a few points, some people might not want VoiceOver at a high speech rate because of comprehension issues, I use mine at %80, I think also the voice you use can affect how easy it is to understand the faster you go, for example I can easily understand Daniel at 100 and find him slow even then, but alex my preferred voice is at 80 because 100 is a little two fast for me. I have never wished for the ability to interrupt speech though, and I actually like hearing numbers for how much I find in my treasure chest, selling of stuff etc.

as to finding out about stuff how its made etc, has nobody on this forum heard of popping into the buildings to actually have a look? before you buy a building if you go into it and flick a few times to the right it will actually list the products that are made by each building, its not hard, just explore a bit you can't break things. so in each building it lists the products that they make, then if you buy the building and tick an item on a production slot it lists what is needed to make it, there is nothing wrong at all with asking for help but there is such a thing as exploration as well.

Submitted by Frost on Monday, May 29, 2017

Hi Michelle, just looking for clarification about the Boost duration.
I was wondering if you had some time to look into the boost duration issue?
Is it there, or is the reason why we don't get it is because it's a bug?
Also, I was wondering if there's any chance you guys can add a "stop production" button?
I think it would be helpful when we are working on our quest.
For example, if the grain quest we are currently working on was completed, but we still have 30 minutes of automation left.
It would be helpful to stop the production of the grain so we can use the storage space we have, to make other products that are not in the same location, like coal or stone for this instance.
I can't thank you guys enough for making this game very accessible for the blind, thank you for your time and dedication.

Submitted by KE7ZUM on Monday, May 29, 2017

Why not just sell the grain and the storage will begin filling your other products. You will still get gold for with effort which works. This is what I do when I play

I also noticed the reset that someone was talking bot I waited for my gift from the princess and watched it flip to 21 hours with out me doing anything. This on my android device.

Submitted by Ornella on Tuesday, May 30, 2017

I always sell my stuff so I get more money to buy things. If I don't need anymore of that product I don't restart it so I could get more room for other things.

Submitted by Nolly on Wednesday, May 31, 2017

The reason we don't want to sell the extra item such as grain is it takes up storage that could have filled up with another quest product while we are offline. The key point is while off line. Having the full 15,000 of storage space to fill up with something we need to complete a quest can save valuable time, rather than only part of it because a product we no longer need is there instead.

Of course we can make the production line create something it lacks materials for,so it simply produces nothing but there are quite a few lines that don't need materials to create.

Submitted by Ornella on Wednesday, May 31, 2017

Then when the automation stops for what ever product you don't want then don't restart it and sell I what ever remained from the product.

Submitted by Frost on Thursday, June 1, 2017

Exactly!!! You have it!! I don't have time to constantly be on my phone to empty out my storage with products I don't need anymore. It would be great if we could just stop it.

Submitted by Frost on Thursday, June 1, 2017

Hi Michelle, I just have one quick question.
I was wondering if you could add the "flicking down with one finger" navigation in the "extend your storage" page?
For example, in the main screen and you are on "Castle", when you flick down with one finger, it takes you directly to the "Estate", or if when you are in the "product selection" page, everytime you flick down, it takes you to each of the different sections on the page. It kind of acts like a heading.
Can you please add a navigation like that on the "extend storage" page?
Whenever I have to buy more storage, I have to flick 6 times to get to the "purchase" button.
When you have to purchase over and over again to get to the desired amount of storage space, it gets a little frustrating.
So far, the "extend storage" page and the "princess" are the only ones who does not have that navigational feature.
I would be very thankful if you could add the navigational feature on these pages, or at least on the "extend storage" page.
Thank you very much again for your time and dedication. I really do appreciate the things that you guys do to make this game very enjoyable to us.

Submitted by Taylor Brown on Thursday, June 1, 2017

I've been playing this game for a while, passively, and reading comments here I learned that you can play with Voiceover on.However, when I tried it on my 6S, I had to press hard enough to activate force touch or 3D touch to use it. Is this a known issue, or is my phone just not working right? I'm going to try turning off force touch to see if it fixes it.

EDIT: I turned off force touch and swipes stopped working, regardless of pressure.

I have two suggestions, though. First is making the princesses button and the upgrade estate buttons anchors that you can flick down to, as it'd make the game easier.

Second is to make it so unfinished quests go to the top of the list, and completed quests go to the bottom. Then, it'd be easier to just open castle, flick down a few times, and check progress rather than manually checking each quest to see which ones I still have to do.

Submitted by alex wallis on Thursday, June 1, 2017

I don't see the need for the princess to be an easily available option, I mean she doesn't do much apart from once a day, I think its better to have the estate be the easily flickable option I mean your more likely to do things with that than the princess.