Help us improve accessibility of our game Idle Crafting Kingdom

iOS and iPadOS Gaming

Hi everyone,

I'm one of the developers of the game Crafting Kingdom.
We just released the game today and we would love to know what you think, especially in terms of the game's accessibility.

The game focuses a lot on crafting resources, producing goods and then selling them.
You start out small, chopping logs in your lumberyard. Eventually you will work your way up unlock new products, buy new buildings and production facilities which allow you to produce more valuable goods.
You can also build out your own estate, if you have the necessary construction materials.

The game is incremental, which means one of the gameplay mechanics is that you need to restart your progress every now and then to get ahead. You complete quests and earn bonuses like faster production and higher sale prices for your next restart.

The game is free. There are optional ads, but no in-app purchases. The ads are voluntary rewarded videos, which will give you a powerful boost for watching (for example double log production for 10 minutes).

You can find the game here:

We tried to make this game as accessible as possible, but know that there are probably plenty of things that could be better. We would really appreciate some feedback on what could be improved. Any feedback is welcome.

Please note: The game uses Unity and the Unity Accessibility Plugin (UAP), so not all VoiceOver gestures are supported.



Submitted by Michelle on Saturday, March 18, 2017

Unfortunately ads are problematic. The placement, labeling and overall accessibility of the close button is taken out of our hands completely. To make matters worse, some videos will switch into a landscape mode without notification. If that happens, you might try to swipe left or right to find the button, but nothing happens, because the phone thinks you are swiping up or down.
I'm still trying to find a solution for this.

Ornella's suggestion of just tapping on the app so it takes you to the store and cancelling from there might be a good workaround for now.
In general, if swiping doesn't seem to do anything, try swiping in a different direction, like up or down. Maybe the phone was just silently switched into landscape mode.

Submitted by Michelle on Saturday, March 18, 2017

Hi everyone,
a new update is now waiting for review by Apple to be released. This version has several fixes, some improvements on the accessibility and will make the app work better with iPhone 7 and the other phones that had issues before.

I will post another update when the app is live with a detailed list of improvements.

Submitted by Lulu Hartgen on Saturday, March 18, 2017

Me again! Now that I'm getting into higher priced items, I'm finding the way the figures have been written sometimes gets me confused, because voiceover doesn't read it properly, meaning it reads literal figures rather than words. For example, if an item is priced at five million gold coins, and no, I don't have anywhere near that much yet, it reads the figure as five zero zero zero zero zero zero gold coins. If the figure was written like this: 5,000,000, I can't read the individual characters, but I'm assuming it's written now as 5000000, then we'd get it as five million.

This is just a little thing, and I don't know if anyone else is having this problem, maybe it's just me, but when I see so many zeros and I don't have a way to actually review a piece of the text character by character, I get confused sometimes, I'm not sure whether I need 10,000 gold or 100,000 to unlock something, that's a heck of a difference.

One lovely touch I found since my last is the Pr... well, let's say the property which isn't a property. Did anyone else find her? If not, go look, I'm not spoiling it for you, but that is a really cool feature! And, I've just seen about the update being in review, thank you for being so on the double with that, I cannot wait!

Submitted by Paige on Saturday, March 18, 2017

I am using an iphone 5s and i am having lag issues. I can navigate around the main menu with difficulty but double tapping acmomplishes nothing.

Submitted by Lulu Hartgen on Saturday, March 18, 2017

In reply to by Paige

Hi. The main menu is always the most laggy and difficult and it may take a few openings and closes of the game to get it to work. Try to activate the play button, that's the way I've always got it to work for me, then even if I've had to go back to the main menu for options or whatever, it seems to work easier. I do hope that helps.

Submitted by Michelle on Saturday, March 18, 2017

Thank for pointing out the formatted number issue. I didn't think of that!

I suppose that not all numbers behave the same way, because I remember some are formatted like you said, and some are not.
I added that to my Todo list.
Excellent find.

Submitted by Ornella on Sunday, March 19, 2017

I can't wait for the other version. I hope it fixes the lag issue because my fingers are really hurting. lol

Submitted by Jen on Sunday, March 19, 2017

I have waited what seems like forever, for a game that involves building and crafting, and no combat.
Thanks so much to the developers for including VoiceOver users.
I have the same lag issues like everybody else, but with a lot of patience, I am slowly getting the game to work.
When that lag is fixed, this game is going to be golden!

I've said it before, but it bears repeating. People who do not like combat games in the VI community are woefully under catered for. There has to be something better than card, word , endless casino mock ups, quizzes and arcade style games and simon says imitations. When I write that it seems like there's a lot of choice if you don't want to fight, but think about it, if you want role play, crafting, questing without combat, before Crafting Kingdom you'd search in vain. I can't thank the developers of Crafting Kingdom enough who have taken the trouble to make this accessible for us, and just as important, have kept it free. I never mind making in app purchases to support development, but I realize some people just can't, and I always feel like I'm taking unfair advantage somehow in getting ahead by doing it. By using the booster method, we're all on an equal footing. Once again, thank you so much, Michelle and everyone.

Submitted by Ornella on Sunday, March 19, 2017

I agree with Lulu Hartgen. This game is awesome. And the only casino game I enjoy playing is fruitpot by Eduardo. In the future I would like to see more business style games like this one and café or restaurant games. Maverick games are dieing and none of their games are close to anything like this.

Submitted by Sunshine Daisies on Sunday, March 19, 2017

In reply to by brandon armstrong

Hello there, first I want to thank the developers of this app for creating and making the app accessible for the blind. I've only played the game for a day now, and I'm already addicted.
Like many others, I'm experiencing the lag issues, and I'm very happy to learn about the update released so soon.
I have one suggestion that I didn't see anybody mention.
Is it possible to put a "sell all" button when you're in the city?
The "sell 1, 10, & 50" buttons are great because sometimes you need a certain number of products for expansion, but I would like a "sell all" button when my storage is full and I need to get rid of the whole lot at one time.
A question for Michelle, I saw the "more games" button in the main menu, do you have other games that are voice-over friendly like this game?
Again, thank you very much for all your time and hard work in making this game fun to play, and accessible for the blind.

Ooh! This Sell All thing was something I was thinking of, this selling no more than fifty items can get tedious, especially when you have a lot of storage as I have at the moment, but if you added a sell all button you'd need to be really careful with it, because I don't know about anyone else, but sometimes I find I tap stuff I didn't mean to. I'd hate to accidentally hit sell all and find my entire storage emptied, especially if I were saving products up for something I needed. Later on in the game you have to have stuff in your storage before you can make other stuff, so you'd be really mad if the whole thing just got emptied. Perhaps an "Are you sure you want to do this?" type dialog would work around this. Or else sell 100 would make life a bit easier?

Sorry I forgot to mention this on my previous post.
I don't think the "Real Estate" Boost is working.
It says that it's suppose to have 20 percent discount on expansions. When I picked it, the expansion price on the storage didn't change, and the requirements on the "Estate" didn't change either.
I didn't know where the discount pertains to exactly so I checked both the storage expansion and the estate.

Submitted by Sunshine Daisies on Sunday, March 19, 2017

In reply to by Lulu Hartgen

A comment on Lulu's post.
I hope the developers don't add another dialog box. The reason why I thought of the "sell all" button is to lessen swipes and taps when you're selling your goods.
The dialog box would just add another step to the process. We just have to watch what we do in the game and be careful on what we tap around.

Submitted by Michelle on Sunday, March 19, 2017

Hi all, we just discussed it and think the Sell All button is a great idea. I'll add it in with the next update after this one.

It will be an extra button either before the Sell 1 button, or after the Sell 50 button.

Thank you all for the great feedback. I'm sorry that the game doesn't run smoothly for everyone yet.
But I'm also really happy about all the great ideas and suggestions. There is clearly a lot that can still be in improved upon to make the game a smoother ride.

Submitted by Michelle on Sunday, March 19, 2017

In reply to by Sunshine Daisies

Hi Sunshine,
The Real Estate Boost is not broken, it just has a description that is misleading. What it does is make the additional production slots cheaper.

The problem is that the inaccessible button issue doesn't currently let you buy more production slots. So right now the boost is useless when playing with VoiceOver. But this too is fixed with the coming update.

In the update after that I'll rewrite the accessible description of that boost to read production slot as well.

Submitted by Orinks on Sunday, March 19, 2017

Hi all,

I heard this game was looking for testers? My friend got in and suggested I come here to ask for an invite. I use an iPhone 7 so I'd like to provide feedback on this game. My email is for use with TestFlight.

Also, how is that cooking management game coming along?

Submitted by Ornella on Sunday, March 19, 2017

If the double tapping on the play button doesn't work put a little more force on it and it will work. Sometimes I tap on different things and nothing happens and I have to add more force to the tap.

Submitted by JTran2013 on Sunday, March 19, 2017

Has anyone else experienced getting an error message saying We're sorry there are no videos to play right now. Please try again later.? I received this message last night trying to get a boost. I was able to watch videos again after some time.
Thank you,

Submitted by Ornella on Sunday, March 19, 2017

I never got that error message. That could happen if the videos are taking time to load.

Submitted by Yokose on Monday, March 20, 2017


I have been playing your game for some time now. I think it is a grate game! I do have a suggestion... I hope you do not mind it. I had some help getting more production slots in the game from someone whom has some vision. I've discovered that the more slots you have the more you have to press "Produce" for each slot.

My suggestion is... would it be possible to add a single "Produce" button for multiple production slots that are automated? Lets say for more then 10 production slots that have the automate upgrade unlocked? Thank you so much for your time and consideration. On a side note the button to purchase more production slots is still hidden with VoiceOver enabled... even when there are more then one production slots purchased. I am running version 1.0 of Crafting Kingdoms on an iPhone SE 64GB and iOS version 10.2.1.

Yours, Yokose

Submitted by Michelle on Monday, March 20, 2017

Hi Yokose,

yes, that's true, each production slots you have needs you to hit the Produce button once every ten minutes to restart the production. This will take a lot longer with VoiceOver than it would a sighted person who could basically just quickly run their finger down the screen.

We don't want to change the gameplay but here's two ideas that we had:
1. Add a 'Refresh All Automations' button which can be unlocked either with gold coins or with a quest.
2. Reorder the buttons on the production slots. If the produce button was the first button inside a slot, retarting automations is a lot faster. You can swipe up and down to quickly jump between slots. So restarting automations would be "swipe down, swipe right, double tap - repeat".

What do you think of the second suggestion? Would that order of buttons and labels inside a production slot be confusing? It would mean the produce button would come before the button that let's you select the production and before the label telling you the duration and so on.

On another note, the new update which fixes both the lag issues and the "add production slot" button is still not through the review process at Apple. I'm crossing my fingers that it'll make it through today.

Submitted by Yokose on Monday, March 20, 2017

Hello Michelle,

I like both ideas. I was going to suggest the first option... but now that I've thought about it, it's hard to advise.

The first option would simplify things for large numbers of production slots... I think.

The second option is grate as well. my only concern is that when I swipe down, I like seeing for example... "Production Slot one, Logs", "Production Slot two, Timber", and so on. If one can swipe down and still see that first, then a swipe right to the produce button to produce the material, that would be awesome! Just so I know that I am understanding though...if I for example had 6 production slots in my Lumber Yard... I should see "Production Slot one, Logs" as I swipe down to the first production slot, then a swipe right would bring me to the "Produce" button, right? After starting the production another swipe down would bring me to "Production Slot two, Timber", then a swipe right would bring me to the "Produce" button for that production slot, and so on, correct? If that is the case, then that would make things easier I think.

Both ideas are grate as I said... I like them both. if I had to choose though, I think I would go with the first option. Thanks so much for your time!

Yours, Yokose

Submitted by Hubert on Monday, March 20, 2017

That would be great if the update goes through soon, it would make playing the game a lot better, considering it will flow nicely. As for the suggestions regarding automations and production buttons, I definitely like the sound of that.

Submitted by Michelle on Monday, March 20, 2017

I'm thinking both options could be valid, why settle for one? Adding a quest reward to unlock a "Refresh All" button is definitely a nice idea, I think.

And then I'd reorder the buttons in the next update to work the way Yokoze described it. We definitely want to keep the general announcement of slot number and production first, but then a single swipe to the right would bring you to the produce button instantly.

Submitted by Ornella on Monday, March 20, 2017

When I open the gift or reward, how do I make it active? Do I have to restart the game every time? I'm asking because when I opened the gift it said 4% higher I think but when I clicked on sell the price was still the same.

Submitted by Michelle on Monday, March 20, 2017

Hi Ornella! Thank you for playing!
The princess bonus is active immediately, you don't have to do anything else.
The thing is, logs sell for only 10 gold coins, they are the cheapest product there is.
If you add 4% onto a price of 10, you'd get a price of 10.4 gold coins. Because there is no such thing as 0.4 gold coins, the price is then rounded, which brings you back to 10.
If you however sell timber, you should already see the price has gone up.

Submitted by Ornella on Monday, March 20, 2017

Okay. I was wondering about it. I just restored the game because I completed all the quest. It was hard to sell 5000 logs and I was trying to activate to make the lumber yard go 10 times faster but I wasn't sure what was happening.

Submitted by Ornella on Monday, March 20, 2017

Okay. I was wondering about it. I just restored the game because I completed all the quest. It was hard to sell 5000 logs and I was trying to activate to make the lumber yard go 10 times faster but I wasn't sure what was happening.

Submitted by Tangela on Monday, March 20, 2017

I did get the beta version of this game to play. However, I notice the self voiced tts it is using does not honor my speech settings. Specifically, its very slow. Is there any way, either in the app settings or in ios settings itself, to change that?

Submitted by Michelle on Monday, March 20, 2017

Hi Tangela,
the game is supposed to use VoiceOver, but it can only do that if that is enabled. If you turn off VoiceOver in the game, it will fall back to the system voice. The speech rate will also be a default rate, which cannot be changed in this version. It was just supposed to be just a fallback solution, the default should always be VoiceOver.
In the test version, you can enable or disable VoiceOver freely and after a second or so it will switch voices.
Did you have a specific reason or bug that you encountered that made you want to turn off VoiceOver and use the system voice instead?

Submitted by Tangela on Monday, March 20, 2017

Well, mainly that I didn't realize it *could* be played with voiceover on, so it was just switching to the system voice. :) user error, as usual.

Submitted by Michelle on Monday, March 20, 2017

Hi everybody, Apple just approved the update and it is now live in the store.
Here's a list of changes that made it into this version:
- Main menu performance improved, so that it no longer makes finding or tapping the play button impossible
- Treasure chests stay in the map a little longer
- VoiceOver can now be turned off during play and system voice will be used as fallback
- Tutorial popups no longer make the estate or city screen inaccessible when entering them for the first time
- Button to add more production slots is now accessible
- Options menu is now easier to close, just swipe down 4 times and you'll end up on the close button
- Added quit game button to main menu
- Other music will no longer be stopped when entering the game
- After activating a boost it will announce how long it is going to be active

This version will be a lot better and easier to use for those with iPhones that have newer chips. And in the next update in a few days that will be improved even more, as we have continued to make more optimizations over the weekend. I will continue to post and update here.

Thank you to everyone who helped beta test. We're hoping you won't run away, we still would like to improve on the swipe sensitivity and a few other bugs.

Submitted by Ornella on Tuesday, March 21, 2017

I downloaded the update and when I opened it I hear the voiceover click for when something is about to open and then it says double tap to open. I do it a few times and I still can't get to open it. I cleared the memory and closed the game from the ap switcher and still nothing. I restarted the phone and when it still didn't work I deleted and redownloaded and I'm not getting to play. I'm using an Iphone 4s running ios 9.3.5. If I can't get to play the game I will have to wait till maybe next week when I change my phone.

Submitted by Jordan on Tuesday, March 21, 2017

I finally got the Play button to work after a few tries. I find the game to be a little sluggish and clunky, but it is playable and enjoyable. One question. How do you add more production slots at the lumber mill?

Submitted by Tristan on Tuesday, March 21, 2017

I just want to add my voice and saying thank you so much for making such a great accessible game. The fact that you have reached out to the applevis Community to gain feedback and suggestions is really appreciated. by the way if you are after any more baiter testers, you can add me at
thank you so much again.

Submitted by Roxann Pollard on Tuesday, March 21, 2017

Hello Michelle. First of all, I, too, wish to add my thanks for making an accessible game. I really like the concept of building a world like this.
I like the suggestions posted here, in the discussion with Yocose, with regard to the production slots, specifically number two.
As far as the update is concerned, I still see too much Voiceover lag time; better, but needs improvement.

One question... I have read in this forum that it's required to quit the game sometimes to lock in some things. does this simply mean to use the new Quit Game on the main menu screen or something else?

Keep the updates coming.

Submitted by tunmi13 on Tuesday, March 21, 2017

Ok...? This is strange. I just updated this game and... It won't ipen. I hear the confirmation sound when I double tap it, followed by the two tones meaning its opening, but after that, it just says crafting kingdom again, on the home screen.

Submitted by alex wallis on Tuesday, March 21, 2017

Hi, this game seems like it has lots of potential to keep me occupied for ours, a few questions, is the game actually winnable or is it open ended so I can play as long as I want? and are there ways to extend the lengths of time boosts and automations are active for?
on the subject of automations I have noticed that when I use the produce button when an automation is active the time before the automation runs out goes back up, is this a bug or intentional?

Submitted by Ornella on Tuesday, March 21, 2017

I'm having the same problem with the game. Its not opening.

Submitted by Lulu Hartgen on Tuesday, March 21, 2017

Wow, was I ever glad to see this update! Thank you so much for it! Here are my comments, now I've been playing for a few hours.

The lag is better, could be better still, but it's better. Main menu is heaps better, that works for me like a charm now. Production slots, oh wow, isn't it great to be able to have my properties produce more than one thing! But, no gain without pain, right? I'm leaping about like a headless chicken, pressing buttons to refresh automations, even though I do try to start everything around the same time. That quest refresh all reward button would be soooo cool! Just please, don't make it too hard to get hold of or my hands are going to fall off!

The treasure chest is way easier to get, thanks for that. I still have problems with focus, especially in world map, so having the chest stay around is making life easier.

Swiping up and down to get to production slots or items in city is a great thing, but care is needed, focus does tend to jump rather eratically when doing this if you deviate even a little from a dead straight line.

One thought I did have: when looking at items in city, I often want to quickly check real fast how much of stuff I have. At present I'd swipe down from logs, say, and it would say timber, but then I'd have to swipe right once to tell me how many I have. Sometimes I can get down ok to the next thing, but more often I lose focus and end up on a sell button I don't want to be at. I'm wondering if we could have the number right by the product name so we could see how many we have without having to swipe right. This would let us check down a long list of products real fast on the fly with just up and down swipes, and only have to swipe right if we need to sell any.

Once more, thanks so much for this truly addictive and great game, for making it accessible and for the great update.

Submitted by Portia Scott on Tuesday, March 21, 2017

In reply to by Ornella

Hi to both of you, and anyone else having issues opening Crafting Kingdom,

In order to fix this, and allow the game to open, unfortunately, you will have to uninstall the app, and then re-install it. I know this isn't a wonderful solution, as you'll lose all your progress, but it is the only way I've gotten it to open.


Hi, I agree with you Lulu, and everyone else! This is a very wonderful update, and the game is definitely addicting, smiles I play it all day, pretty much, so that should tell you how much I love this game. Excellent work. Thanks to the developers for making such a wonderful game, and for doing the work you do to improve Voiceover functionality with the game. Looking forward to your next update.

Submitted by Michelle on Tuesday, March 21, 2017

In reply to by Ornella

Some people reported that the app closes again immediately after opening.
We have encountered this problem too, and it seems to be a very random behavior. All over sudden it will work, then it will not work, then it will work again. We've been spending today working on this, but are having trouble reproducing it reliably. We're currently starting the game 100 times an hour in the hopes that it will fail to load. As you can guess, if you actively want it to crash, it won't...
I'll keep you posted.

Thank you to everyone who is offering to beta test. I have not replied to everyone yet, because we are so busy tracking down this bug. But we would love to have all of you as testers of course. I will try to respond to everyone within the next 48 hours.

Submitted by Michelle on Tuesday, March 21, 2017

Hi Lulu,
that is a wonderful suggestion. I added it is as you described: When swiping up and down through the different products in the city market, you will hear the amount of products that you have in storage right after the product name.
Also, after selling an amount, the game will announce how many you now have left in storage.
Both of these improvements will come with the next update. That update will also further improve the laggy-ness. The swipe detection is still a little unsensitive, so you need longer swipes than you'd usually need with VoiceOver. This will be improved too, but it will have to wait for a future update. We're trying to fix the more severe issues first.

Submitted by Michelle on Tuesday, March 21, 2017

One of the features I would like to add in the future as well is a simple cloud save to either Game Center or Google Play. That way it wouldn't matter if you'd reinstall the game, you wouldn't loose your progress.

Ornella, would you care to join the Testflight project as well? As soon as we have a new build I would like you to try it out. As long as you don't uninstall the store version first, you won't loose your progress.

Submitted by Kristen on Tuesday, March 21, 2017

Loving this game.

I, too, had been hoping for an accessible construction type game that didn't have the combat element that Celtic Tribes or Lords&Knights have. This reminds me vaguely of another accessible game called "Dragons" that had a similar concept where you had to start over to get a boost to the next run of the game - but Crafting Kingdom is worlds more in-depth and a lot more fun from what I can see so far.

I did have that original issue with not being able to play since I have an iPhone 7, but finally have been able to play starting today once the update got downloaded/installed.

So far the only oddity/strangenesses I've noticed:
- When I double tap on something, like the Lumber Yard, I have a hard time telling right away that I successfully got to the new page without swiping around. I'm not sure if I'm missing some sort of sound effect when a new page opens that is normally there on other IOS apps ... but it's sort of a minor thing.
- I do miss not being able to use the rotor and switch to being able to navigate by word or letter, but this is similarily another minor thing.

I'm amazed that a Unity game is playable at all and am heartened to hear that this plugin is now available - maybe more apps will take the plunge in making their games accessible!

Also, I'd be fine with being a beta tester if you like. My email is

Submitted by Ornella on Tuesday, March 21, 2017

I uninstalled the game and already lost the progress. I'm not sure if I could beta test but if the new update comes I could always try it out because I'm not sure what day I'm changing my phone. I will have to wipe this one out completely.