Problems with Safari on Mac if I Upgrade

Forum
macOS & Mac Apps

I have read about the problems that people are having with Voice Over and the latest Safari upgrade for the Mac. I am currently running Catalina, 10.15.5 and Safari 13.1.1. It is bugging me to upgrade to the latest version of Catalina. If I do so, I will also be upgrading to the latest version of Safari and all it's associated problems, correct? If so, I will definitely stay with 10.15.5 until they resolve the problems with VO and Safari.

Options

Comments

Submitted by PaulMartz on Friday, October 16, 2020

Member of the AppleVis Blog Team

If you upgrade and get the new Safari, the workarounds are to get the developer release, or use another browser such as Chrome. I use Chrome when I can't get Safari to behave, and while it works fine, the fact that it doesn't support keychain means I have to look up and enter my credentials a lot. If I were you, I'd avoid the upgrade and wait for 10.16, but I'm not sure when that is to be released.

Submitted by Siobhan on Friday, October 16, 2020

I use Firefox and it's terrible! compared to safari. I have not had terrible trouble with thing, I don't discount those who have. If you can wait and have a Mac that supports it, awesome. Mine will not, so so far, for a 2012 mine is ok on Safari. Though as I said, just because I don't experience it, doesn't mean it doesn't happen to you or others.