WatchOS 7 Enabling Voiceover causes display to switch to showing time

Forum
watchOS & Apple Watch Apps

I've just upgraded my Apple Watch 4 to WatchOS 7. Previously I would get a notification that would appear on my watch. I would triple-click to enable Voiceover and it would read the notification to me straight away.

Now with WatchOS 7, the notification appears and when I triple-click to enable Voiceover it turns on Voiceover but it switches back to the time screen. So I then have to navigate back to the list of notifications and find the most recent for it to read it to me. Although I can do it, it's much more difficult for me and I wish I could make it work the same way as WatchOS 6. The same thing happens if I have an app, such as Strava, open on the watch. Before I could triple-click to get voiceover to read the information displayed on the app. Now it switches back to the time screen and I have to navigate back to the app.

I've looked at all the Voiceover settings and can't find a way to get it to work as before. Has anyone else had this problem?

Options

Comments

Submitted by Travis Roth on Saturday, September 19, 2020

Club AppleVis Member

I've not upgraded to WatchOS 7 yet... Curious about your use case though: if you need VoiceOver frequently why do you keep turning it off?

Thanks. My eyesight is poor but I can read the time on the Apple Watch using the largest digital watch face in white. This is great for me as I wasn't able to read the time on any other watches I've tried.
So I don't need Voiceover turned on permanently to get the time, but I do need Voiceover to read anything else on the watch. I don't really want the watch talking all the time, possibly accidentally in public, so I like to keep Voiceover turned off and turn it on when needed.
It worked perfectly for me with WatchOS 6. A notification would appear, I would triple-click, and Voiceover would automatically read it to me. But now triple-clicking switches back to the time screen and it reads the time to me.

Submitted by Olivier on Saturday, September 19, 2020

Hello,
Beeing blind, I can't tell you if I have the issue or not. However, I might have a solution for you. Few years ago, Apple introduced a feature called Aptic time. It basically makes vibrations instead of telling the time out loud. I never tried it personnaly but I think this would allow you to keep VO turned on all the time.

Submitted by Fahad Alrashed on Sunday, September 20, 2020

Hello.
I have a solution for you:
Try to adjust the volume by double tap and hold with two fingers, then swipe up or down instead of turning voiceover on or off.
I know this is not great solution, but I hope this help.
The issue with this solution is effecting all notifications volume, not just voiceover volume.
There is a similar problem also in iOS 14:
Previously, in iOS 13, when I receive a call; I triple tap the side button to turn on voiceover and see who is calling.
Now, in iOS 14, when I triple tap the side button, the iPhone declines the call.
I always turn VoiceOver off because VoiceOver reads the time and number of notifications when I receive every notification.
Adjusting volume while voiceover is on will affects all notification volume; for this reason I didn’t mute voiceover.

Submitted by Fahad Alrashed on Sunday, September 20, 2020

Hello.
I have a solution for you:
Try to adjust the volume by double tap and hold with two fingers, then swipe up or down instead of turning voiceover on or off.
I know this is not great solution, but I hope this help.
The issue with this solution is effecting all notifications volume, not just voiceover volume.
There is a similar problem also in iOS 14:
Previously, in iOS 13, when I receive a call; I triple tap the side button to turn on voiceover and see who is calling.
Now, in iOS 14, when I triple tap the side button, the iPhone declines the call.
I always turn VoiceOver off because VoiceOver reads the time and number of notifications when I receive every notification.
Adjusting volume while voiceover is on will affects all notification volume; for this reason I didn’t mute voiceover instead of turn it off.

Submitted by Glenn Wilson on Wednesday, October 14, 2020

Hi Fiona,
I have the same problem, also an Apple Watch series 4. I have updated to watchOS 7.0.2 but this has not fixes the problem. I have unpaired my watch from my phone and reset the watch and paired it again with the phone, This did not fix it. This seems to be a problem with the OS and we will likely need to wait for Apple to fix it.
I understand the desire to be able toggle VO on and off. VO can be annoying if it is left on all of the time, however, it is useful when notifications come in, or you are using an app and you nee to know what is on the screen. Taptic time is good for telling the time. You can also tell the time by resting two fingers on the screen and the watch will read it to you. However, this is no good for standard text.