Problem with pool swim work-out using Apple Watch

watchOS & Apple Watch Apps

Hi everyone,I wonder if anyone can help me with the following issue: I tried the pool swim work-out on my Apple Watch yesterday. For those of you who haven't done this before, during this work-out the display is woken up and navigated using the digital crown. So I got through my swim and pressed the digital crown and side button simultaneously to let the watch know I had finished. But then I got stuck. The work-out summary was presented with the 'done' button at the end. I could navigate this summary using the digital crown, but I could not double tap on the 'done' button using the touchscreen. I presume this is because navigation by touch doesn't become available again until the watch has dried, but either way I was stuck unable to tell the watch I was done with my work-out. Is there any way of simulating a double tap on the touchscreen using the digital crown? Also, it took a very, very long time for navigation by touch once again to become possible. An hour or so in fact. I'm wondering whether this is because I did something wrong at the end of my swim? Should I take it off, for example, and tip it up or something to eject water? This might sound quite a lame suggestion but I'm clutching at straws a bit here. chnyhow, help from someone who's gone swimming with the watch would be fabulous please. I want to know whether it's something wrong with the watch, or something wrong with the me.



Submitted by mehgcap on Sunday, May 27, 2018

Member of the AppleVis Editorial Team

There may be a better way, but here's what I've found works well enough. I rub the screen a bit until most of the water is gone, using the finger I touch with so the friction can dry some water from there as well. Water causes huge problems for the touch screens of nearly all modern devices from any manufacturer, so getting rid of it is the most important part. A towel, of course, would work just as well, but I like to do this just after I'm done swimming so the time/hear rate are as accurate as possible.

Anyway, once my touch registers correctly, I turn the crown to unlock the Watch from its "water lock" mode. Then, I get to the first page of the workout and end it, just like normal. Of course, as I've done all this with touch, regular interaction is working just fine.

I suspect your main problem is still having too much water on your fingers and/or the touch screen. Try drying it off first next time and see if that helps. I'll have to try pressing both physical buttons to end my own swimming workouts, as that would save me a couple steps. Thanks for the idea.

Thanks that's great advice. I think you may be right, and perhaps one of my other problems has been that I was a little anxious when taking the watch for a swim, so I rotated the digital crown to eject water every couple of lengths. I know it says you're able to take it for a swim, but the idea still took some getting used to! Judging by what you say I'm guessing you don't unlock it during the work-out at all, right? Also, can I just clarify that there is no way to perform an equivalent of a double tap with the digital crown? Pausing your work-out with your physical buttons works well actually. It does mean you can take your time getting dry and what have you without its affecting the accuracy of the work-out summary.

Submitted by mehgcap on Monday, May 28, 2018

Member of the AppleVis Editorial Team

First, yes, pressing the side button and crown together will pause any workout. However, you must have screenshots disabled (a setting in the iOS Watch app), since the same button presses are how a screenshot is taken. I've never been able to get this to work for me reliably, though, so I rarely use it. I'll have to take another look.

No, you can't double tap with the crown. You can scroll, and you can use a two-finger triple tap to turn on "crown navigation" so you can simulate left/right swipes with it. That's all you can do, as far as I know.

No, you don't need to unlock the Watch at any point during a swim workout. Using the Water Lock feature only disables touch input on the screen, it does nothing whatsoever for actually preventing water from entering the device. That's down to the seals and other technologies the Watch already has, which are, of course, always in place. You can start the workout, swim, and end the workout, or pause it to end it later I suppose. The only time I unlock my Watch while swimming is if I need to check my current heart rate, yards swum, or some other metric.

As a quick aside, if you can dry a finger and the screen enough, Taptic Time will still work even when the Watch has Water Lock enabled. You can use that to check the time without needing to unlock your Watch.

Submitted by Bingo Little on Tuesday, May 29, 2018

That's very interesting about Taptic time. I didn't manage to get that working and presumed it was disabled, but I will try what you suggest next time.

I've also tried to track the distance swum, energy used and suchlike during the work-out. sometimes it works, and sometimes it presents me with the now playing screen, which I believe is page 3 of the work-out screen. With only crown navigation available it's not possible )or at least I haven't found it possible' to navigate back to page 1, where the data about how you're getting on is.

Back to the physical buttons thing, I believe that the watch taps you on the wrist when your workout is paused or resumed by means of these. I'm not absolutely sure this is correct, but am fairly confident. I think Apple Watch screenshots are disabled by dafault incidentally, as I've never changed this setting and yet when I went to look last night it was set to off.

Thanks for all the great responses about this. Looks like we're all learning on the job, so to speak.