Looking for a way to clear notifications from the Apple Watch

watchOS & Apple Watch Apps

Hello Watchers (smiles)

I gather that there is a bug in the current software which means that the action to clear notifications isn’t currently working for VO users.

Does anybody know if there is a workaround to this? Anything that will enable me to tidy up the notifications?

Using Forced Touch I was able to bring up an option to Clear All, but this doesn’t seem to work and simply sits on the screen until I restart the Watch.

Am I missing something, being dumb, or is this as good as it gets until we see a software update?



Submitted by Tim Noonan on Wednesday, May 6, 2015

I never encountered this bug for the first week of Watch use, but now do more frequently.

I've found that if you wait for a few notifications to accumulate, and wait for speech to finish before you hard press, then you may have better success.

Hope this helps.

Submitted by robin24 on Sunday, May 17, 2015

Hi all,
I've just discovered a workaround for this issue, so I wanted to go ahead and share it with all of you! Unfortunately it's not very pretty and rather complex for what it's worth, but you may consider it if you have loads of notifications to clear...
When you're within the notification center on the Watch, disable VO by triple-pressing the Digital Crown.
Once VO is off, execute a force touch on the screen, just like you would do with VO enabled.
Now, the 'clear all' option should be visible, and that should be the only option on the screen.
At this point, if you simply tap somewhere in the middle of the screen there's a good chance that you'll hit the 'clear all' button. It's fine to tap a few more times around the middle, as no other buttons should be visible here.
Now, press the Digital Crown to get out of notifications.
Next, triple-press the Digital Crown to re-enable VO. Once VO is back in business, open the notification center once again - now there should be nothing in there anymore!

Yes I know, this is unnecessarily complex and complicated, but I'm sure that's not the only complication on your Watch... OK OK, I'll admit that was a really lame joke, but I'm sure it's not as lame as that force touch VO bug... :-)

Submitted by TreoRenegade on Saturday, May 30, 2015

I've found that a press and hold on the watch screen with my finger may or may not work, in terms of bringing up the "clear all" box. But, when I use a stylus, it always appears. I then use my index finger to punch the visible "clear all" command, and it works, consistently.

Submitted by David on Saturday, May 30, 2015

Maybe I'm not keeping up, but wasn't this particular problem fixed? I've got 1.0.1 installed, and Iv'e been able to clear notifications fine so far. Mind you, I've never had enough come in at one time that I wanted to clear them all in one go, so I've only done them singly so far. But it's always worked when I've done it with a single-finger flick up and double-tap on Clear. Next time I get a list of notifications I'll try the clear all.

And yes... after complaining about the price of the watches, I have ended up with one. I keep blaming my wife, as she wanted to try it. But that's basically how I ended up with an IPhone in the first place. :-)

Submitted by David on Saturday, May 30, 2015

Just to say I've just tried the force tap, and the clear all button comes up fine and works. So it seems this is fixed now in 1.0.1... unless anyone with the update still has problems?