Apple Watch finally works with Airpods

Forum
watchOS & Apple Watch Apps

The automatic switching of Airpods between IPhone and Apple Watch when using Voiceover has never worked as it should and the connection between the Airpods and the Watch could only be decribed as flaky at best. Fortunately, Apple appears to have resolved the problem in IOS 12.1.4 and Watch OS 5.1.3.

I reported this bug to Apple in March 2018 and I though they had decided to ignore me but finally, the bug is gone in the latest versions of IOS and Watch OS.

Once connected to both devices, you can get the Voiceover output from either device simply by touching the screen.

If you've not updated to the latest versions, this is a very good reason to do so.

Options

Comments

Submitted by Holger Fiallo on Sunday, February 10, 2019

Nice to know. I have apple watch 3 and iPhone xx. Like my watch. It is nice and I just got a silver ban for my watch for $15 which normally I would have to pay $50 in amazon.

Submitted by Oliver Kennett on Sunday, February 10, 2019

Is this common to the W1 devices such as beats x too?

Submitted by Oliver Kennett on Sunday, February 10, 2019

Hi,

Just did the update on my iPhone and my beats x still drop the connection and the only way of choosing a device is to invoke Siri on that specific device. IE, if I want the beats X to give me the sound from my watch I have to invoke Siri on my watch and vice versa with my iPhone.

Shame. Would have been really cool for it to work seamlessly with voiceover.

Submitted by Stuart Duncan on Sunday, February 10, 2019

In reply to by Oliver Kennett

I can't confirm for certain but I tried Beats X before the Airpods were released and they had exactly the same problem.This appeared to be caused by the W1 chip. I strongly suspect that this fix will sort out probelms with the Beats also.

Submitted by Stuart Duncan on Sunday, February 10, 2019

Just for clarity, once you've done the updates on your phone and watch, you'll need to go to the Control Centre on the watch and tap the Airplay button, then select the Airpods. Once this is done, your watch and phone should work as expected with Voiceover enabled.

Submitted by Oliver Kennett on Monday, February 11, 2019

Sadly it doesn't seem to work on the beats X even when I do the suggested control centre airplay thing on the Apple Watch suggesting that this is AirPods specific. Shame. Please, if anyone else is having a different experience, let me know.

O

Submitted by Eileen on Monday, February 11, 2019

I'm not seeing any change in behaviour here.

I'm running the latest software, but switching my AirPods between my iPhone and Series 4 Apple Watch is still the same frustrating experience that it's always been.

And, yes, I've tried every possible option for initially connecting my AirPods to the Apple Watch.

Has anybody else actually seen the change in behaviour experienced by the OP?

Submitted by Holger Fiallo on Monday, February 11, 2019

Maybe the next one will fix the problem. I heard that a new airpod will be out this year.

Submitted by Charlie on Monday, February 11, 2019

In reply to by Eileen

Hi, I followed instructions and updated both my IPhone 6S+ and my Apple Watch 3. I restarted both devices, following the update, to latest IOS and Watch versions of software. I made sure that I selected my AirPods from the Control Centre, in my watch and was looking forward to everything working seamlessly. I'm afraid that there was no difference and, to swich between my phone and watch, when using my AirPods with Voiceover, I still have to activate SIRI on the device I want to move to, in order to get the AirPods to switch over.

I would really like a solution to this. Am I doing anything wrong or are there some other steps I need to follow?

Submitted by Holger Fiallo on Monday, February 11, 2019

During Christmas of last year I went to apple store about my iPhone. I did asked about this issue and the guy stated that there is nothing at this time to do regarding this. Again hope the new airpod will be better regarding this.

Submitted by Stuart Duncan on Monday, February 11, 2019

I'm devastated. After updating my IPhone and Watch, both devices were functioning as expected with Airpods and Voiceover. I was delighted.

I put my Watch on charge over night and unfortunately, in the morning, my Watch and IPhone wouldn't connect via bluetooth. I restarted both and the Airpods probelm was back. I can no longer switch beetween and connect both devices at the same time.

Oh well, at least I had a half day of what should be.

Submitted by Oliver Kennett on Monday, February 11, 2019

Fingers crossed for the W2 chip. Apple being a bit pants again with half baked promises.

Submitted by mendi on Tuesday, February 12, 2019

Okay, so I am slow to the draw here, but I had no idea simply invoking Siri would make the watch and/or phone go to your airpods. You don't even have to talk to Siri, just invoke it. Obviously, it should work correctly and I get that, but the fact I can quickly hold down a button and get it to go... I'm just glad to have found a shortcut. Now, I can finally hear my Apple Watch in loud public places!

My day has not been wasted. I learned something. :)