VoiceOver speaks through AirPlay device after being restarted while AirPlay is the selected output source

Hi!
Just wondering if any of you can reproduce this, before reporting it to Apple.
So the thing is, if I'm playing audio through my AirPlay device, in my case the Apple-TV, and then for what ever reason turn VO off and back on again, VO will then speak through the AirPlay device.
This happens both on my iPhone 6 and on an iPad Air 2, and both are running on iOS 9.2
This is very annoying, since there's a lag of several seconds when VO is speaking through AirPlay, so there is nearly impossible to get AirPlay turned off when this happens. I find the easiest way of fixing it is to reboot the phone.
So try it out while on AirPlay, just turn VO off and then back on again and see if this happens to you.
Please let me know what you find when testing this, so I can be sure this is real before reporting it.
Thanks in advance
Cliff

Forum: 

I've Noticed This Too!

Member of the AppleVis Blog Team

Hi,

I have noticed this as well with my bluetooth speakers and an Airplay speaker.
It's not ideal, but the easiest solution is to move the Rotor one place anti-clockwise to Audio Route, and swipe down.

It is difficult to hear VoiceOver through the audio which is playing on your speaker or Apple TV, so it might be useful to pause playback with a 2 finger double tap if possible.
Move the Rotor very slowly, as VoiceOver feedback seems to lag after restarting it like this.

Kind regards,
Niall

This first appeared in iOS 9.0

Club AppleVis Member

It used to be that VoiceOver always stayed on the internal speaker when using AirPlay and was routed to the external device when using Bluetooth. Beginning with iOS 9, Apple added the option in the rotor to change the VoiceOver audio destination between the internal and external routes.

Unfortunately, this new feature is very buggy in my experience. As you observed, turning VoiceOver off and back on will cause the setting to change, resulting in VoiceOver being redirected to AirPlay speakers. Furthermore, changing the setting in the rotor often causes VoiceOver to stop speaking altogether.

The only way I know of to work around the issue is to disable AirPlay before turning VoiceOver off and back on. Once the bug is triggered, the only reliable way I found to get VoiceOver back to normal is to disable AirPlay, since the audio destination option in the rotor is broken.

I reported this to Apple Accessibility a couple of times now, and I am still waiting for a resolution to the issue.