Voiceover Unusable with Learned Remote on Apple TV 4th Gen

tvOS & Apple TV Apps

I accidentally posted this in another user's topic before realising it would be better as a separate topic, apologies.

I gave my visually impaired (registered blind) elderly father my old Apple TV Generation 2 a few months ago. He uses it with a Learned Remote as he finds the small Apple TV remote too small and fiddly to hold properly due to some mobility issues, and the Voiceover reads out the movie titles, descriptions etc very well indeed.

It works great, and he uses it for the sole purpose of watching Netflix movies.

Pleased at how well this works I purchased a 4th Generation Apple TV for him so that he can also enjoy BBC iPlayer, ITV catchup etc.
I setup the voiceover and it works well with all the Apps that I tested, is great. Well done Apple, Amazon Fire is not even in the ball park.
He cannot use the small Apple TV remote very well, and two finger rotor gestures on the small touch pad are out of the question. Due to multiple strokes his speech is not good enough for Siri, so before anybody says 'just use Siri', let's not. This should not really be a problem, the learned remote that he uses on the TV Generation 2 can be learned on the Generation 4 with all the same buttons etc. Sounds simple I thought.

I setup the Voiceover - Works Great
I setup the learned remote - Works Great
Then I enabled voiceover and tried to navigate using the learned remote - TOTAL FAILURE

Remember, this is exactly what we already do on the 2nd Generation TV, and it works wonderfully.

On the 4th Generation TV, using Voiceover with a learned remote, the menus become un-navigable.
The navigation cursor selects icons that are not there (I am sighted and can see what is happening). The navigation also does not always select icons that are really there. The navigation appears to be trying to navigate in a different screen to the one that is actually being displayed.
In Netflix it becomes impossible to navigate vertically downwards, or even to move along the current row. To untrap the navigation I have to use the home button on the Apple Remote, and use the rotors to select a different navigation mode, then it works again with the Apple TV Remote. As soon as I try a learned remote again it all goes down the pan, changes the navigation mode to something unusable and locks up in corrupted navigation pages.

WTF Apple??

What works so brilliantly well in the Gen 2 is a total Train Crash in the Gen 4.
There is no working around it so far as I can work out, and I am hoping that you know better.
I think that Apple tried to be too clever with their new more complicated interface, when really all that many people need is something that is simple and works well.

If Apple want to make the new remote and TV Gen 4 really clever and more accessible here is my take on the 'missed opportunities' that I think would be helpful to many Accessibility users.

1. Most learned remotes have a wealth of 'spare buttons'. Why not let these be learned as shortcuts to any existing button or sequence of buttons, let's call it a macro.

2. Maybe allow an App to have a learned remote button, so on our learned remote we could have a Netflix Button, a BBC iPlayer button etc. Would that be such a big ask?

3. This is the real winner - as a user without speech difficulties I find that the Siri voice control allows me to do things that NO combination of remote buttons can do. For example, "Find War Movies on Netflix" instantly does exactly that.
Why not allow a learned remote button to remember a Siri submission. It does not need to do complicated voice recordings, this is immediately translated to a string of words, so just remember the words. This would allow me to setup a remote that at the touch of a button can locate exactly what my father needs to find without any 'multi-finger mini-touch pad twisting imaginary knob' actions.
Come on Apple, you have been the best. Don't drop the ball now, you are so close!!

4. The 'learned remote' has a set of learned media control buttons that are not really applicable to most remotes, yet miss out buttons that exist directly on the Apple Remote. If you are going to learn another remote it would make sense to at least copy the buttons on the Apple Remote, but Home and Volume are completely missed off, play/pause is turned into two separate buttons rather than just a toggle.
The worst omission is the HOME button, why is this excluded?

Anyway, enough rant, back to my question.

Does anybody know a way to get Apple TV Gen 4 to work with a learned remote and voiceover together in the same way that the Apple TV Gen 2 so effortlessly does.

If you can help I would be most grateful.

Thanks Steve



Submitted by themusicman08 on Saturday, February 3, 2018

First of all, I am sorry that your father has had many strokes. This has to be a big serious challenge. It sounds like their are compatibility issues with the learned remote from the 2nd generation Apple tv. With that being said, I would suggest that you maybe call Apple's accessibility hot line and maybe see what they have to offer. That number is,
They are open twenty-four-hours a day, seven days a week. I have stumped a few customer service reps with questions that they've had to send as tickets to engineers.

Submitted by Justin on Saturday, February 3, 2018

Hi Steve.
What about using a bluetooth keyboard with the apple TV instead of the learned remote? It's definitely compatibility issues between the older remote and the newer apple TV. Do you know if there's a new er version of that remote available for the 4th gen apple TV? I'm not exactly sure, as I currently don't have an apple TV, but I thought about using a bluetooth keyboard with the device. Maybe that would work easier, or maybe that would just open a whole new can of worms.

Submitted by John Lipsey on Saturday, February 3, 2018

The phone number given for Apple accessibility is the US number. Based n the list of apps you mentioned, I assume you're in the UK. In that case, you'd want to ring Apple's accessibility support number on 0800 048 0754.
I'm hopeful they can resolve this issue of you, or at least move it up the chain to someone who can.
Good luck!


Thank you for your reply. I will most certainly call the hotline.

I have reported the problem to Apple support, and I am surprised that they did not tell me about this hotline. They advised me to submit the problem as a bug report via apple.com/feedback which of course only allows me to send my problem to Apple, but receives no response or support.

Regarding remote controller incompatibility, I have learned 3 different controllers now so that my dad can choose the one that suits him best. All work perfectly in every way until voiceover is enabled, then none of them work.

Searching the web I find that this problem seems to have affected many users since they upgraded to iOS 11. The problem seems to be ‘QuickNav’. It seems that QuickNav cannot be disabled. I am reading that it also affects users of the AppleTV remote until they use the rotors to set ‘direct touch’ navigation, but this setting does not stick. If I choose ‘Direct Touch’ fron QuickNav then use the learned remote to run the Netflix app it jumps back into unusable mode again.
The holy grail would seem to be to disable QuickNav so that the remote can be used as it was in iOS 10.

From reading many posts this is my understanding.

All help and advise is gratefully received.

Thank you again for the Apple hotline number.


Submitted by Steve on Saturday, February 3, 2018

In reply to by John Lipsey

Thank you John

I shall try the UK mumber also. If it is not 24/7 I can call USA at no cost, and the problem is not app specific do I am sure either will be equally applicable.

Thank you for your help, I really am grateful that people are so quick to come forwards with genuinely helpful information.

Best Regards

Submitted by Cliff on Sunday, February 4, 2018

Hi Steve! Sorry about all your problems. Many of us are also facing some VoiceOver issues on Apple TV after they made some differences in iOS 11, that not necessarily is for the better.
But I just had an idea when you mentioned that this probably is related to quick nav.
Try connecting a bluetooth keyboard to your fathers Apple Tv. Then when the keyboard is connected and working, and VO is turned on, try pressing both left and right arrow keys on the keyboard simultaniously. I have never had a keyboard connected to my TV, but this is the way one toggle VO quick nav on or off on either Mac or iOS, so it probably works on the Apple TV as well! And if it works to toggle quick nav off, then we'll just have to hope that it sticks and don't go back to quick nav on when the Apple TV is idle for a while and wakes up from sleep/standby mode.
It's anyway worth a try! :)
Take care
Cliff from Norway! :)

Submitted by Steve on Sunday, February 4, 2018

In reply to by Cliff

Hi Cliff

Thank you for the suggestion. I have an Apple bluetooth keyboard. I will give it a try and post the results back here.


Submitted by Steve on Sunday, February 25, 2018

Thanks again to everybody who offered help and suggestions.

I called the UK hotline number and worked through the problem with a very helpful Apple support rep. It turns out that the problem is not actually with the Apple TV 4 voiceover and learned remote combination, but with the Netflix App.

The key to everything working well with a learned remote (except for Netflix) is to set ‘Vertical Navigation’ on the rotor.
To a sighted person like myself Vertical Navigation can appear to be misbehaving as moving up or down announces the first item on the row you move to rather than the item directly above or below the cursor position, but this makes complete sense if I remember that it is not designed to assist sighted users.

If I tried to replicate the navigation problems in another app (BBC iPlayer for example) everything works just fine. The reason that the problem appears to extend beyond the Netflix App is that once it is all jammed up in Netflix you need to turn off voiceover to extract yourself from the problem. If you stay clear of Netflix all seems to work just fine.
Apple have eMailed me the appropriate contact details for Netflix support and I will be following this up with them. I hope that they are as helpful as Apple.

I will update this thread again when I have made further progress.

I have to add that the quality of the support offered by Apple was outstanding. The support rep actually went away and learned a remote then replicated the issue while I waited on the phone, then used a screen view session on my iPhone to view my TV using the iPhone camera so that he could view my exact problem for himself.
Well done Apple.