Is tvOS 14 broken, or is it just me?

Forum
tvOS & Apple TV Apps

Hi folks.

So, I’ve downloaded and installed tvOS 14, mainly because the control Centre did not work with voice-over. However, I found it to be a less than positive move. Whenever I swipe down, it seems it misses out items and jumps from item one to item 3, for example. The rotor seems to have lost things like direct touch and I’m finding the whole experience quite cumbersome. Is it just me?

Options

Comments

Submitted by Jim D on Thursday, September 17, 2020

Kerry:
Try performing a two finger triple tapp This moves between explore and navigation mode. This should get you your rotor options back.
Jim

Submitted by elliot2012 on Thursday, September 17, 2020

I had the same problem initially, had to go into settings and change focused from direct touch to follow focus

Submitted by Paul on Thursday, September 17, 2020

I wouldn’t know if I was experiencing the same issue, because I don’t even have speech. It’s similar to the control center issue the OP mentioned, except that I don’t even hear which rotor item is selected even though I can hear the rotor sounds.

Submitted by Roxann Pollard on Thursday, September 17, 2020

Hey Paul, have you tried using SIRI to restore speech or using the triple tap of the top left-hand button to do the same?

HTH

Submitted by Roxann Pollard on Thursday, September 17, 2020

Hello Elliot. Thanks for posting your suggestion. Apple TV performs just as expected, once I changed the setting. Appreciate you.

Submitted by Paul on Thursday, September 17, 2020

Being an experienced user, it’s the very first thing I tried. I even tried restarting the Apple TV again. I haven’t been able to figure out how to fix the issue.

Submitted by Chris Gilland on Thursday, September 17, 2020

TVOS 14 has proved to be an absolute disaster! I have speech, thank god, but only barely. The two finger tripple tap is doing absolutely nothing for me of any use. I, too, find, most notably under Settings, that items are skipped, and certain things which aren't skipped simply aren't read. I've tried direct touch, and also follows focus. Both are having this issue. It was this way all the way back to the first dev seed. Reported, but, yeah... At least iOS is much better than this as far as not being too buggy. LOL!

Submitted by Roxann Pollard on Friday, September 18, 2020

Sorry that didn't work. I thought you would have already tried my suggestions but wanted to post them just in case.

Submitted by Jim D on Friday, September 18, 2020

I haven't noticed items being skipped in TV OS 14. In earlier versions of TV OS however, I set touch tracking to slow under the remote control options. This seemed to make the remote much more usable with Voiceover. You may want to give this a try.
Jim

Submitted by Missy Hoppe on Friday, September 18, 2020

I was pretty disappointed with tv OS 13, so imagine my surprise when things actually got worse under tv OS 14. For me, the roter is virtually useless; only thing on it is actions, but then, if I flick up to close an app, for example, nothing happens. Extremely disappointed. I'm still not sure what I think of iOS 14 either, but the issues I'm having with it aren't nearly as show-stopping as the trainwreck that is TV OS 14.

Submitted by Paul on Saturday, September 19, 2020

In reply to by Roxann Pollard

Finally solved the issue. Turns out that for some reason no audio channels were selected for speech output (the setting at the bottom of the main VO settings screen). It wasn’t something I initially thought to check since speech was obviously being output before the update and none of the hardware had been changed.

Submitted by Kerry Fielding on Saturday, September 19, 2020

In reply to by Jim D

Hi Jim. This has definitely made things a lot easier though wierdly when I turned on the Apple TV this morning after not using since the day i upgraded, things seemed a lot more stable. I changed the tracking to slow anyway. The 2-finger tripple tap also helped. Cheers

Submitted by Troy on Saturday, September 19, 2020

apple tv has been an absolute disaster since tv os11 and this prooves to be no different in fact much worse. Time to ditch and sell my apple tv and just stick with my firestick and chromecast. Sorry apple.

Submitted by Jim Fettgather on Sunday, September 27, 2020

I I wonder if there is a list of commands, documentation, any info at all regarding Voiceover and IOS 14? I have not been able to find anything on Apple's web site.
Once I got the rotor options back thanks to Jim D, things seem to be somewhat more useable, but apps such as Netflix, Youtube, Hulu, CBS All Access, and Prime Video have their own unique interfaces, so can certainly take some time to learn.
Thanks.

Submitted by Chris Gilland on Sunday, September 27, 2020

Would anyone by chance happen to know if you can pare MFI hearing aids directly to the Apple TV 4K with TVOS14?

Submitted by Kerry Fielding on Monday, September 28, 2020

Hi Chris. I think what this gesture does is change from direct touch to cursor tracking or whatever the other option is.

Submitted by Kerry Fielding on Monday, September 28, 2020

Hi. We have only had our Apple TV since July, and I know when I got it, I found a list of tvOS 11 by simply googling. Also, it is unlikely that Apple will provide commands for using third-party apps such as Netflix et cetera. I have generally found that if I use the Apple TV app to search for stuff, it will bring up the name of that program if it exists on any of the platforms you have installed, which I think is a great feature by the way. My only gripe with it is that if the program appears on BBC iPlayer (a platform available only in the UK), it doesn’t bring up the audio described version. For some reason best known only to themselves, the BBC have chosen to put all audio described material under a separate category on its platform, so, rather than allowing you to turn on audio description in the app and simply have any program audio described, you have to hunt for it. I’ve complained to them about this, but no changes as of yet.

Submitted by Jim Fettgather on Thursday, October 1, 2020

Again, using TVOS 14.01, for some reason when on what is called the top shelf, where it seems you can flick right to see recently viewed programs, often, the clicker will just bong and not launch a program. I have tried Vertical Navigation, and a fairly new setting that was formerly called follow focus, but I sure must have a setting that is set incorrectly to not get the clicker to activate an item.
Just curious if anyone has noticed this behavior, and thanks a lot.

Submitted by Geoff on Monday, October 5, 2020

I have no idea if it improves anything, but I saw it posted earlier tonight so thought I would add it to this thread. I haven't made the time to play with tvOS 14, so I'm glad to have read this thread first.

Submitted by stewart meas on Sunday, October 18, 2020

After update to tvos14.2, HomePods aren’t even on list of audio outputs. I can’t even set them up as default audio output. TvOS needs another update now I’m back to my weak tv speakers.

Submitted by Matt Taylor on Wednesday, October 21, 2020

Hi all,
I have discovered today how to get follow focus back on TVOS 14. If you go into settings, accessibility, voiceover there is an option in there that is automatically set to direct touch, if you click it, it changes to follow focus. Why it couldn’t just remain on the rota I don’t know.
I agree with what other people have said, the accessibility on TVOS 14 is extremely cumbersome and unnecessarily difficult. They have turned a device which was very useable, into something that is quite difficult to navigate at times.
I hope this helps though, even a little.
Thanks,
Matt