Second generation Apple TV - Audio Description on Netflix

tvOS & Apple TV Apps

I'm trying to get audio description on Dare Devil via Netflix on my 2nd gen Apple TV. When pressing and holding the "select" button on the remote, voiceover doesn't read out the additional menu.

I've signed out of Netflix and back in again, and still the same.

Is this a 2nd gen Apple TV issue? Or does anyone with a 3rd gen have the same issue too?

If it is the 2nd gen issue, then I might consider buying the 3rd gen, and then the 4th gen when it's out....




Submitted by sockhopsinger on Monday, April 20, 2015

Did you listen to the podcast that David Woodbridge did on accessing the audio description? Sorry if this seems like a ridiculous question, but hey, questions gotta start somewhere.

Submitted by Ray on Monday, April 20, 2015

In reply to by sockhopsinger

Hi. Thanks for your response.

Yes, I did listen to David's Podcast. He demo'ed selecting AD just after playing the second episode of Dare Devil. BUt on my 2nd gen Apple TV, when I try to select the language options, VO doesn't read out. I did post a comment and asked about that, and some others posted something similar, but the issues digressed somewhat. Hence my new post.

I've seen a few posts here about Netflix doing an update on their app, and some others was querying 3rd gen Apple TV. But my specific query is on 2nd gen Apple TV, and why VO doesn't read out the additional menu when selecting language options when playing a film/tv programme.

I've noticed VO doesn't read out this additional menu on regular iTunes/Apple TV purchases as well. SO I reckon it's a 2nd gen Apple TV issue. I just wanted to ask if anyone else here has the same issue, or is it just me?

On the other hand, I have no problems accessing AD on Dare Devil via the Netflix app on the iPad, works brilliantly...

Just to recap... 2nd gen Apple TV, I select Netflix, Dare Devil and play an episode. After about 5 seconds or so, I press pause, then press and hold the main Select button. An additional language menu pops up. VO doesn't read this menu out at all, so I have no idea whether AD is an option. I hear the click noises when cursoring up or down, but no VO...

Any ideas?


Submitted by sockhopsinger on Monday, April 20, 2015

I don't even know what generation I have, but I don't have problems getting it to read. I don't know if this will help or not, but have you tried restarting your AppleTV after logging out and back in to Netflix? Sorry I can't be more help, but that is all I can think of.

Submitted by Ray on Monday, April 20, 2015

Yeah, I've restarted the Apple TV and signed out of Netflix.. Had my Apple TV for about 4 ish years now... Might try again when I get back home tonight...

Might have to implement plan B.... Buy the 3rd gen Apple TV... ANy excuse for a new toy....

Thanks anyway.

Submitted by Amy on Friday, May 8, 2015

I, too, have a 2nd generation Apple TV, and am experiencing the very same thing. Not only do I have the exact same results as you when attempting to enable audio described content on Netflix, but the option for audio description is completely missing from my accessibility settings with regards to iTunes content. This, after insuring that, I am running all current OS updates. I do believe, unfortunately, that this, is, a 2nd gen apple tv problem; and not user error. *frown* Ah well... that will just mean that it'll make me upgrade at some point. HTH...

Thanks Amy..

Nice to know it's not just me... I'll sit tight until after WWDC in June and see what Apple can pull out of the hat for 4th gen Apple TV. But in the mean time, I've been using the Netflix iOS app and airplaying it via the Apple TV to watch AD content. So not bad I suppose.

Take care