ENABLING DESCRIPTIVE AUDIO FOR APPLE TV THIRD AND FOURTH GENERATIONS ON NETFLIX CANADA

Forum
tvOS & Apple TV Apps

I have enabled descriptive audio and made sure it is turned on from the settings menu of both the third and fourth generation apple TV devices that I have. Yet when I go to play either marvel's daredevil or the crown in Netflix the audio description does not play on either apple tv device even though descriptive video has been turned on. By contrast when I enabled audio description in settings on my IPhone 6, descriptive audio for both these shows played fine on the phone when I went into Netflix. So what am I doing wrong here? Has anyone else run a cross this situation? help would be much appreciated; the apple accessibility line was of no help at all.

Marc Baillargeon
Edmonton, Alberta Canada

Options

Comments

Submitted by Siobhan on Tuesday, November 8, 2016

Hi Mark. Did you sign out, then back in with Netflix on both devices? I've heard sometimes that helps. Sorry I'm not more useful.

Submitted by That Blind Canuck on Tuesday, November 8, 2016

Hi Marc,

You might also want to contact Netflix Canada directly, there is probably something they need to do at their end.

I know back when I first got my Apple TV 4, the Netflix app needed an update in order to make it work, but in the meantime, we were told to contact Netflix directly as they had to enable it on their end. Now this was quite a while ago and I would have thought that an update would have been released by now, but perhaps not. This is why you might want to contact Netflix Canada, they might still need to do something at their end.

Another thing as well, you might want to make sure that when you open the app, you go under the same profile as the one you use on your phone and while playing content, check the audio tracks to make sure that the DV track is selected. If you do not see a DV track, then this means you will probably have to contact Netflix directly, and when they enable it, then the DV track will become an option that you can select.

Hoep this helps!

Submitted by JLove on Saturday, March 4, 2017

I had the same issue. Then I realised I had changed the language on the audio language setting.
Go to settings, Audio and video, audio language. Do not change the language to English, or any other language. Set it to default.
Also, make sure the Audio descriptions setting is on, on General, Accessibility.
If it still doesn't play, make sure you choose English with audio description from the audio menu on Netflix. The Apple TV does not save the setting automatically like the iPhone.
If you would like to, or need to change the language of the video on netflix, do it directly from Netflix.