AppleTV issues

tvOS and Apple TV Apps
Hi. Anyone have a problem with their AppleTV when trying to watch online content? I have an subscription, and for a while everything was working fine. Lately, it keeps losing its connection. My router is an Airport Express, if that matters at all. Then, last night, I bought a movie on Itunes and tried to watch it on my main system through my AppleTV. Ditto! Same problems. My AppleTV software is up to date. I had thought about trying a reset on my Airport Express, thinking that might be part of the problem, but am unsure how to reset the router. Any suggestions or help would be appreciated. Thanks.



Submitted by Dave Nason on Monday, May 27, 2013

Member of the AppleVis Editorial Team
Hi. I actually have this problem sometimes too, especially with my 2nd generation Apple TV. At the risk of speaking too soon, my 3rd generation doesn't seem as bad so far. I've noticed that it can happen a lot for several days in a row, but then it can be fine again for ages, it's very strange.

Submitted by Cliff on Tuesday, May 28, 2013

In reply to by Dave Nason

Yupp, same old story! The airplay icon disappears, and there's always a struggle to get it back. The first thing to try, is to turn airplay off and back on again on the apple tv. This works most of the time for me. The next to do on the list, is turning wifi off and on on your device, in my case an iPhone. Then if that don't work, restart your router, after letting it sit for half a minute before turning it back on. A reset of the router could also help. Most routers have a little whole on the back side, which contains a tiny button that can be reached with a pen or some other thin item to reset. Usually, you hold this button for some seconds until the lights go off on the router. But beware that this also reset your wifi password. I think I finally managed to do a more permanent fix on my router, by entering the router settings and enabling multicast streaming. Have worked fine after that now for a week, but you never know... This behaviour started happening for me after the last apple tv software update, and I think that is to blame. But I also have trouble sometimes with the iPhone not finding my airprint printer, and that seems to be happening at the same time as my airplay icon is on vacation, so that again makes me suspect the router for being the bad boy here... Don't know if any of this helped. But let us know if any of you has a final solution, once and for all! :)

More Like This