TVOS accessibility after update

Hi, has anyone else updated to the latest TVOS yet and if so how are people finding it? I am finding navigation a little tricky and also in my Movies Wishlist and TV Favourites voiceover is now just saying "1 of 16, 2 of 16, 3 of 16, etc, instead of reading out the name of the film or tv programme.


TV OS 11 accessability issues.

I have updated to it, and it's been rather disappointing. I am having a hard time with the media controls in netflix. Sure, I can get Siri to do those things for me, but still, it was accessible in TV OS 10, why isn't it in 11? Maybe we should let Apple know about this.

Very dissappointed in TVOS update

I have two Fourth Generation Apple TV units, and unfortunately, both have been upgraded to TVOS 11. IMO, the apple TV was the most accessible it's ever been when it was first released. Things weren't great under TVOS 10, but I had learned to live with the stuff that bugged me. Now, things are much, much worse. The remote only seems to work when it wants to; it's like it has to be on a certain setting before it can respond, but no matter what I do, it won't stay on whatever that mystery setting is. I don't like how the homescreen navigates now. It used to be that the cursor would stop at the end of every row of apps. now, you can just swipe left or right indefinitely, and staying within or navigating to a specific row of apps seems all but impossible. To me, this is the equivelant of the trainwreck that was iOS 8. Maybe another update will come out to fix things, but I sure wouldn't get my hopes up; all of the issues I first discovered in TVOS 10 remained present until yesterday's update. If anyone out there is having a more positive experience, please share how you're getting things to work consistently.

tv os11 is a disaster for me

hi just updated to tv os11 and its a disaster for me.
I can't navigate the guide in directvnow.
I use to in tv os10 just fine.
Its a whole new interface.
Also can't close apps

It's different

Well the subject says it all. Using the Apple TV with the New OS is just a different experience. I don't want to be rude but it makes me sad and honestly a bit angry that the blindness community just assumes something can't be done just because we have to adapt to a new paradigm.

Think about it this way: All Apple did was to bring TV OS and iOS closer together. So if you want to go to the next element just swipe to the right. If you don't like that just toggle direct navigation in the rotor and learn the layout of your favorite apps. So you see that there is a way to get close to the old way things used to work.

If something really is a accessibility problem of course we as a community should give Apple some constructive feedback but just saying that something doesn't work or is a catastrophe just because we don't want to adapt is just scary.

In my Opinion the old way was more intuitive however remember? We had to get used to it too. And honestly I expected TV OS to behave like iOS the first time I got my hands on it.

Things like media controls for example in Netflix have to be reworked to be more accessible. Until that is done why not just use Siri? I mean there is a way to get things done. So I prefer to do them that way then and try to give Apple as good as a feedback as I can. So they have a fair chance to improve things that arn't running correctly.

trouble navigating tv os11

hi after updating to tv os11 i am trying to move through the directvnow guide but i can't.
I been playing with it but it will read the channels in the guide.
But if i swipe right it use to read me the show thats on.
Now it reads a show from another channel.
It worked fine under tv os10
i'll still play with it.
I noticed in the rotor setting navigation is gone.
Now vertical navigation is there

Inconsistent remote behaviour

I have had a lot of issues with the remote appearing not to respond to swipe gestures e.g. up and down. AT times I have also been unable to select items by pressing down on the remote touch surface. I get an error sound like the sound that is played when you have reached the edge or bottom of the screen, and nothing happens. One place where this happens consistently is in the Radio tab of the music app when trying to activate the sub-tabs under radio ("Beats 1", "Featured" and "Stations". Resetting the apple TV has improved some of the issues with general responsiveness and reliability of selecting items with the remote, but this has not fixed the issue in the "Radio" tab of the music app.

TVOS 11 and Direct TV Now

Updated my 4th gen Apple TV to TVOS 11 when it first came out, and it took me a while to get used to the way the Apple TV remote works under TVOS 11. It's somewhat annoying with all the rotor use to do things that were simple to do in TVOS 10, but I've gotten used to it. Wanted to share that with a bluetooth keyboard connected to the Apple TV, Direct TV Now's channel guide becomes far more usable... I'm able to use the arrow keys and the enter key to scroll and select something to watch in the guide. Usually what I'll do is scroll up and down to see what's on, then arrow left to land on the channel name, which is a button and then hit enter. The currently airing program shows up and I hit enter to begin watching it. With the Apple TV remote, once you reach the top of what's currently displayed on the guide page you're on, you have to go back to the top again and select a channel to change it, click to show it, then go back to the guide to continue to the item that's above what channel you're currently watching. Same issue comes up at the bottom of the current guide screen... Try the bluetooth keyboard tip and let me know what you think.

Follow Focus

Not sure if this will help anyone, but if you switch the rotor to "follow focus", that seems to change the navigation back to tvOS 10 behavior. For example, since the tvOS 11 upgrade, when using Netflix, it was difficult to move from one row to the next, and the row titles were sometimes read on their same line. Since I changed the rotor to follow focus, it behaves just as it did in tvOS 10 with the navigation much easier and the row titles now being read correctly.

Reply to Roxann

The option showed up automatically for me. Are you on the latest update?

Follow Focus

I too recently changed my Apple TV to Follow Focus and it has been an improvement for navigating then before. Although one thing I did notice though, anytime you pull up the keyboard, usually when searching for something, when in Follow Focus, it appears that VoiceOver doesn't see the edit field. I don't recall, but in iOS 10, couldn't you bring VoiceOver to the edit, or search, fields?

Voiceover Unusable with Learned Remote on Apple TV 4th Gen

I gave my visually impaired (registered blind) elderly father my old Apple TV Generation 2 a few months ago. He uses it with a Learned Remote as he finds the small Apple TV remote too small and fiddly to hold properly due to some mobility issues, and the Voiceover reads out the movie titles, descriptions etc very well indeed.

It works great, and he uses it for the sole purpose of watching Netflix movies.

Pleased at how well this works I purchased a 4th Generation Apple TV for him so that he can also enjoy BBC iPlayer, ITV catchup etc.

I setup the voiceover and it works well with all the Apps that I tested, is great. Well done Apple, Amazon Fire is not even in the ball park.

He cannot use the small Apple TV remote very well, and two finger rotor gestures on the small touch pad are out of the question. Due to multiple strokes his speech is not good enough for Siri, so before anybody says 'just use Siri', let's not. This should not really be a problem, the learned remote that he uses on the TV Generation 2 can be learned on the Generation 4 with all the same buttons etc. Sounds simple I thought.

I setup the Voiceover - Works Great
I setup the learned remote - Works Great
Then I enabled voiceover and tried to navigate using the learned remote - TOTAL FAILURE

Remember, this is exactly what we already do on the 2nd Generation TV, and it works wonderfully.

On the 4th Generation TV, using Voiceover with a learned remote, the menus become un-navigable. The navigation cursor selects icons that are not there (I am sighted and can see what is happening). The navigation also does not always select icons that are really there. The navigation appears to be trying to navigate in a different screen to the one that is actually being displayed.
In Netflix it becomes impossible to navigate vertically downwards, or even to move along the current row. To untrap the navigation I have to use the home button on the Apple Remote, and use the rotors to select a different navigation mode, then it works again with the Apple TV Remote. As soon as I try a learned remote again it all goes down the pan, changes the navigation mode to something unusable and locks up in corrupted navigation pages.

WTF Apple??

What works so brilliantly well in the Gen 2 is a total Train Crash in the Gen 4.
There is no working around it so far as I can work out, and I am hoping that you know better.
Apple tried to be too clever with their new more complicated interface, when really all that many people need is something that is simple and works well.

If Apple want to make the new remote and TV Gen 4 really clever and more accessible here is my take on the 'missed opportunities' that I think would be helpful to many Accessibility users.

1. Most learned remotes have a wealth of 'spare buttons'. Why not let these be learned as shortcuts to any existing button or sequence of buttons, let's call it a macro.

2. Maybe allow an App to have a learned remote button, so on our learned remote we could have a Netflix Button, a BBC iPlayer button etc. Would that be such a big ask?

3. This is the real winner - as a user without speech difficulties I find that the Siri voice control allows me to do things that NO combination of remote buttons can do. For example, "Find War Movies on Netflix" instantly does exactly that.
Why not allow a learned remote button to remember a Siri submission. It does not need to do complicated voice recordings, this is immediately translated to a string of words, so just remember the words. This would allow me to setup a remote that at the touch of a button can locate exactly what my father needs to find without any 'multi-finger mini-touch pad twisting imaginary knob' actions.
Come on Apple, you have been the best. Don't drop the ball now, you are so close!!

4. The 'learned remote' has a set of learned media control buttons that are not really applicable to most remotes, yet miss out buttons that exist directly on the Apple Remote. If you are going to learn another remote it would make sense to at least copy the buttons on the Apple Remote, but Home and Volume are completely missed off, play/pause is turned into two separate buttons rather than just a toggle.
The worst omission is the HOME button, why is this excluded?

Anyway, enough rant, back to my question.

Does anybody know a way to get Apple TV Gen 4 to work with a learned remote and voiceover together in the same way that the Apple TV Gen 2 so effortlessly does.

If you can help I would be most grateful.

Thanks Steve