two problems, need advice

Other Apple Chat
Running on a pc here... so not sure how many people will be able to help me on this one. lol This is more a general problem, but since it only happened after I updated itunes and my iphone is the main problem, thought I would post it anyway... My computer is not letting me connect any new USB devices to it and registering them. Every time I do and check the device status in the device manager, it tells me that Windows cannot initiate the driver for this hardware and gives me a code 37 error. This includes, but is not limitted to usb keyboards, apple products and guitar effects processors.. the weird thing is, my ipod worked fine before... and when I connected my iphone the first time it told me that I had an outdated version if itunes. And now that I have the latest version, neither my ipod or iphone work. Doesn't even charge them. Second problem is actually on my iphone under IOS 6... I got a bluetooth keyboard for my iphone yesterday, and have been trying to connect it. I got it paired, but every time I connect it it'll connect for a couple seconds and disconnect again until I press the pairing button on the keyboard and try again. Weird thing is... I don't think it's the power, because my keyboard is plugged in. any help with both of these problems would be much-appreciated.. and I just got my iphone, and want to start using it but can't... it's the most frustrating thing! lol



Submitted by Shaun Uk on Tuesday, January 1, 2013

Hiya mate, A code 37 error in Device Manager means there was a problem with the driver. Now as this only started after installing / updating iTunes the first thing to try, (assuming you've already tried the trusty turn pc off and back on again trick), is uninstalling iTunes and restarting pc. If this fixes the USB problem then try reinstalling ITunes again. If uninstalling iTunes doesn't solve the issue, then your windows USB device drivers or registry values could be corrupt. I've had this problem a few times myself on both Windows XP & 7. There's a few ways to tackle this. (You don't say what version of windows you are using so can't give specifics, but here's some tips) 1. If you use System Restore Points then simply roll back to last saved point. 2. Run the System File Checker utility. (in an Adminstrator Command Box type sfc /scannow). 3. Edit registry values. Google "code 37 error device manager" for more details. To be honest, the method I always use is to uninstall the usb controllers from device manager and restart the pc. This forces windows to reinstall the USB drivers. However, I suppose there's a chance that Windows fails to reinstall them although that has NEVER happened to me it's something to bear in mind. 1. Go to Device Manager. 2. In the treeview of devices go to Universal Serial Bus Controllers. (usually at end of list). 3. Expand the USB Controllers and uninstall any device that says USB Root Hub or USB Generic Hub. (I just press the DEL key when I'm on the item I want to remove.). 4. Answer yes to the are you sure dialogs and when you've removed them all restart the pc. 5. Windows will restart and then start to reinstall the usb drivers. Let it finish and then restart again. 6. Plug in a usb device and see if it works. Oh and can't help with keyboard problem, but have you tried letting it charge overnight or at least a few hours first? I know you say you have it plugged in and I agree that should be fine but I can't think of any other reason other then power loss why it would disconnect. Or could just be faulty I suppose.... Hope this helps and good luck!. Shaun

Thanks for all those tips... I think I am going to try uninstalling all the USB host controllers and see f it works. But just in case windows for some reason doesn't reinstall all the drivers, what do I do to restore them? Also, I'm on windows XP... an if I uninstall itunes, do I lose my library or whatever when I reinstall it? If so, how do I export my library so that I can get it back without having just to readd everhing? As to the keyboard... I did try letting it charge overnight. I tink it's probably faulty. lol