iPod nano battery life problems

Other Apple Chat


I'm having some strange battery life problem, this time on my iPod nano. I plugged it in the other day into a wall outlet when it came up low power and left it to charge for about 3-4 hours. When I came back to it and unplugged it, the battery level was at 30%, which I thought wasn't right and it hasn't been giving any stable indication since.
I was listening to music with it shortly after for about 10 min and it had gone down to 22%. After doing some Googling I read somewhere that turning bluetooth off could solve it. This made it worse, literally as soon as I turned bluetooth off it went from 22% to 9%.
The reset by pressing and holding the home and power button doesn't seem to be available on these either. I tried this and had them held for about 5 seconds until it said "iPod shutting down", only it doesn't restart like iOS does. Nothing happens until I press and hold the power button, and it boots up within a couple of seconds, as if it has been on sleep mode and no change to the battery thing.

Any suggestions?




Submitted by DPinWI on Thursday, June 26, 2014

I have a nano 4th generation. When I reboot it, I hold the top of the ring, and the middle for a few seconds. It shuts off, and takes a while to reboot and come back to life. Given how fast you say your device is rebooting, I wonder if you aren't getting the reboot sequence on your nano quite right.

Sorry, that's all I've got. Good luck.

Submitted by dvdmth on Thursday, June 26, 2014

Club AppleVis Member

I can think of two possibilities that could cause that.

First, it may be a faulty charger. I had that very experience with an iPod shuffle, where I left it plugged in overnight and had almost no charge the next day. I had another charger for the shuffle, and that charger worked fine, so in my case it was a faulty charger.

On the other hand, the rechargeable batteries in these devices will wear out over time. Depending on how old your device is, it's possible your battery is at end of life.

Either way, it's probably a hardware issue, either with your charger or with your iPod. You may want to contact Apple about this.

Submitted by Callum on Thursday, June 26, 2014


Thanks for the replies. Perhaps I should have posted this a bit earlier but I managed to get in touch with Apple support and they advised me to reset all settings on the iPod, wait until the battery completely drains then fully charge it again. It's charging now and the indicator is working as it used to so far. I think this will have resolved it.

To the replies, it's an iPod Nano 7th gen, I was meant to put that in somewhere, and I knew it wasn't my charger as I use the same one for my phone and it charges it fine.

Thanks again though