Facebook on Mac with El Capitan

Other Apple Chat

Hi everyone,
Ever since I upgraded my Mac air (earlier 2015 version) to El Capitan, I get stuck when updating facebook status using social widgets on the notification pannel because once I typed the text for whatever status, I can neither add a location nor can I find the usual post / send button that was there earlier. When I hit VO + space to submit my status update to Facebook, the VO either says that I pressed the Facebook Button or the Twitter button. What could be the reason for this weird behavior?
I even tried to navigate using trackpad commands but had no luck with it so far.
Any help / tips with this regard would be greatly appreciated.



Submitted by carine on Wednesday, October 28, 2015

Unfortunately, I note the same problem here, with a macbook pro, and osx el capitan!
Is it an accessibity problem, or we can't post a facebook status feels to the notification center anymore? that is the question!
Any help wil bee apreciated too!
Carine from Nice, france!

Submitted by Piotr Machacz on Wednesday, October 28, 2015


There seems to be a problem that the VoiceOver cursor doesn't want to get to the controls to send the post, add a location and so on. However, the keyboard focus can still get there. Just tabbing only inserts tab stops into the text, but if you press ctrl-tab, it works. Pressing ctrl-tab will move you passed the edit text to "cancel" and "post" buttons, while pressing ctrl-shift-tab will move to the controls before the edit box "add location" and the pop-up button that lets you choose the audience.

Submitted by Jay Bee on Wednesday, October 28, 2015

In reply to by Piotr Machacz

Thank you Piotr . That partly solved the issue by enabling me to navigate beyond the text field. But even if I somehow get to the post / Cancel buttons, There doesn't seem to be a way to press them. When I navigate to either of the buttons and when I hit the regular command of pressing a button which is VO + Space bar, that doesn't press the post button as in the usual case. Is there any way to solve this part of the problem as well?
Thanks in advance!

Submitted by Piotr Machacz on Wednesday, October 28, 2015

As I said in the previous comment, the VoiceOver cursor does not want to follow the keyboard focus into the composing controls of the widget. Pressing VO-space activates the control under the VoiceOver cursor, which in this case is probably still sitting on the button to bring up the Facebook post dialog. So, what you can do is press the space bar or enter which activates whatever the actual keyboard focus (the thing that moves when you tab around) is.

Submitted by Jay Bee on Wednesday, October 28, 2015

The space bar thing surely worked like a charm!
Thank you so much and sorry for getting you to explain almost the same thing again more or less!