Cydia and errors with random package listings

Other Apple Chat
Hello! I've got the following problem: since about a month i have this problem when cydia after it's done refreshing the packages list throws an error of "Wow! You exceeded the number of versions this apt is capable of". Then "Problem with (Here the patch tpo some random package listing file of a random repo" and finally "The package or status file couldn't be parsed or opened". I've tried removing the faulty package listings but then either it will have problem with other file or even with Status in DPKG or it will stop for a while then come back with it again. Maybe one of my repos is faulty But then i've tried removing those which i've added recently and it doesn't do the trick still. what can i do to stop it from happening? It's really annoying mew. Thank you in advance. best regards Paweł



Submitted by Ken Ewing on Saturday, September 10, 2011

Try reinstalling all APT packages (Manage>Packages). Let me know if this works.

Submitted by Paweł Masarczyk on Sunday, September 11, 2011

In reply to by Ken Ewing

So what i'm supposed to do is to reinstall the apt package under manage > packages? hmm i think it's a bit impossible as while trying to hunt down the problem i removed the old status file from DPKG which was also affected by my error and resulted in Cydia forgetting what packages are installed. Now it claims that there's an update for the APT package but it won't let me install. the error sounds something like "Maybe a package cycle".

Submitted by Ken Ewing on Sunday, September 11, 2011

I'm not sure what all you've done to try to resolve this problem so I am only trying to help. You said in your last post that you deleted the /var/lib/dpkg/status file. I am assuming from the tone of your post that you didn't copy it anywhere else or rename it before deleting it just in case. Is there a /var/lib/dpkg/status-old file? If so: 1. Copy the status-old file to a different location in case you need to use it again 2. Rename /var/lib/dpkg/status-old to /var/lib/dpkg/status 3. Respring If this works then try reinstalling all APT packages. Let me know the results.

Submitted by Paweł Masarczyk on Friday, September 23, 2011

In reply to by Ken Ewing

Hello there~! Yeah i've tried that status-old trick. Sometimes it worked but only for a while sometimes it didn't work at all. I was even forced to recreate Status so i just removed it, created a new one in Notepad and saved it where it belongs. It also worked but only for a while and then kept breaking again. I've tried also to reinstall the apt packages and to no avail. I have a feeling that the destructive source is the Ispazio one. Everytime it's loaded in the sources list the destruction starts - tested with many devices. Not sure about the results without it but it was the first one to crash and sometimes removing it stopped all the trouble for a while. I've tried cleaning it out from every place that the Cyfix scripts cleans in and it still crashes. I just hope that the system restore is not my only alternative for now. I appreciate your help. Thank you. Have a nice day/evening Best regards Paweł