Can not get rid of an album from my iPhone

Other Apple Chat
Hello, I have a couple of compilation albums which have gone under "various artists". To try and free up storage, I am storing these on my iPod as they are pretty large and I've got them on my iPod fine, and I've also got one of them off my phone, but can't get rid of the other. I've gone onto the music section of my iPhone in iTunes and made sure both various artists and the name of the album I don't want on there is unchecked and it definitely is. I've also tried checking the album, syncing my phone, then unchecking and syncing it again to see if that worked for some reason but it didn't. I also tried deleting the songs off my phone manually, which took a while, only for them to go back on as soon as I plugged my phone into my computer. Can anyone help me with this? I'm using iTunes on Mac. Thanks



Submitted by Clare Page on Sunday, February 23, 2014

Hi! Even though I have never used iTunes on a Mac, I have found, from my experience of syncing my iPhone to my PC with iTunes for Windows, that, if I want to take music off my iPhone, I must delete it from iTunes before syncing the phone with the computer, then it doesn't appear on my phone after it is deleted from the computer and the sync is done after that. Hopefully iTunes for the Mac works in the same way, not syncing music over to an i-device when it has been removed from the music library of iTunes on the computer.

That does work as I've done it for music I didn't want any more, however I still want it on my iPod, so if I did that would it delete off my iPod as well?

You need to make sure that the albums and all their songs are unchecked in all the sections, including albums, artists, etc. If they're checked in just one section, even though they're unchecked in all other sections, they will still sync to your device. I've made this mistake. If they're unchecked under all sections, they should be deleted from your phone when you sync it. Deleting them from your library is unnecessary, since if all else fails, you can reset the sync history under general prefferences, which will clear all checkmarks and let you start fresh. Hope this helps.