Window: Authentication required Login panel

macOS and Mac Apps

Hello all,
I get this mysterious announcement from Voiceover about 4-5 times a day on my iMac running the latest Sierra. I find no window where I can type in my login/password. I asked my sighted wife to locate it for me and she sees no window. I have rebooted my Mac several times to no avail. It is getting on my nerves.
Any idea which app is generating this mysterious message or any way I can do some sleuthing myself? Thanks.



Submitted by falcon wings on Sunday, December 11, 2016

I don't think its a bug,but if it is I wouldn't know of it.
This message comes up,and as soon as you press any key it goes away,right?
From what I have seen, it happens when your machine is idel,and the screen either turns off or dims to save power.
or possibly,before the mac is about to sleep.
changing any or all of these settings might make the frequency of this window coming up less or non existent,however changing these settings might also result in reduced batterylife
ahh,wait you are using a Imac so that shouldn't be a issue,although I haven't used one so I wouldn't know.

Submitted by Ekaj on Sunday, December 11, 2016

I was kinda wondering about this too, but wanted to wait and see if others were experiencing it. It also seems to me like a minor bug, because I never got it until updating to OS Sierra. I've experienced it the most in iTunes when operating on battery power, but I'm wondering if other apps have this issue too.

Submitted by david s on Sunday, December 11, 2016


I haven’t seen this one. But then again, I’m still on Yosemite. Is there a particular app that is or was open when this occurred? Someone mentioned iTunes but I’m curious to know what you were running when this occurred. It sounds like a service or program was idle and suddenly needs authentication. It gets it then goes away.

Have you tried disabling wifi and see if it goes away? Do you have any other programs or services that requires periodic authentication?

HTH and good luck.

Submitted by Mani on Sunday, December 11, 2016

Thank you for all your responses. I just got that message a few minutes ago and I have Finder, Terminal, Mail, Safari (with a lot of open tabs), TextEdit and Dictionary open. I also have the 'Require password after sleep' unchecked. This started happening only in Sierra although I don't remember which specific release of it.
And yes, I I sometimes have the iTunes app running too.

Submitted by Chris on Sunday, December 11, 2016

I think this is your computer attempting to go to sleep when you're not doing anything. Try setting the sleep after slider in Energy Saver settings to never or to a large value like 1 hour.