WiFi Connectivity bug in mavericks?

Forum
macOS & Mac Apps
Hi All, This is not a VoiceOver issue at all; my Mac is doing something annoying and I want to see if anyone else is having the same problem. I have a 2011 MacBook Air running 10.9.2. When I wake my Mac from sleep, the Wifi status is "No signal." This happens no matter if I've physically moved the Mac around from network to network; it occurs both when I venture out and when the Mac is sitting at home. Turning Wifi on and off again does not resolve the problem; the only workaround I've found is to restart the mac. Granted, a Mac restart is a far cry from a windows restart on an actual hard drive, but I just wanted to see if any other 2011 MBA owners had seen this to determine whether it is a software, firmware, or hardware issue. It seems to happen every other time or so that I wake my mac. Thanks, Chelsea

Options

Comments

Submitted by KE7ZUM on Tuesday, March 18, 2014

Not as of yet. No issues here. I'm drawing a blank, but if there is a way, try reseting yrou network settings in maverick and that should clear out something corrupt if any.

Take care and hope that sort of helps.

Submitted by Isaac Hebert (not verified) on Wednesday, March 19, 2014

I have experienced this problem too with my mac and my iDevice both devices would just disconnect from the network with out me doing any thing all I would have to do is reconnect them to the network then they are working fine.

Submitted by Chelsea on Wednesday, March 19, 2014

Reconnecting to the network manually worked; much easier than restarting. So it looks like a Mavericks bug, unless your MacBook models are running Mavericks as well. Thanks!

Submitted by Wayne A on Saturday, March 22, 2014

Club AppleVis Member

In reply to by Chelsea

I encountered the same problem when I upgraded to 10.9.2. I did a search on Google and found an article that linked the issue to Bluetooth. I turned off my Bluetooth and the problem disappeared. I don't know why this worked. When I want to use a Bluetooth device, I simply turn it back on. When the problem did occur for me, I did not have to re-start my computer but just re-connected the WiFi. I read that the problem may only be present with certain routers, particularly Airplane routers. Hope this helps.

Submitted by Chelsea on Sunday, March 23, 2014

Hi Wayne, I actually use Bluetooth very rarely on my mac and didn't realize it was turned on. Apple seems to have a habit of enabling it on update, so thanks for the tip. I'll see if the problem goes away.