Voiceover Speaks Text with Keyboard Echo Words without Spacebar or Punctuation

Forum
macOS & Mac Apps

Hello all,

I had thought that this was a setting, but upon absolutely scouring the Voiceover Utility and Mavericks' System Preferences, I'm discovering that this is a very cool, but very annoying bug.

Before I go any further, I'm using OSX 10.9.3 Mavericks on a Mid 2010 stock White Polycarbon MacBook. When I'm typing text, be it in Text Edit, iWorks Pages, Male, Safari, OSX dialog boxes etc., it only happens with key echo set to words. When I'm typing text, Voiceover speaks the text which I have just typed even though I have not pressed the spacebar or a punctuation mark which would invoke the key echo. The delay is about a second to a second and a half, and the delay is very consistent. it doesn't matter whether I'm typing words, sequences of letters and numbers, only numbers etc. It also doesn't matter which voice I'm using or where in the OS I'm working. I deal frequently with foreign languages, and that doesn't even change this either. Whether I'm using Alex, Samantha, Allison, Ava, Aleksandros, Melina, Tingting or even little ole Fred! Nor does it matter which keyboard layout I'm using. Even in CJK languages such as Traditional Chinese Pinyin, it does it!For example, if I'm typing the word hello, I'd type h, and VO would say "h." I type the e, and it says "he." With both l's, it says "hell. I type the o, and it says hello. With numbers, I'd type the numeral five with a pause, and it'd say "five." Type a 0, and it says "fifty."

I am not a very thorough person, and I don't prefer to be such for various quirky reasons. I have looked at every option in every tab of the Voiceover Utility and Mavericks' System Preferences, and I've found nothing. The only thing I haven't done is to read the bloomin' VO user's guide! A friend of mine, who is thrice as thorough has also done the same, and has come up empty. If there are any Apple developers up here, please submit this to the bug reporter.

I've come to like this quirk, but it needs to be rectified so that blind and VI businessmen don't get outed while entering financial or other confidential data into their Macs.

Options

Comments

Submitted by dvdmth on Wednesday, June 18, 2014

Club AppleVis Member

I'm pretty sure that's how VoiceOver is supposed to work on the Mac. If you don't want your words echoed, turn it off. The option can be quickly accessed with the verbosity rotor, Control-Option-V.

I understand what you're saying about sensitive data being overheard, but that's the risk you take when you have typing echo enabled, in any form. For that matter, simply using VoiceOver to read something may be enough for someone to overhear something they shouldn't. If it's important that no one overhears, you should be using headphones, or braille, or something which makes your VoiceOver experience more private.

Submitted by Rosco Vittore on Wednesday, June 18, 2014

this is definitely a bug. No question. I completely agree with Mr. Bloomgren. i'm a little bit confused how you would think that this would be normal behavior. what is your logic for reaching this conclusion? if voiceover is set to word echo, then that is exactly what it should do: echo words, not half words. I personally agree with Ben entirely. though I completely agree with Dvdmth's suggestion to use headphones, this is not always a viable option. we can sit here all day long and say that there are ways to get around this. That is very true. but not all hardware is going to work for everybody. for example, maybe I'm drifting from the original topic here, but are you going to sit here and tell me that if you're blind, you absolutely must use a braille display? okay, give me $10,000 and I'll do it. oh, never mind the fact that I don't read braille in the first place. I can definitely listen to Alex however, and can navigate with speech. my point being, you can piecemeal your way through this all you want, however the bottom line is it is definitely a bug, and it needs to be investigated by apple developers, and more so Apple engineers. case closed. I, for one, am an Apple developer. I definitely will be filing this on bug reporter. I appreciate the heads up. I normally use character echo, as I like to be very thorough, and be absolutely certain that I know what I'm typing as I type it. this said, I definitely see where this is a major problem. I was able to reproduce the problem on my end with about five different Macintosh computers. therefore, I know for a fact that this is definitely a bug. there is nothing you can change in the voiceover settings, nor within Mavericks itself that is going to fix this. Here is another reason that I know this is definitely a bug: if you try to reproduce this with lion, or for that mind Mountain lion, it will not occur. heck, this does not occur in Tiger, Leopard, nor snow leopard. I know that that's going Wayback in the machine days, however, my point is, we did not see this problem crop up until Mavericks. obviously, though I do use the beta of you Cimity, I am on very strict NDA, and therefore cannot confirm one way or another whether this bug exists over there. I will however say, if hypothetically it does exist, it is being dealt with by me filing separate bug report. this is just my two cents worth, take it or leave it, however, in my opinion, it is definitely a bug, and I will definitely be addressing it with Apple engineers.

Submitted by Ekaj on Wednesday, June 18, 2014

This is most definitely a bug on my end too, and also on my sister's Mac Book Air. We're both running Mavericks. However, I've found that if you type relatively fast like I do, words are echoed when pressing the Spacebar. But for those who don't type as fast or take their time, etc., I think this definitely should be addressed. I haven't yet tested this out with passwords, but it would be interesting to do so. What I'm also wondering is if the Word setting will fix the problem I've been having with stuttering speech, or at least reduce the occurrences of this.

Submitted by dvdmth on Wednesday, June 18, 2014

Club AppleVis Member

For a long time, Apple has assumed that a pause of a second or so means you have finished typing whatever you were intending to type. For example, in the Finder you can type a portion of a file name to jump to it. Apple moves the focus to the item about a second after you stop typing, so if you pause for a second, then continue, you will end up jumping to the wrong file because Apple thinks you are starting to type a new file name instead of continuing. Also, when using the search box to filter the list of items, in iTunes for example, the filtering takes place a second after you stop typing into the search box. That's the Apple way, and VoiceOver speaking the word a second after you stop is consistent with this behavior.

When I first learned VoiceOver, I noticed that very behavior with typing echo, and I thought it was perfectly natural, because I had been using Macs for many years prior, and it was in harmony with everything else I had experienced with the Mac interface. I'm not saying you should like it, or even that it should be that way in an ideal setting, but that is, in my opinion, precisely what Apple intended to do, and since it was their intent, it is not a bug by definition.

If you'd like this behavior changed, go ahead and contact Apple accessibility about it. I won't argue over that, as I'm sure the partial word echo can be annoying for slower typers. It personally doesn't bother me, but I'm a relatively fast typer.

Submitted by Ekaj on Thursday, June 19, 2014

Thanks for shedding some light on this. I guess I was just not used to this behavior since after all this is my first Mac computer, but now that you've explained it it does indeed make sense.