VoiceOver skipping content in Safari

Forum
macOS & Mac Apps
On my Mac, Voiceover is skipping content in some pages that I visit. If I move with the VO + arrows VoiceOver jumps over the area without acknowledging the existence of the text. I have notice this in several pages, and in some occasions I can find the text in the item rotor, but some times it will not be even appear there. My son who is sighted, had confirmed me that the text is there, and he had move the mouse over the text, and VoiceOver had read it, which confirmed me that the text is readable,but VO jumps over it. What worries me the most is not knowing what causes this, and not knowing what information I have missed in some web pages. Not sure if this is a problem of VoiceOver, the way a page is coded, or a combination. Please let me know if someone else had noticed this, and if someone have a solution.

Options

Comments

Submitted by Justin on Sunday, April 13, 2014

Hi, I've found this bug in safari under Mavericks. When I use the Say all command, VoiceOver does skip over some text. I don't know of a work around for this, so if anyone has one, pleas let us know. CT.

Submitted by Carlos M Contreras on Sunday, April 13, 2014

Hi Justin: I had noticed that problem too, but I have it since Mountain Lion. My work around that problem is that when I noticed that the text stops making sense, I change from read all to moving item by item with VO + right arrow. The problem that I'm having now is worse because I haven't found how to get the text read using the keyboard. The problem also exists in iOS, but at least I can touch the text, and it will be selected. I tried one of the pages where I'm having the problem on an old Mac Book running Lion, and the problem is also there. I reported the problem a few weeks ago to Apple, and they asked me to send my VO settings. I sent them, but haven't heard from them. I'm hoping to hear a solution here.

Submitted by Piotr Machacz on Sunday, April 13, 2014

Have you tried to touch the page with the trackpad if you have one? I once saw a text area in an application where I could get to it with the VO Cursor but once I touched it, the field gained focus.

Submitted by Justin on Monday, April 14, 2014

That is very interesting. This read-all problem for me came about when I upgraded to Mavericks. With earlier versions of OS10 there haven't been these read problems in safari. Also on iOs, I switched to google chrome instead of safari. Hopefully they don't break accessibility with chrome! Anyway, I haven't tried the trackpad solution, since I don't primarily use the trackpad at all. HTH.

Submitted by Ekaj on Monday, April 14, 2014

I'm actually having the opposite problem with some voices. Some of them will stop reading in the middle of something in Chrome. I'm wondering if a complete reinstall of Safari would help? Just thinking off the top of my head here.

Submitted by Justin on Monday, April 14, 2014

That might work. I've never seen a voice stop reading in chrome before, anyway, That is very interesting.

Touching the text make it accessible, but finding it is not easy. For example, in one of the pages where I have the problem you can have a list of items in different screens with buttons to navigate to first, previous, next, last, atc. On that page now that I know the buttons are there, I look for the go to label in the item rotor, and move around the buttons to select the proper one. But if I get out of that group, VO wil only read the item previous to the group, and the item after the group. BTW, this is on a page of the federal government which I assume is section 508 compliant. The problem occurs in Safari and Chrome.

More Like This