VoiceOver reads all numbers as individual digits?

Forum
macOS & Mac Apps
Hi. I am seeing a pretty strange behavior when VoiceOver reads numbers to me. I am using a german environment with a german voice, so this might as well be something specific to that environment. When VoiceOver reads any kind of number to me, it spells the individual digits and completely misses to inform me about any punctuation (commas). So when I hear something 2,34GB, VoiceOver says "2 3 4 GB", which is pretty useless, I have to use character by character navigation to actually know what number is being presented to me. Is this perhaps a setting I am missing? Do you see the same behavior in other locales like English, or is this something specific to a german locale? Any hints on how to fix this would be highly appreciated. Thank you, Mario

Options

Comments

Submitted by Nicolai Svendsen on Thursday, March 15, 2012

Club AppleVis Member
Hi! Try hitting VO-V for verbosity settings, then hit N to go to "Numbers." Check if it is set to digits or words. Set it to digits, then hit escape to exit and save. You change the preference by using up and down arrow on their own. I hope that helps. I don't think it's specific to the language you use, at least not if it just says the numbers individually.

Thank you a lot, that did the trick. I had to actually set it to "words" to get what I wanted, but now I am really content, very nice! I really wonder why digits was the default, but that is another story. Thanks again.