VoiceOver Not Reading Negative Balance in Online Bank Site

macOS and Mac Apps
Hi, VoiceOver isn't reading negative balances - I'm used to having it read "minus $323.12" but it just reads $323.12. I suspect it's because the online bank site doesn't use a - symbol to represent a negative balance but instead (). So a negative balance on the site is shown as ($323.12) Are there VoiceOver settings to make it say minus if it sees numbers wrapped in () or do I need to have the bank change their code?



Submitted by dvdmth on Tuesday, April 1, 2014

Club AppleVis Member
On the Mac you can change VoiceOver verbosity settings by pressing VO + V, or Control + Option + V, then use left and right arrow to navigate through the options and up and down arrow to change the settings. You might try changing the punctuation setting from Some to All to hear precisely how the number is being formatted on the page.

Submitted by dvdmth on Wednesday, April 2, 2014

Club AppleVis Member
The verbosity settings are also available on iOS, but they aren't consolidated in one place like on the Mac, unless you have a Bluetooth keyboard. For punctuation, go to Settings, General, Accessibility, VoiceOver, Rotor. Look for the option for Punctuation and select it, then use the rotor to adjust the punctuation setting. A couple other options, like speaking hints, can also be added to the rotor here. For typing feedback and phonetic feedback, there are sections within the VoiceOver settings for each of those, but I don't think they can be added to the rotor. If you have a Bluetooth keyboard, you can use Control + Option + Command + Arrow keys to access a special rotor which has the verbosity settings as well as speech settings, but this special rotor cannot be accessed directly on the iOS device as far as I know.