voiceover not actually using the voice I set

macOS and Mac Apps

Hey folks,
I am quite excited to have my macbook pro in. I was going to get the brand new Air, core i3, but I found a used 2015 macbook pro on Ebay, and it's amazing. However, while I am pretty good with mac os and voiceover, it is giving me one big problem. I went in and tried to download a few voices, and get rid of some of the default ones I don't need, but voiceover still isn't wanting to use these like it should. More specifically, my system is set to Spanish. Default voice is Monica compact, but I have set it to Paulina which is a decent voice. But it is still forcing Monica on me. I know for a fact that the voice did download, because otherwise I could not select it in voiceover options.
Am I missing something here, or have others experienced similar problems?
Help will be much appreciated.



Submitted by Justin Harris on Sunday, May 3, 2020

Ok, so I wanted to reply to this in case anyone ever has the same problem and googles for an answer or comes here for an answer. I tried everything in VO utility with no luck. But I also remembered that in addition to the voiceover settings, there are other speech settings, where a system voice can be defined. That did the trick. Then I found a tutorial online on how to remove unneeded voices by going in to that library folder and moving the ones you don't want to the trash. Now, I have just two voices, and that's what I wanted. Now super easy to cycle between Spanish and English.

Submitted by Karina Velazquez on Wednesday, May 6, 2020

Hi Justin! Nice to know you’ve got one quickly, now I think you could help me with some random doubts. Will get back to you asap if you don’t mind.enjoy your new toy lol

Submitted by Justin Harris on Wednesday, May 6, 2020

Hola Karina, que gusto de saludarte. Claro, estoy para ayudar en lo que pueda. Si quieres, me puedes contactar por WhatsApp, al +1 620-714-0820. No soy experto pero si no sé la respuesta, investigo. :)

Submitted by Queen Siren on Wednesday, May 6, 2020

Hello. I've had a similar problem to this before. I went into the VoiceOver utility, and downloaded a voice, and it had a bit of difficulty setting as default. I have a couple of suggestions. First, when you are in the voices menu, there should be an edit button near the table showing the various voices. If you click the button, you should be able to set the default voice there, as long as it is downloaded. However, just because that is the default voice, it does not mean that that voice will speak everything. To do this, there will be a table near the area where you select the voice, where you can select a voice to speak various things, such as elements and status. If you would like to have multiple voices that speak different messages on your screen, you can choose that in this table. However, if you would like one voice to speak everything, you will need to navigate the table, and choose the same voice for each of the choices. Another thing that may or may not help is going into the accessibility category in your system preferences, and going into speech. It may help if you set your system voice to the voice that you want VoiceOver to use. Finally, if all else fails, I tried going into the VoiceOver utility, setting the default that I wanted, and then rebooting my computer. I hope this helps, and note, the computer that I tried these things on is running Mac OS Catalina, so if you are using an older version of the operating system, things may be a bit different Good luck.

Hello, in fact I had the same issue and I resolved it like you did. on another hand, I have posted somewhere here, regarding if I can set different voices and languages for different activities, in fact I have tried to set some activities but all what I can do from there is change the voice verbocity but nothing more extensive, and I need this because as Justin, I jump a lot between English and Spanish and the automatic language is not always reliable, is it possible to change languages in activities?

Submitted by Justin Harris on Thursday, May 7, 2020

Hi there, I did end up figuring all this out, and things are working great. In addition to the steps you indicated, I went in and deleted all other voices from the system folder, making it quite easy to cycle between the voices I chose to leave, one for Spanish, one for English.
Karina, I have never messed with Activities, but you can cycle through voices and change some voice settings on the fly by using vo + cmd + shift, and using the arrow keys. Left and right cycle among options such as voice and speed, up and down actually make the change in that particular part of the menu. Again, that's where it is helpful to not have tons of voices on your system, so you can cycle through them pretty quickly.

Hello all. I am glad everybody has figured out this voice issue. Unfortunately, I am not of much help when it comes to activities, because I don't use them. I apologize. Be well.

Hi Justin, I have used that shortcut but every time I use it my Mac goes sluggish and in many cases I have to reboot VoiceOver, so I think I must delete all the voices I don't use either.
On the other hand, is curious that I have never found a VoiceOver user that use activities on the Mac lol.

Take care all.

Hello. I guess, my reason for not using the activities, is mostly because I prefer interacting with VoiceOver similarly to the iPhone, with the trackpad. I also enjoy the way the shortcuts work in Linux and even Windows, than they do on the Mac. However, this is only personal preference, and if anybody wants, I can test them for you, as I love accessibility testing, and I mostly have nothing better to do. Take care.

More Like This