voiceover on macOS force reading punctuation regardless of configuration?

Forum
macOS & Mac Apps

Hi People's. I'm sorry, I'm kinda new here, but somewhat desperate. I'll try to explain to the best of my abilities. On iOS, I used to have punctuation set to none. As of iOS13, I made a custom group, and disabled underscore, vertical line, etc, etc, etc. Sounds beautiful if I may say so myself. On Windows, I'm even more crazy with it, got everything disabled.
Recently, I got into the world of macOS, and this is where the problem starts. I didn't want to upgrade to Catalina, and was happily on Mojave. I set my voiceover punctuation to none. Generally, that would mean things like %, +, bullet, and basic stuff like that would at that point be silenced. But apparently not here. Basically, between none and some, there was no difference in terms of symbols being read. OK, no biggy, figured I'd just go on Catalina, and set up a custom group. Uh, nope...
I set up a custom group, based on none. I put all symbols on ignore, I put the symbol as the punctuation, and it's word spelling as the replacement.
So for example, /, ignore, slash. Yet, I hear https slash slash colon www dot google dot com.
In other words, Catalina's customised punctuation settings basically do no difference.
So this is where you guys come in here. How the hell do I stop it to read punctuation? I don't mind using a script, I don't mind modifying system, I literally don't care as long as there is some sort of a solution... Obviously my 4 years of iOS knowledge doesn't seem to work on this issue, so any pointers, I will appreciate.
Thanks so much!

Options