Very weird behavior with Google Docks

Forum
macOS and Mac Apps

I must say, I'm quite befuddled here. LOL!

Using OS11 Big Sur with Voiceover, I open up Safari, go to drive.google.com, then once signed in, I hit shift+T to create a new blank document. That goes well, but then, I'm evenutally taken to the web content area. Voiceover goes nuts! First, it seems to interact with the web area, but then, it almost immediately stops interacting. So, I start interacting again, and I'm then told I'm in the edit area of the document, which is expected. If I then type something, Voiceover again is going crazy. Sometimes I can get it to read the current line I'm typing on where my caret is sitting, and usually this is consistent if I do VO+L, but if I up and down arrow, and no, quick nav isn't on, sometimes it reads the correct line with focus, but other times and more often, it randomly reads maybe two lines above if I up arrow, or 2 or 3 lines below if I down arrow.

Nothing seems to read if I use standard keyboard shortcuts for selecting text, and I'm not being told when things are toggled such as bold, underline, italics, etc. If I try making something into a heading, like a heading level 1 or 2, forget it! If it's doing it, Voiceover sure is not telling me so. Further, VO+T isn't telling me any change is attributes. It's not even telling me how the text is aligned. If I try arrowing with left and right arrows, that works, but if I either hit backspace, or the delete key, either way, Voiceover isn't saying anything. It's totally silent. I may as well have not hit any key in the first place. I've checked all my Voiceover settings, and everything as far as what gets announced with deletion, and with the cursor passing over text is set correctly, and works properly everywhere else, just not in Docks.

I do have both braille support and screen reader support enabled in Docks.

I dont' know if this matters, but I do have allow Voiceover to use Apple Script checked in the Voiceover Utility, although, I also tried with that unchecked, and it made absolutely no difference either way.

I disabled and re-enabled Voiceover which didn't help.

I know that Pages would probably be a better sollution, or something like Microsoft Word, but the company I'm working with on this project requires Google Docks due to the need for realtime collaboration, so for this, those other apps are not viable.

Has anyone else had these many issues on Big Sur with Docks? I also tried with Google Chrome, and had the exact same experience, if not worse.

Safari is totally up to date, and so is Chrome.

Heck, I even attempted with Edge for the Mac, and even that didn't work any better. I don't ever remember in the past Docks being this clunky/buggy on the mac.

Options