Unable to toggle VoiceOver check box to allow AppleScript Control

Forum
macOS & Mac Apps

Hi,
I have recently purchased a Macbook Air running Yosemite.

I wish to allow VoiceOver to be controlled by AppleScript. When checking the relevant check box in the VoiceOver utility and entering the correct iCloud password, the check box remains unchecked.
I have attempted to toggle the state of the checkbox with Voiceover disabled. i have also tried adding applications including script Editor, Autimator and VoiceOver to the allowed list of apps under privacy but to no avail.

Would anyone happen to know what setting is preventing this change from taking place under Yosemite? Perhaps there is a security setting I need to alter to permit this change?
Many thanks for any assistance.
Sam

Options

Comments

Submitted by Carlos Taylor on Friday, June 19, 2015

I noticed this about three or four weeks ago. You should submit a report to apples accessibility team about this. I did so and I believe they are working on it, but it doesn't hurt for more people to report this as well. Send an email to accessibility@apple.com.

Submitted by Ekaj on Friday, June 19, 2015

I just tried checking the box for AppleScript and then entered my password. Confirmed here too and will send a report to the accessibility team. I hadn't noticed this until just now upon reading this thread. I guess that's because I haven't used AppleScript that much yet.

Submitted by Bo on Friday, June 19, 2015

I recently wiped and reinstalled my Mac straight to Yosemite 10.10.3. I noticed I can't check this box either.

Submitted by Ekaj on Wednesday, September 26, 2018

I can indeed confirm that this has been corrected in OS Mojave. I just attempted to tick the box, and upon entering my admin password VoiceOver reported that the box was indeed checked.