Two things that drive me crazy using VO and Safari!

macOS & Mac Apps
I can do my online grocery shopping equally fast using either IE with JAWS or Safari with VO. However, there are two things about using Safari with VO that drive me crazy. 1. After choosing a link using the web rotor, you have to press again to activate it - I can't believe how often I forget this. 2. After pressing Cmd+LeftSquareBracket to go back a page, the focus goes to the top of the page and not to the link you activated to leave the page. the first is just a matter of habit, but the second issue makes using Safari a real drag at times. I wonder if it is just me and there is a way of getting around this? JT



Submitted by Daniel on Friday, March 8, 2013

Hi JT, in responce to your two questions, for the 1st I understand what your saying but to be honest I havn't really had a problem with the way voiceover handles this. Of course this is a matter of opinion and I completly respect yours and understand where your coming from. As for your 2nd question I totally get you on this one! It gets on my nerves too. Have you sent an email to If you have then just ignore this post but if you havn't done so then I suggest that you fire off an email to them explaining your two issues and any others you might have. I'm sorry I can't be of more help.

Hi. On the first question, yes I tend to forget to push return again to activate it, but i think with Jaws jumping around we kind of expected that. As for the second issue I totally hate when things like that happen to me because if the page isn't set up right it takes hours so it seems, to find where I was. I think though that Jaws having a stable way of staying where you left it, spoiled us just a bit. however, I for one would kill to disable the autoo complete feature of safari if I could. I know how to spell google. Anyway I'm also sorry I can't give you any better tips.

Hi all, While we're on the subject, one thing that really bugs me, and I notice it on the AppleVis website probably more than any other, is that when I move through the web page, VoiceOver keeps saying things like: "Exiting landmark, entering navigation landmark" or some such nonsense before getting to the point of telling me what the particular element says! It doesn't happen on iOS, just on Mac. Is it possible to turn this off? Thanks

I'm so agreeing with that! That's one of the main reasons why I prefer to do most of webbrowsing on my iphone! Really wish there was a way of turning those announcements off...

To add what David has said, another thing that I really don't want to hear voiceover saying in Safari on the Mac is. 4 items, 2 items, 1 item. I think you get the picture. I mean hmm are there really 6 items before voiceover starts reading the text your after? e.g. when browsing through one's facebook news feed. Very strange behaviour. Anyone else get this a lot?

Get this all the time, and it's extremely anoying! Just making browsing on mac safari much less efficient than it could have been... That's why I think everything just seems to work much more smoothly on the iphone... But if there really isn't a way of turning this things off, maybe we should have contacted about this? And maybe one of you who have english as your native language should do it? ;) just think you guys would be much better at explaning the issue much more clearly than I could do... ;)

Submitted by JT on Saturday, March 9, 2013

Is something that works a bit like place markers in JAWS, they make using GMAIL a breeze compared to the MAC. However, I do love how VO filters things like links lists and headings list by what you type, I find that amazingly useful. Let's hope that one day every screen reader will have every possible feature and life will be just perfect!

Submitted by Carlos Alonso on Saturday, March 9, 2013

if you open the voiceover utility (vo+f8) and change the verbosity level to Medium instead of the default High, some of this announcements will not be read. I am relatively new to the Mac so I am not totally sure what other announcements this level will omit, so play around with it, snce I changed it I don't think I'm missing anything critical - this is not different from jaws which enables high verbosity as a default. I used jaws for many years before getting my Mac mini recently, and fI think a lot of things I found annoying about vo can be adjusted if you play around with its settings.

Submitted by Carlos Alonso on Saturday, March 9, 2013

In reply to by Carlos Alonso

in the verbosity settings, after the level option menu, there is check box that if checked, will show a table to set verbosity level for many different type of elements, here you can change the ones that annoy you to 'low'

HI folks, Been looking at all these comments an have some thoughts: 1. I think that the reason VO announces the link and you've got to press enter on it is because it moves the cursor there. There may be instances when you don't want to click it, you want to option click to download a file as an example. 2. The second issue of VO forgetting your place on a page can be fixed by setting a VO hotspot before moving to a new page. For example, go to a page that you want to read, moving the VO cursor to a position you want remembered. press "Control + command + option + Right brace to set a place marker. It's just an option to help a bit for those who may not realise you can do this.

Hi again, guys! I'm sorry for using this thread for my questions about verbosity, since it is a little of topic to the original post, but it's already mentioned here, so what the heck ;p I've been looking into the verbosity settings for VO, but I can't seem to figure out what exactly needs to be changed to stop VO from reading e.g. Entering complementary, exiting list, list 4 items and all the unnecessary stuff VO keeps reading while browsing in Safari.. The global verbosity settings are set to low, so I think there must be one or more settings in the table for more verbosity settings that has to be further customised. Most of them says the name of the setting, standard and then just name, in the table. But some says content and name... Not sure which one I want to change and what I would want to change it to. Wow, this would be so great to get sorted out, so I could have a better experience browsing webcontent on my mac.... Thanks in advance, guys :)

Yeah, also, while using up and down arrows to jump through headings in quicknav mode e.g. on this site, VO says 2 items on every new heading, where it would say the number of the post when doing the same on my iPhone. Think that makes much more sense to be able to hear which number the post is, in stead of just hearing VO say 2 items for each new heading... Any suggestions?

Submitted by KE7ZUM on Sunday, March 10, 2013

Hello. I always have made it a habit to press enter twice. and as for your second issue set a a hotspot which you can remove later to go to the link you were at when you pressed cmd left arrow. That's the key stroke I use. Take care.