Trouble dragging and dropping with VO

macOS and Mac Apps

Hi all,

I'm using something on the web where I need to drag and drop one item onto another to complete what I'm doing, but for some reason VoiceOver isn't letting me drag and drop.

I'm moving to the item that I want to drag, moving the mouse to it by pressing VO +CMD +F5, marking it for drag and drop with VO comma, then moving to the place where I want to drop it, moving the mouse to it then dropping it using VO full stop, however wen I try to drop the item it says "marked item is no longer in view". I know these are the correct steps for dragging and dropping as I've used them before and they work fine, so is there a way I can somehow stop the window moving as I navigate around so the item stays in view? Or is there another drag and drop command I could try? I've tried simulating a mouse click at the item that I want to drag, then simulating another at the place where I want to drop it but this doesn't work either.

I have no vision so can't describe how the page looks or anything like that, and i'm going to be using this service quite a lot all being well, so getting sighted help would get quite annoying eventually.

Cheers for any suggestions,




Submitted by Christopher Duffley on Monday, August 1, 2016

I believe there's an alternate way you can drag/drop things. Just don't know about things on websites, however.

Drag and drop as you normally do, but don't do the VO-COMMA thing. Instead, you can press VO-COMMAND-SHIFT-SPACE to hold the mouse down at the location where the mouse cursor is. Next, go to the location where you want to drop the item, and then press VO-COMMAND-F5 to route the mouse cursor to VO cursor, then press VO-COMMAND-SHIFT-SPACE again to let the mouse go.

Hope this helps and that the steps make sense!


Submitted by Dave Nason on Tuesday, August 2, 2016

Member of the AppleVis Editorial Team

Again I don't know if this will work on the web, but may be worth a try. I rarely drag and drop any more. Instead I usually copy and move, Command+C to copy, then Command+ Option+V in the location you want to move it to. Hope that helps though I fear not in this case :)

Submitted by Callum on Tuesday, August 2, 2016

Hi both of you,

I tried both the suggestions and neither worked, but while I was trying them I realised the message about cookies was still showing, so I got rid of this and then drag and dropped the way I did before and it worked fine. It was obviously covering wherever I was trying to drop. That's what happens when you just jump into navigating pages by headings :)

Thanks for the tips though.