Strange phantom "Apple submenu" message when typing since Yosemite clean install

Forum
macOS & Mac Apps

Hi all,

I've had this crazy issue for several weeks now after doing a clean install of Yosemite from Mavericks. I hoped it would just go away like a lot of Mac quirks seem to do after an upgrade but no.

I notice it mostly when I type a tweet in YoruFukurou. I'll do command n for new tweet and start typing and VO says, "apple, submenu" over and over as I type so that I can't hear my keyboard echo. I have to command F5 toggle to make it stop.

At first I thought it was just YoruFukurou that this happened with but I've noticed it in other areas I type, even renaming a file in Finder.

I've tried opening the application chooser menu to see if there's some dialogue open and at first there was. But I've tried that again and there was no odd dialogue open and never anything that says "Apple, sub menu".

I am at a complete loss and this is incredibly annoying as it pops up with no warning, like when taking down a phone number in Text Edit when I'm on a phone call.

Has anyone seen this behavior and even better, found a solution? I've repaired permissions and that seems to stop it for a time but it always comes back. *scream*

Thanks a million.

Options

Comments

Submitted by Justin Ekis on Saturday, December 6, 2014

I can think of one possible cause for this, if you are using a laptop. In the Voiceover utility, under navigation, there is a setting about how Voiceover should treat the mouse pointer. You might have it set to have the Mouse pointer move the Voiceover cursor. So if you brush the trackpad even lightly while you're typing, the VO cursor will move to the area you touched. For you, it just happens to be the left side of the menu bar. Changing that setting to either of the other two options might fix the problem. I find that some web pages work better if the mouse follows the Voiceover Cursor, and others work better if the mouse ignores the VO cursor. I haven't personally found any good use for the third option yet.

Submitted by KE7ZUM on Saturday, December 6, 2014

Actually tha'ts not a bug. You have speak delay after x seconds and you are rubbin the mouse pad some how.

Submitted by Ro on Saturday, December 6, 2014

Hmmm nope, no track pad or mouse of any kind hooked up. This is happening on a Mac Mini. A friend thought it sounded like a focus issue so maybe it's an issue with settings since I forgot to save VO settings before my clean install.

Submitted by dvdmth on Saturday, December 6, 2014

Club AppleVis Member

Even if you don't have a mouse or trackpad, I would check the setting regarding mouse focus. When the Mac starts up, the mouse pointer is initially placed on the Apple menu in the menu bar, so it sounds to me like the mouse pointer is affecting VoiceOver focus.

As stated above, make sure VoiceOver is configured so that the mouse pointer will not move the VoiceOver focus. Whether you have the pointer follow the VO cursor or ignore it is up to you. Personally, I have the mouse pointer ignore VoiceOver focus and use VO-Command-F5 whenever I need to bring the mouse pointer to where VoiceOver is.

Submitted by Ro on Saturday, December 6, 2014

Are you referring to the "follows Mouse cursor" pop up menu? If so, I have that set on follows Voiceover cursor. the other option is "moves Voiceover cursor.

My settings are the same as a friend using Voiceover and he doesn't have this issue. Let me write my settings here to compare.

Initial focus of Voiceover cursor popup button: Keyboard focused item

keyboard focus follows VO cursor: checked checkbox.

VO cursor follows keyboard focus: checked checkbox.

insertion point follows VO cursor: checked checkbox.

VO cursor follows insertion point: checked checkbox.

mouse pointer: follows VO cursor popup button.

allow cursor wrapping: checked checkbox.

skip redundant labels: checked checkbox.

automatically interact when using tab key: unchecked checkbox.

enable fast searching: unchecked checkbox.

Submitted by Mani on Sunday, December 7, 2014

I have the same issues with TextEdit. I tried to change all kinds of settings in the VO Utility but nothing seems to work. I am just getting used to it. Besides, Alex sounds tinny like that on my Mac. I ended up using Tom or Ava. Is there any easy way to go back to Mavericks?
Thanks.

Submitted by Ro on Sunday, December 7, 2014

Glad to hear I'm not the only one. I'll email Apple a11y. What is the bug report format? I've never been a beta tester or anything. Thanks.

Submitted by Ro on Sunday, December 7, 2014

I asked a beta tester friend and he's sending me a bug report template. Thanks.