Speech Settings Question

macOS & Mac Apps

Does anybody know if there's a way to change the order in which Voiceover on the Mac announces the heading level of text? For example - by default Voiceover reads: "Heading Level One", then the text. I would much prefer if it read the text first, then the heading level. Is there a way to flip this? I believe there is in NVDA, but wasn't sure if VO allows for such customization.



Submitted by Piotr Machacz on Friday, January 29, 2016

Go into the VoiceOver utility, and then the "verbosity" category. Check the additional options checkbox. This makes a table appear that lists almost every control you can think of on OS X and lets you change the verbosity options for them. Find this table, interact with it, and locate "heading" inside it (just use first letter navigation to get to it quickly). Now, go to the right with vo-right to get to the verbosity menu button. Press it, and choose the "custom..." option. Now you get a dialog box with another table which lets you choose what and when should be spoken when VoiceOver reads a heading. By default, the order of things to be spoken is status, then type, and finally name. You want to move the "type" option down, so that "name" is before "status". To do this, find the "type" option in the table, and press command downarrow to move it one item down. You can then press enter to close that dialog and save your changes. That's all there is to it, now VoiceOver should read the text of the heading first.

Submitted by Joseph Westhouse on Friday, January 29, 2016

Thank you so much, Piotr! I had no idea there was so much control over the verbosity of VO. One more point in favor of this screen reader. That's exactly what I wanted!

Submitted by kevinchao89 on Saturday, March 26, 2016

In "Headings", I tried reordering "status" and unchecking it, but it didn't seem to make a difference. I also looked in help, but there was no info on what "status" is.
Does anyone know what "status" does?

Submitted by Becca on Saturday, March 26, 2016

Hi. When in classic view in mail, it says blank, from, etc. How do I change this to say from first?