Safari busy, busy, busy, busy, busy ...

Forum
macOS & Mac Apps

Hello. Since upgrading to the newest Safari, I've been encountering "Safari busy" and busy and busy and busy and busy messages on innumerable Websites. I was hoping it was a temporary thing and would resolve itself, but it's not been getting better. At all.

Are others having this same problem? If so, does anyone have any suggestions for lessening it?

Thanks very much.

Howard

Options

Comments

Submitted by elliot2012 on Sunday, September 26, 2021

Yeh having this also it’s pretty much unusable for me. Have switched to chrome

Submitted by Carlos M Contreras on Sunday, September 26, 2021

I just tried Safari Technology Preview, and the Busy busy busy message is also there.

Submitted by Howard on Sunday, September 26, 2021

it does seem somewhat less awful. Oy. It's amazing that this was allowed out the door, as this problem would have turned up if anyone had tested Safari with VO for, like, 30 seconds. But then again, I'm old enough to remember when Apple didn't suck.

Submitted by Ekaj on Sunday, September 26, 2021

I installed the update to Safari yesterday, and have been playing with it off and on today. I've noticed the increasing "busy" messages but the funny thing is they seem to only occur at random at least on my machine. I have a 2013 MacBook Air, which ironically enough is hopefully going to be taken to a local Apple repair shop this week for an unrelated issue. I might be upgrading my hardware sooner than I think, but only time will tell. I'm wondering if these constant "Safari busy" messages have something to do with coding perhaps? In any case, I'm planning to contact the accessibility folks at Apple regarding this issue.

Submitted by harry6116 on Sunday, September 26, 2021

For me it is happening particularly when loading pages, I'm wondering if the page is actually loading visually but VO and Safari are hanging.
It is incredibly annoying and I'm on the point of switching to chrome but I just don't find that browser verboce enough sometimes.

Submitted by Carlos M Contreras on Sunday, September 26, 2021

Today I spent sometime playing with settings in the Safari preferences, and now the problem seems to be solved. I think that the offending settings is found on the Privacy tab of the Safari preferences. On that tab you should uncheck the following item:

Allow privacy-preserving measurement of ad effectiveness

If I remember correctly it is the last one there. Please try this, and report here. If this is the issue, we can report it to Apple so that they can work with it.

I suppose the issue is only with Voiceover, since I haven't found any complains on regular forums.

Submitted by Howard on Sunday, September 26, 2021

Thanks for your work, and your suggestion. I tried it out, and found it better on some Websites, but not so much on others. Interestingly, it was worst when I just now went to this site to add my comment. Still, it was much better on some sites, so you are onto something. Thanks, again.

Submitted by Ekaj on Tuesday, September 28, 2021

Hello. I unchecked the box under Privacy settings for Safari, and it seems to help a bit. But ironically enough, immediately upon clicking on this thread I got another "Safari Busy" message. I wrote Apple's accessibility team yesterday as promised, but I am currently locked out of that email account until further notice due to some other issues which I won't get into on here. But I think this is one of those bugs that I can live with at least for now.