Safari behavior when logging into websites

macOS & Mac Apps

Hi all. I've asked before, no one has been forthcoming, so here goes. Again. When i log into certain websites, my computer seems to freeze. In other words, after logging in, I try to tab through and i hear "ignoring next key press" The keyboard is unresponsive, the only way to fix this is to close the lid, reopen then after putting my Mac password in, things are fine. I noticed this behavior with amazon, honey, even Apple vis when I logged in. If anyone can help, this would be great. i noticed it more in the newest Mac. I have about a six year old Mac book pro. This is really frustrating for me, I can't even turn off voice over with command F five. Thanks all. My talking book library is also a site that's effected.



Submitted by Andromache on Tuesday, October 16, 2018

I wish I knew how to help, but this doesn't happen to me. I've had Safari itself freeze sometimes, but not the entire keyboard. My computer's six years old, too, but I have the Air rather than the Pro.

Submitted by Siobhan on Tuesday, October 16, 2018

Hi. Thanks for responding, finally someone else did. Let me make sure you understand the problem. I log into something, say Amazon. Email, done. Password, done. Now if you try to do anything, except using the voice over modifiers to move through the page, you hear "ignoring next key pressed." This is exactly the same as if you held down the voice over keys, and pressed tab. I checked using keyboard help. so in theory, because i've pressed this, now i hear a ding sound if I do anything withthe letters, numbers, or command f five to try to shut off and turn Voice over back on. I wish we could force quit it and restart it. Hope that makes sense to you and anyone else who reads this.

Submitted by Tyler on Tuesday, October 16, 2018

Member of the AppleVis Editorial Team

Have you tried clearing your cache and cookies? Over time, these items can build up and gradually degrade performance.

Also, another possible cause of freezing could be disk failure, either hardware or software. If it is a hardware problem, you'll probably need to get your physical disk replaced. However, if it is a software problem, you may be able to fix it by running first aid in Disk Utility. If that doesn't work, a reinstall of macOS might do the trick.

Finally, generalized performance problems can sometimes be addressed by resetting the SMC and NVRAM. To reset the SMC, shutdown your computer and press and hold the control, option, and shift keys, and the power button for 10 seconds. Release the keys and turn on the Mac.

To reset NVRAM, turn on the Mac and when you hear the startup tone, press and hold the Command, Option, P, and R keys. Release them when you hear the startup tone for the second time.


Submitted by Tyler on Tuesday, October 16, 2018

Member of the AppleVis Editorial Team

By the time I posted my comment, I saw that you had clarified the specific issue you are having. When you log in, are you using the Control and Option keys or the Caps-lock key as the Voiceover modifier? Using the Caps-lock key when interacting with a password field can sometimes cause the Voiceover modifier to appear stuck. Try using the Control and Option keys and see if that makes a difference.

Submitted by Bryan Jones on Tuesday, October 16, 2018

A few thoughts.

1. You mentioned VO is saying "Ignoring Next Keypress" when you attempt to tab between elements. In Mac VoiceOver, the function to ignore the next keypress is invoked by pressing VO+Tab, so if the VO keys are locked on you might expect to hear "Ignoring next keypress" with every second press of the Tab key. Make sure your VO keys are not locked on. Press VO+; (VO+Semicolon) to toggle this setting.

2. The inability to toggle VO with the standard Command+F5 might indicate the issue is related to the keyboard or a keyboard setting rather than the web browser or a particular website. Does the issue occur if you use an external USB or BT keyboard?

3. What OS version & browser version are you using? If you are using Safari, do you get the same result when you try with Chrome?