RSGames client help

Forum
macOS & Mac Apps
hi, need help opening RSGames. when i went to open it from the downloads, it gave me a message that it couldn't be opened. help me to open this

Options

Comments

Submitted by Jeffry Miller on Tuesday, January 7, 2014

Mary, that is happening I assume because you have your mac set to only open downloaded files that come from the apple app store. You can change it by viewing package contents or something like that or you can go to privacy settings in security in the system preferences, and change how you want to handle downloaded apps..

Submitted by Mary Foushee on Tuesday, January 7, 2014

In reply to by Jeffry Miller

hi, can you or someone tell me how to do that please. i am new to this, so any help would be great!

Submitted by Piotr Machacz on Tuesday, January 7, 2014

Go to your system preferences, then find security and privacy. This screen like a few other preferences has a security lock on it where you need to enter your password to change any settings. So first, go to the bottom of the window, and keep going left until you find the "click the lock to make changes" checkbox. Press it, then enter your password. Now we can deactivate gate keeper. What is it? It's a security feature which prevents unsigned applications from running. To sign an app you need to go through Apple, and not every developer does it, especially if they don't have a developer license. So, to turn it off, now that you unlocked the controls, go to the top of the window. You have 4 tabs here, and you want to be on general. Keep going right until you hear "allow apps downloaded from". You have 3 options. The first, mac app store, is self explanatory. Apps that you downloaded from other places won't run, unless you force them to through their context menu. The second, Mac app store and identified developers, will let you run downloaded apps, but only those that have been signed. What you want to activate is the last option, Anywhere, which is again self explanatory. Press it, then you can quit system preferences and run the RS games client.

thanks, it worked!! now i'm sitting here waiting for them to send me a password so i can log in and start playing