Random hyphens which cannot be removed appear in Pages

Forum
macOS and Mac Apps

Hello,

As the title says, I'm experiencing an issue with hyphens in Pages: when writing words like Romania and many others, a hyphen appears inside the word (e.g. Ro-mania) and I cannot remove it. I don't think the problem is with auto hyphenation, because even when I tick the box in the toolbar which prompts Pages to remove autohyphenation from specific paragraphs, they are still there.
Could someone suggest a solution for this problem?
Thank you in advance.
Regards,

Alexandra

Options

Comments

Submitted by Kevin Shaw on Thursday, October 21, 2021

Hi Alexandra,

There are two places in Pages to disable hyphenation. The first is for the document as a whole in the document inspector. It looks like you've turned this off.
There is another one that is often missed inside the paragraph formatter. VO-J to the formatter and select the More… tab beside the Style and Layout tabs. there is a checkbox in the scroll area called Remove Hyphenation. Try checking that to see if it makes a difference.

Submitted by Alexandra Moldovan on Thursday, October 21, 2021

Hello,

Thank you very much for your answer. I only did the second setting, that with the paragraph, which I was talking about before, and it didn't work. Could you explain where the first is? What do you mean by document inspector? I couldn't find it in the toolbar.
Thank you again for helping me and I hope I can fix it soon, because it's very annoying.

Submitted by Bruce Harrell on Thursday, October 21, 2021

Hi. I have no idea where the inspector is either. However, there is something else you can try. Go to the edit pulldown menu in the menu bar, arrow down inside it to substitutions, inside substitutions arrow down to smart dashes. If it's checked, uncheck it. If it's not checked, I'm stumped.

Good luck!

Bruce

Submitted by Kevin Shaw on Thursday, October 21, 2021

The Inspector is an area on screen that lets the user change various aspects of the text or a document in Pages. You get to it by using VO-J to jump between the body area of your document and the inspector pane.

By default, Pages displays the Format Inspector. If it is not showing, press Command-Option-I to reveal it.
The other inspector is the Document Inspector. You can switch between these two by going to the View menu, then Inspector, then choosing Document Inspector. Jumping between the body and the inspector lets you move through Pages rapidly without having to navigate lots of menus.

I've written 3 guides to Pages in the AppleVis Guides area if you'd like to dig deeper into other things the Inspector can do. Hope his answers your question.