A question on using an archive Utility

Forum
macOS & Mac Apps

Hello Apple Vis,
I am trying to extract/unarchive a Tar archive that I downloaded off line.
Using Archive Utility keeps giving me an error one message, and I have tried downloading The Unarchiver, but even with that i am getting no where.
Does anyone have any suggestions on how to unarchive a Tar archive/ I've simply clicked on it with VoiceOver, and I have done command Plus O, and Control Option shift and M, and still nothing has happened. I keep getting the same error. The error one Which is Operation not permitted.
I have no idea on how to use the Unarchiver.
Any help would be appreciated.
Chuck

Options

Comments

Submitted by KE7ZUM on Wednesday, March 15, 2017

Yeah download puzip using homebrew and ruby then

midir "path/to/directory/wherefiles/should/go \
7z a "path/to//tar/archive

Submitted by Chuck Winstead on Wednesday, March 15, 2017

Do this Through terminal?
If your curious on what i am trying to do I am trying to unarchive a Distribution of Linux for my raspberry pi, and i have the software to writing it to an SD card, but the software needs me to unarchive the distribution. Right now it is in my downloads folder.
I'll follow your instructions.

Submitted by KE7ZUM on Wednesday, March 15, 2017

Yes, you do this through terminal. Google how to install homebrew and ruby then brew install p7zip and you should be good to go from there. Homebrew is addicting though so use with care. Lol!

Good luck.