Question About Teamspeak for the Mac

Forum
macOS and Mac Apps

Hello all,

I am posting this message on behalf of a friend who is trying to use TeamSpeak on a Mac. The problem she is having is that TeamSpeak prompts for her to agree to a license agreement after she's installed the program but no matter what she does, the agree button is greyed out. Apple says this is likely a TeamSpeak issue but I was wondering if somebody who has used it could please tell me if you have found a way around this problem with VO.

Thank you for your time. Best,
Jesse

Options

Comments

Submitted by robin24 on Wednesday, August 17, 2016

I've just discovered this thread and wanted to revive it, since I'm having the exact same problem here! Please, if anybody has found a solution to this very weird issue, could you please be so kind and share it with us?
Many thanks!

Robin

Submitted by Jake on Wednesday, August 17, 2016

To get past this, you need to do two things:
First, enable accessibility for the Teamspeak application in system preferences, as it uses a 3rd-party toolkit. Go to system preferences/Security, and select the privacy tab. In the table, select accessibility as the permission to change, then in the next table, check the box next to teamspeak3 client.
Second, restart Teamspeak after you've done this and navigate the license dialog with the tab key, *NOT* the VO keys. In fact, in TS, avoid the VO keys whenever possible and use tab. It's more reliable. Now, go to the license field, and scroll down with the down arrow key. It may not read the actual license (I don't remember) but just keep scrolling, down down down down. It's about 6 pages long. Once you scroll all the way to the bottom, the agree button will become active and you can press it with the space bar. Irritating, but at least it only needs doing once.