Problem with the some websites and VoiceOver on Mac, any ideas?

Forum
macOS & Mac Apps

hey everyone, so I am typing this on my new MacBook Air, so let's hope this works :).

I have an interesting issue with a website and I am wondering if you guys can help.

If you check:

http://forum.audiogames.net

you will find the heading to the different forum rooms.

For me at least, I can't directly click on the headings, because VO doesn't#t focus on the link to the room.
For example, Vo says:

Heading level 1 with 3 objects: general game discussion.

if I want to go to the room, I need interact with the heading and than I have to click the link to the room, which is kind of tedious.

Here is the interesting part, a friend of mine doesn't have that problem. For him, Vo doesn't announce that the heading contains any objects, it just displays the page with only the heading and the name of the room.

We both tried reseting the voice over settings to standard values, but still the same results for both of us. When he clicks the heading, he can jump to the room, and if I click the heading, it clicks on a text element in the heading and not the first link in there.

I also have the problem with the mobile webpage on the Mac where I have to interact with some headings to get the links inside.
Do you have any ideas what could provoke this behavior? I would have guessed that this could be a grouping issue or a mouse focusing thing, but as I said, we both reset the VO settings, so this technically shouldn't be the problem, or is there anything else Could have missed?

Already thanks in advance for any help.

Options