Please help me restore functioning of time keyboard commander

macOS & Mac Apps

After I updated to Mac OS Mojave yesterday, I foolishly managed to disable the functioning of the keyboard commander that announces the time for VoiceOver users. (It was my own stupidity -- when I was asked if I wanted to allow access to something or other, I quickly and unthinkingly clicked on "no.") I've tried resetting the VO commander keys under VO utility, but that didn't fix things.

This isn't the biggest deal in the world, but I didn't realize how often I hit command-t to check the time, and I'm missing it now. If anyone knows of a way to fix my foolish mistake, I'd appreciate your help.

Thanks very much.




Submitted by Bryan Jones on Wednesday, September 26, 2018

I'm seeing the same issue. Details below. I have not had a chance to chat with Apple Support yet.

Issue: After upgrading from macOS 10.13.6 to macOS 10.14, I attempted to use the standard Keyboard Commander keystroke to hear the time by pressing Right Option + T, but I was presented with the following message dialog:

“scrod“ wants access to control ““. Allowing control will provide access to documents and data in ““, and to perform actions within that app."

I left the dialog untouched while performing some other tasks, eventually restarting the MacBook, and now both of the default Keyboard Commander keystrokes that call AppleScript Scripts seem to fail with no message displayed or spoken. The 2 default scripts in Keyboard Commander are X to send a VoiceOver screenshot to mail, and T to announce the Time of Day. Note that the default Keyboard Commander keystrokes to open Mail and Safari still work without issue.

Steps to reproduce the issue:

1. If VoiceOver is not running, press Command+F5 to turn VoiceOver on.

2.. Make sure Keyboard Commander is enabled and working:
2a. Open the VoiceOver Utility: VO + F8
2b. Go to: Commanders > Keyboard
2c. Enable Keyboard Commander.
2d. Use Right Option Key.
2e. Make sure this is in the list of commands: Right Option t: Run AppleScript Script: Time Of Day

3. If the Mac has not yet been updated to macOS 10.14, update now.

4. Attempt to use the Keyboard Commander keystroke to announce the Time of Day by pressing Right Option Key + T.

Expected result: VO will announce the time.

My result on the first attempt: Nothing was announced, and a dialog appeared with the text, "“scrod“ wants access to control ““. Allowing control will provide access to documents and data in ““, and to perform actions within that app."

My result on subsequent attempts: No visual or audible messages are presented.

Troubleshooting steps taken:
Disable/Re-enable Keyboard Commander.
Quick web search for issues related to "scrod" turned up no obvious solution.

Hardware: MacBook Air (11-inch, Mid 2013)

Submitted by Ekaj on Tuesday, October 2, 2018

I got this message twice, and clicked Allow each time. I had Samantha announcing the date and Time, and Bruce for everything else. Now Bruce also announces time and date. Very interesting.

Submitted by Bryan Jones on Friday, October 5, 2018

Note: The following seems to have worked on my system, but as always YMMV and proceed at your own risk.

Following a tip from Daniel Jalkut (the MarsEdit Developer) I was able to force these permissions dialogs to reappear by executing the following command in Terminal:

tccutil reset AppleEvents

The next time I pressed Right Option + T, two permissions dialogs with the "scrod wants to access ..." message appeared, and selecting OK seems to have restored the Time of Day shortcut without trashing anything else that I've noticed yet.

Mr. Jalkut's tip with explanation found here:

Submitted by Howard on Friday, October 5, 2018

I just now followed your instructions, and it worked like a charm. I'd had no idea how much I relied on that particular keyboard command -- until it stopped working. Thanks so much!


Submitted by Ro on Friday, October 26, 2018

Updated today and said no to this scrod thing and then oh no! Where's my time! Thank you so much for posting the solution!

Submitted by Andromache on Saturday, October 27, 2018

It's also possible to get the time from the Mac's equivalent of the system tray in Windows, but admittedly, it's more tedious.

I said yes to that dialog, so I had no problems. I figured it must have been connected, since it happened right after I hit Cmd-T. But what is it, and why is it only a Mojave issue?