Messages app no longer working on my Mac

Forum
macOS & Mac Apps

Why is my Messagesapp no longer working onmy Mac? Until a couple days ago,I was able to send and receive messages on both my Mac and my iPhone. I canstill send and receive on my iPhone, but Mac's Messages app seems only to send to other iPhone accounts. I'm sure I mistakenly hit some switch somewhere but could use advice to get back to normal. Thanks much

Options

Comments

Submitted by Tyler on Saturday, January 4, 2020

Member of the AppleVis Editorial Team

One thing to check is if your Mac is configured to receive messages sent to the phone number you use with Messages on your iPhone. To do this, choose Messages > Preferences, (or press Command Comma) and click the iMessage button in the toolbar. In the, "You can be reached for messages at," table, make sure your phone number is selected. If it isn't there, check that iMessage is configured with the same Apple ID on your iPhone as it is on your Mac.

To do this, open Settings > Messages > Send & Receive on your iPhone, and make sure the Apple ID is correct and that your phone number is selected as an available address.

HTH

Submitted by David A on Saturday, January 4, 2020

Hi Tyler, Thanks for your info. My settings on my Mac and iPhone seem to be set as you have advised. It seems I can send msgs to everyone from my phone, but only to iPhone users from my computer - e.g. computer seems to want to make every outgoing msg an iMessage format. I'll keep looking about for the source of this confusing matter! Thanks - Dave

Submitted by KE7ZUM on Saturday, January 4, 2020

Do you have message forwarding turned on in iMessage's in iOs messages settings? if not try that and see if that works.

Submitted by David A on Sunday, January 5, 2020

I can't even seem to find a message forwarding option in my Message settings on IOS. I'm now getting a message in my phone's settings/messages area that states "waiting for activation....". following theswitch which turns iMessage to the on or off positions. In any case, thanks for the idea and feel free to keep them coming.

Submitted by Tyler on Monday, January 6, 2020

Member of the AppleVis Editorial Team

One thing to try if iMessage is, "Waiting for activation," on your iPhone is to toggle iMessage off, restart your iPhone, and toggle it back on. If that doesn't work, try signing out of your Apple ID, in Settings > Messages > Send & Receive. Restart your iPhone, sign back in, and then repeat the process on your Mac.

Another more drastic step if the above suggestions don't work is to reset network settings by going to Settings > General > Reset > Reset Network Settings. Note that if you do this, all the Wi-Fi networks your iPhone has joined will be forgotten, requiring you to reenter any Wi-Fi passwords you had previously saved.

HTH

Submitted by Seanoevil on Monday, January 6, 2020

A simple one, but something that has caught me out, is Wifi Settings. Both your phone and mac have to be on the same network for you to be able to send SMS.
If you have multiple networks, double check your settings.
hTH
@SeaNoEvil00

Submitted by David A on Monday, January 6, 2020

Happy to report I found the solution to my Mac's messaging problem yesterday after searching Apple's online help forum. Somehow, my phone's Settings/General/Date and Time settings were lost and I guess this means my carrier did not know where I was. This caused me to lose SMS messaging capabilities, which rendered iMessages inaccessible. The Apple forum did a great job of walking me through the steps to get things squared away, so all seems well again. Thanks to all on this forum who took the time to pass along info and suggestions - I would be lost without my access to AppleVis!