Mac mail attaching files to a message

macOS and Mac Apps

When attaching files to a message in the Mac mail app, I can't find any way to see what files have been successfully attached. In the body of the message, I only hear "group" where the files are likely embedded and can't interact with it. Is this a Mac OS 12 issue, something that's been around awhile, or just me?



Submitted by Kilroy on Tuesday, November 23, 2021

I'm seeing the exact same behavior here on macOS Monterey 12.0.1.

I don't send attachments frequently enough to be certain, but I *think* that this is a new issue in macOS 12.

Submitted by Kevin Shaw on Thursday, November 25, 2021


I'm experiencing this on an Intel MBP running the latest version of Mac OS. This is an old bug that was squashed in an older OS and is now back.

Please send a note to with the following:
• a description of the problem
• the steps they should take to repeat it
• information about your Mac including the OS version and any other key information, such as whether you were attaching by using Command-Shift-A or copy and pasting a file in.

I will do the same.

Good luck!

Submitted by Bruce Harrell on Thursday, November 25, 2021

I write click on the file with vo-shift-m, arrow down, right arrow on share to open the share submenu, arrow down, select and vo-space on mail, and proceed with sending the email. Sends the file every time.

Happily, I never upgraded to Monterey. Nevertheless, you might want to give this method a try anyway. You can Cc yourself to confirm it worked.

Happy Thanksgiving!


Submitted by Kevin Shaw on Tuesday, November 30, 2021

Hello Kevin,

Thank you for your email. We appreciate you taking the time to bring this to our attention and have passed this information along to the appropriate team for consideration.


Apple Accessibility

Well, at least it's on someone's desk. I tried. they're going to get another one from me about another issue shortly.