locked items in trash folder, but there's nothing there to say whether it's locked or not.

macOS & Mac Apps

Hi all, so I wanted to install some apps to the Mac applications folder through disc images, but I came across a weird alert in Mac OS Catalina that says there are locked items in the trash. Here's the kicker: when I go to the trash, there's like ZERO, zilch, zippo, no files in the trash at all for me to unlock. What is happening here and how to fix this? I'm trying to install a zip archiver but have to open it from its original image thingy because I can't get it into the applications folder without having that alert thingy. Anything to get started with this would be good.
Beth, AKA Denverqueen



Submitted by KE7ZUM on Sunday, October 27, 2019

Have you tried a sudo rm -r path/to/app and see if that works? Do this very slowly as you cannot go back and only use this as a last resort.

Hi, I have not tried this. Sounds like a weird terminal thing I haven’t experimented with, but yeah, I will need a step by step on how to get to that part. I’ve never typed in terminals even when I was using Windows, so it seems a bit intimidating, but I’d be willing to give it a try.
P.S. What does the RMR thing actually do?

Submitted by KE7ZUM on Monday, October 28, 2019

The rm stands for remove, or something like it. I'm sure that someone can actually say what the full abbreviation is. The -r flag is for recursive. You might need to sudo to do it though. I'm not exactly sure. By the way this will not move the item to the trash. Once it's gone it's gone for good. I wiped a whole folder this way by accident so be very very very careful.

Submitted by Clayton Jacobs, A.K.A. Blind… on Sunday, November 3, 2019

Have you tried just emptying the trash? That should resolve your issue. Besides, you don't usually need to go into the trash folder if you have discarded something, unless you accidentally discarded something you didn't intend.