Linux Ubuntu on Mac

macOS and Mac Apps


My college course is coming to an end and I'll be starting a networking and security course at university next, and we will be using Linux quite a lot apparently. I'm not sure of anything specific we'll be using yet, but I'm just trying to at least get to know the basics of Linux as I've never used it before.

I've just downloaded the latest version of Ubuntu from the official Ubuntu download page, and created a virtual machine using Veertu desktop. From what I've read, there is a screen reader in Linux called Orca, and this can be enabled at the installation screen by pressing alt+super key+S when you hear the bongo drums sound. I've heard the sound, but can't work out what keys to press on my MacBook Air keyboard to get it working. I've tried command+option+S, command+control+S and even control+option+S using the pass through command so it didn't interfere with VoiceOver, but none of them seem to work. Any help on the keyboard layout would be appreciated.

Thanks very much.



Submitted by Carlos Taylor on Friday, March 24, 2017

Are you using VMware Fusion? Fusion maps the super key, AKA windows key, to the command key. So command+option+s should be the correct keyboard shortcut.

Submitted by Callum on Friday, March 24, 2017

No, I'm using an application I heard about called Veertu Desktop, it does pretty much the same as VMware fusion but is free, and it all looks fully accessible so far. I tried that shortcut though and it didn't work. Does voiceover have to be turned off once a virtual machine is started?

Submitted by Carlos Taylor on Friday, March 24, 2017

You might check to see if that product maps the windows key to to the command key. IYou can also try turning off VoiceOver just to see if that helps, but I don't necessarily have to turn it off in VMware Fusion, however, I sometimes do especially when I need to use the 0 on my numbed as an insert key for NVDA or WinEyes. I have a full usb mac keyboard for my iMac at home.

Submitted by Callum on Friday, March 24, 2017

I've just looked it up and Veertu does map the Windows key to the command key, so I'll try with voiceover off when I get chance and see if that works. If not then I might see if it will run <a href="">Vinux</a&gt;, although I've heard it's not as accessible as they make out.

Submitted by OldBear on Saturday, March 25, 2017

I'm not really impressed with Vinux in place of Ubuntu, it will be always out dated. I suggest going with the Gnome desktop rather than Unity, but your mileage may differ.

Orca isn't as adjustable as Vo or NVDA etc, but it meets my needs. My favorite is the Mate desktop on an Arch Linux system, but that would be for if you really get into Linux.
Good luck.

Submitted by JDawg on Saturday, March 25, 2017

Club AppleVis Member

overtime I try to enter the control option s key, Mac OSos bonks at me, whether VO is on or off. any ideas? this is an installation of ubuntu.

Submitted by Callum on Saturday, March 25, 2017

Are you using a virtual machine or have you actually installed Linux onto your Mac? If it's a virtual machine, you could try moving the mouse pointer into the virtual machine window, press VO +command +F5. You might also need to click into it by using VO +shift +space

Submitted by JDawg on Sunday, March 26, 2017

Club AppleVis Member

doing VO f5 and pressing VO space to click into the window, I was able to do control command s when I hear the drum sound but I still get no orca either. however if it's any consolation, I've booted into the OS image and still can't do it then either. an ideas?

Submitted by OldBear on Sunday, March 26, 2017

I don't use Macs, so I'm not sure if this would work or cause problems. Would you be able to borrow a Windows wired USB keyboard from someone and plug it in the Mac just to see if the Ubuntu image is working?

Submitted by Callum on Monday, March 27, 2017

JDawg, have you tried command option S as well? I believe the option key is mapped as the left alt key.
To make things more interesting, I tried installing Vinux and the screen reader works, I get passed the language screen fine, but then a screen comes up with 2 checkboxes. One of them is "download updates while installing", and the other is about installing third party software, and it doesn't matter which one of these boxes I check or even if I check both of them, there's no continue or install button, just a quit button and a back button. I've tried leaving it for a while in case it was doing something else, but there was no change.

Submitted by Halison Junior Lunardi on Monday, March 27, 2017

I found the following info in that article:

Surprisingly, Veertu doesn't let you use your Mac's Command key as the Windows key in a Windows guest, so you'll need to click on the Start menu in the guest when you would normally use the Win key. I found the same problem in Linux guests. This is fairly serious limitation for anyone who relies on the keyboard.

Submitted by Callum on Monday, March 27, 2017

When I looked it up, I found <a href="">this post on the Veertu forums</a> which mentions that the Windows key is now mapped to command. That's confusing :)
If it doesn't map any key to the Windows key, is there any way we can change that?
Regarding the comment about trying a Windows keyboard, I'll give it a go if I can find a spare one, I think I have one somewhere.

Submitted by Halison Junior Lunardi on Tuesday, March 28, 2017

The problem is the Windows key shortcuts, because the start menu can access also with ctrl more esc

As for the Orca, I believe you can also start it with alt more f2 and write "orca", without quotes.

Can starting Orca with alt +F2 and then typing "Orca" be done on the installation screen, or would I have to get sighted help it install the OS before I can do that?