Issues with TextEdit on El Capitane

Forum
macOS and Mac Apps

Hello all:
I recently upgraded to El Capitane and am faced with the following issues in TEXtEdit:
1) The behavior of the arrow keys (without VO keys) is erratic.
2) VoiceOver suddenly stops speaking characters.
3) VO + A to read text from the VO cursor, stops reading mid way.

Is anyone experiencing these issues? Are there any workarounds? Resetting VOICeover sometimes helps with Issue #3.

Thanks,
mani

Options

Comments

Submitted by mehgcap on Friday, December 4, 2015

Member of the AppleVis Editorial Team

I'm sorry to say I haven't experienced any of those problems, and I use Text Edit almost daily. I'm not sure what to suggest, but I can tell you that those aren't bugs in OS X.

Submitted by Mohammad Aldalain on Friday, December 4, 2015

Not sure if this is similar to what you are having with yours, but here sometimes when QuickNav off moving using the up arrow and down arrow is terrible, it announces characters not lines, and it works just when I switch QuickNav on and then back to off again. Also if you have QuickNav on, CMD+down it does not move to the end of the document. It is so frustrating especially when you are reading books with 300 pages or more. Still this is not happening all the time, and I am not sure if there is anything I can do to reproduce the problem.

Submitted by Seanoevil on Friday, December 4, 2015

Hi,

Since upgrading to El Cap I have experienced similar bugs with VO, except that in my experience they are not limited to the Text Edit App.
I commonly have the bug where typing echo and curser movements no longer announce characters. When this happens, VO sound Effects also cease working. This may occur in any Text Edit field, most notably the Night Owl Twitter Client. When this occurs, it can be corrected by turning VO on and off.
I also experience a problem where VO arbitrarily skips reading paragraphs in a page of text. <Move the curser back and past the unannounced field a second time and it will read it as normal. The only indication that VO failed to read the paragraph is that the VO sound effects still work. And, of course, your text probably doesn't make complete sense,.
I use the high quality Karen voice, but experienced the same problems with the Lee voice as well.
I reported these problems to Apple, who promptly told me that they were unable to reproduce them and that perhaps I needed training. Like it's so difficult to press the down arrow and have VO read text...

Sorry not to have better news.

@SeaNoEvil00

Seanoevil, you are right on your observation. It happens in Mail too. Voiceover does lose her voice periodically. I use Tom for my voice if that makes any difference. I noticed the erratic behavior of the arrow keys happens almost consistently when I switch between documents in TextEdit using Cmd + ~. I also noticed that the VO cursor does not move with the movement of the app and down arrows, sometimes.
It looks like something is broken. Yosemite did not have these issues.

Thanks,
mani

Submitted by Ekaj on Saturday, December 5, 2015

I've experienced this too, but only with VO sounds enabled it seems. I've tried a few voices and they all seem to have this issue in El Cap on my end too. But then again I was experiencing speech issues prior to El Cap as well. Something's messed up with my memory and while I did clear some disk space on here by removing some of the bigger voices and such, I still don't have nearly as much free gb as I did when I first got this Mac. But anyway, turning off VO sounds seems to have made somewhat of a difference on here. This speech issue seems to occur with both my internal speakers and the external ones that I was recently given, but again only with the VO sounds enabled. I'm wondering if the speech issue and the memory issue on my end are related? Just a thought.

Submitted by Seanoevil on Saturday, December 5, 2015

Hi,

I just noted that I somehow truncated my own post above and deleted the final paragraph which said that I use the Lee and Karen High Quality Voices and have reported these bugs to Apple.
The Bugs happen with both my Bose External USB speakers and the internal speakers. Toggling the Keyboard Echo does nothing. I like Keyboard Sounds enabled, so haven't tried working for long periods with them disabled. On my current setup, Audio Ducking is also enabled.

Apple have replied stating that they are unable to reproduce these problems.

With regards to it being a memory problem, I hope not. I run a fairly high end MacBook Pro with 8gb of ram and not very much saved to the HD.

HTH

@SeaNoEvil00