"Interactive Help" Window Appears To Be Keeping Me From Using My Macbook Pro

macOS & Mac Apps

I bought my Macbook Pro from its original owner, who reset it to factory defaults.  When I tried to configure the unit to work well with VoiceOver, I somehow found myself confronted with a window that announces, "Interactive help Window Open." If I move the up or down arrows I hear "Window Close,", then "Window open" as i press the up and down arrow keys.  The "open" or "close" state changes like a toggle.  I have no idea what this is, and had been using the computer to post messages in Nightowl before I found myself replying to the wrong message, and tried to make sure cursors were routed correctly.  This window appears as soon as I turn the computer on, and I can't seem to move past menus without hearing this message announcing that window is open or closed. I would appreciate any ideas about this. I made a recording which I shared with Twitter. I can provide the Dropbox link if anyone wishes to hear this. I can make another recording, as some might find the music in the background to be disturbing. I would appreciate all help.  There is no Apple store closer than forty miles from here, and I have no local friends using the Mac.  If necessary I can get a ride to Fresno, California to the nearest Apple Store, but I'm hoping this is some minor issue that can be solved once I know what's happening. Thanks very much in advance.  



Submitted by Pam Drake on Wednesday, July 15, 2015

This is my first post to AppleVis; and I hope I have expressed the situation clearly. I can barely explain it to myself!

Submitted by mehgcap on Wednesday, July 15, 2015

First, to clarify, can you use the Mac in any way, or does this window prevent normal operation? Second, when you got the Mac, had it been reformatted and had a clean install? If not, I'm wondering if there's a hotkey setting that's catching your arrows. Head into System Preferences > Keyboard > Shortcuts Tab. In the first table, go through the categories one by one (start with Dashboard) and make sure no item is bound to an arrow key by itself. Many will be control-arrows, but check that nothing is set to work with an arrow key sans modifiers.

Submitted by Pam Drake on Wednesday, July 15, 2015

I don't know whether there was a clean install or return to factory setting, but I unintentionally set a password I couldn't remember, and so did a re-install of Yosemite. I did post to Twitter using Night Owl after the yosemite re-install. Oh yes, Nd I did update Yosemite last week when I discovered an update listed in the appropriate menu.

I have the Mac with me now. The menu I see reads: "Help, two items. Search resultSearch: search result, interactive. Sometimes the number of items increases from two to three, depending on whether I interactive with the menu, which I've done on occasion just to see if I can break out of this mode.

I can move through menus, but as soon as I try to function within the menus, such as mocing through menus or toolbars, I will come upon this help menu. If I continue to try to function it will eventually put me into a help command menu. Where I used to navigate with just arrow keys, I now need VO, no matter what the position. When I'm on the desktop, I press up or down arrows, and there's not-so-good ol help! It's there, in fact, when I start the computer and am on desktop. I'd hate to have to re-install Yosemite again, but if all else fails I suppose I can do it.

Hope this makes things clearer.

Submitted by Pam Drake on Friday, July 17, 2015

Here is a link to the recording I made last week in which I attempt to demonstrate my problem. I probably should have lowered the volume on my ever-present music, but I hope someone will be able to get an idea of what's going on here.

Also, in response to Mehgcap's suggestion, I tried to get into the system preferences menu, even searching for Dashboard, but I could not avoid the searches.

Here is the link to the Dropbox file: "What Am I Doing Wrong With My Mac.mp3

Submitted by mehgcap on Thursday, July 16, 2015

I'm curious about something. Press vo-k (control-option-k). VoiceOver should go into 'keyboard help' mode, where it will announce every key you press and, if it's a VO command, what it does. Once in this mode, press your arrows, each one by itself. Make sure that down arrow says "down arrow", and so forth. It almost sounds like your key mappings are way off, which seems like a very remote possibility. Yet, I can't come up with a better explanation, at least not without being in front of the machine myself. Let me know what the results of that experiment are; hopefully it will tell us something.

Although the exercise proved to be a good review of VO keys and commands, there seems to be no problem. All keys were announced as expected.

I wonder if an update would help or make things worse, or is there a ride to Fresno in my future? Are we out of ideas?

Oh well, if anything weird is going to happen, it will happen to me!

Submitted by mehgcap on Friday, July 17, 2015

Have you considered a reset of the PRAM? Doing so may help, though I admit it's a long shot. As explained in this Apple Support article, you shut down the computer, then hold down command, option, p, and r as you boot up. You'll hear the startup chime, but keep the keys pressed until that chime sounds for a second time. The article warns that this could reset some of your system preferences.

Submitted by Pam Drake on Saturday, July 18, 2015

I tried the reset several times, managing to get a seconds chime to ring only once. It did not remove the unwanted help window, and I didn't check to see if any preferences were reset. Today I was unable to get the chime to ring a second time with the attempted reset, no matter how many times I tried. I did notice myself in the Notifications window, and decided to restart the computer, the default setting in the prompt. The other was "cancel", which I had tried earlier to no avail. When I rebooted, the same ol' help menu was there. I'm once again wondering whether I'll have to restore the computer again, or if a software update would help, or make things worse. If I have to restore Yosemite, is there a way to get a copy without having to go online and wait the ten hours for re-installation? As I ask the question, I'm wondering if that's possible, given the fact I have not use the computer enough to have created any backups yet. Itd may be necessary to go to the Apple Store in Fresno after all, as I have no local friends, blind or sighted, who know the Apple platform. I do appreciate Mehgcap's suggestions, and would appreciate more if he or anyone has them.

Submitted by mehgcap on Sunday, July 19, 2015

Updating is certainly possible, as is re-installing. The only way to not wait is to get Yosemite onto a thumb drive (a process known as creating a bootable drive or recovery drive). You do need the Yosemite installer to do that, though, which means downloading. The advantage is that you'd only need to download once instead of for every install attempt. It may indeed be easiest to take the machine to an Apple Store if at all possible. I wish I could help, but I'm on the other side of the country. Of course, if anyone else has any ideas, do please chime in!

Submitted by Pam Drake on Sunday, July 19, 2015

He says he believes this help window has something to do with troubleshooting startup problems. I had thought of calling Apple Accessibility, but he suggests I call Apple Care, as he doesn't believe this is an accessibility issue. I figure O'll call start with Accessibility, and see what they say, and whether I need to talk with them, with Apple Care, or take it to Fresno.

Thanks to Uber and Lyft, the trip to Fresno is about half the cost it would be in a cab. That's still about $50 or so each way, but it beats $100 each way. I'm still keeping my options open, and remain open to suggestions. When I make a mess, I make it big!

Unlike the first time I had to re-install Yosemite, I now have a WIFI connection to the computer, so will not have to get help from an Apple rep via Facetime as I did the first time. If I decide to download and keep a copy of Yosemite, will I be able to locate the correct location on Apple.com? Also, all my thumb drives are formatted for Windows; so will I need to format, or buy a new drive?

Submitted by mehgcap on Sunday, July 19, 2015

If you make a recovery disk, you will need to reformat it beforehand. Needless to say, this will erase all content on the disk. You'll also need at least 8GB free. The process is pretty straightforward, but you'll need to do the formatting and setup on the Mac. You may want to get sighted help for this only because VO seems to not like you at the moment.

Submitted by Pam Drake on Monday, July 20, 2015

Although none are particularly enjoyable, I now have some options thanks to your help.

It may be worth the time to do a long install, then make a recovery disk from a happy MacBook with VO intact. I'm not sure whether my geographically closest friends have ever done a format. Is there a menu choice? Where do I find it; or is it obvious if I just look at the website? Perhaps this window won't be distracting to a friend. Perhaps I'll end up going to the Apple Store.

In any event, thanks so much; and I'll let you know what happens, as the information may be helpful to someone else.

Submitted by mehgcap on Monday, July 20, 2015

Google will have full details on the process, but you'll essentially go to the App Store and download Yosemite. Once you do that, the installation window will appear; quit it, then follow the steps in the guide you find. The key is to use the App Store to download Yosemite, then not complete the installation but rather use the downloaded OS to create your recovery disk.

Submitted by Pam Drake on Saturday, July 25, 2015

In reply to by mehgcap

Well, I contacted Apple Accessibility about my Mac Help mode Interactive" problem yesterday. The message is so aggressivethat it would not allow me to share my screen. Try as we might, I could get into a sharing session, but the "help interactive" window took control of the screen every time. Neither could I boot into safe mode and activate VoiceOver, though the advisor said he has seen it happen.

He called back this morning and tried to set up an appointment for me at the Fresno store, but there are none available! If he hasn't been able to do so by about 2:30 this afternoon, he's going to help me do another Yosemite restore. He says he thinks there's a third party app causing the trouble but I told him the only one I've used is Youru. Could that be it? I don't think I've even installed any other apps. Be that as it may, if no one can see the screen to know what's going wrong, it's a moot point. There is no one sighted nearby who can tell the advisor what's on the screen.

I'll post more when I know more.

Submitted by Pam Drake on Wednesday, August 19, 2015

After a call to the Accessibility folks at Apple, I attempted to share my screen with the rep, only to find that the "Search Status" Interactive" window, as I remember it, so covered the screen that sharing was impossible, no matter what we did.

This left us no choice but to restore/reinstall Yosemite. This time I could not use FaceTime as I had done originally. The Supervisor would not permit the rep to connect with me in this way, probably because it was late on a Saturday afternoon, and probably very busy on the floor.

Instead, I emailed photos of the screen to him as the installation continued. Eventually we were sure the installation was in fact taking place, and I allowed it to proceed till I heard the Apple startup chime and the prompt to start VoiceOver.

I have installed Night Owl again, and so far it is working well. As I have had issues with my phone and other life details, I still haven't done as much work with the Mac as I would like, but it appears to be fine now.

I only hope I don't have any more cursor problems leading to the reappearance of the dreaded Interactive Help window. I'm sure there's a reason for it, and did find it once and shuddered. It did behave itself, so I hope my problems are over, at least for this round.

The people at Apple have been most helpful; and the use of FaceTime and mailed photos have made it possible for me to repair issues remotely on the computer. I only wish my experiences with the phone were this positive, but hope the problems, discussed in another topic, will be resolved when I go to the Apple Store on this coming Thursday.